Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Nojus2001

Possible to get Skype 8 up and running on XP?

Recommended Posts

Posted (edited)
1 hour ago, Mathwiz said:

Took a look inside; AIUI, the add-on is basically nothing more than a SSUAO:

general.useragent.override.web.skype.com = Mozilla/5.0 (X11; Fedora; Fedora; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

So you might try that on NM 28. If it works try it on NM 27. Edit: Sorry; I meant try that on MyPal.

nah same result as using my Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36 , ends up in that startup_load_error unfortunately.

 

1 hour ago, Dave-H said:

Have you "lost" any of your contacts on Skype 7?
I noticed a week or so ago that one of my contacts had reverted to "Messaging disabled until request is accepted" and says that they haven't shared contact details with me.
This is nonsense as I've been exchanging messages with them for months, and they still appear as an active contact on my Android phone app, and on my copies of Skype 8!
Just today I've noticed that another of my contacts has dropped off Skype 7 in exactly the same way, so I'm wondering if they'll all now go one by one!
If I message them from another Skype version the new messages still appear in Skype 7, but I can't reply there any more.
:dubbio:

mhm, not exactly... but something similar has happened to me:

basically all of the contacts i already had have not dropped but 2 of my most recent contacts that i think use the phone app or at least definitely not the pc versions are as if they require "accepting" when i know for a fact they are accepted (coz they are fine on the 'for web' version)

so i assumed those 2 latest one are due to the phone app and old pc version mix/issues or what not, but i did not have old contacts going in that mode suddenly... weird to hear

 

p.s. - that is exactly why i am so sad about the "skype for web" thingy... i don't have skype on a phone nor use phones for anything other then u know, talking lol (yeah im one of those that don't bother with phones for anything other than talk or the rare text)

and skype for web was my solution to those contacts that appear to "require accepting" even if i know they are 100% accepted and talked to already. because via skype for web i was able to message those :\

Edited by Leifman

Share this post


Link to post
Share on other sites

31 minutes ago, Leifman said:

nah same result as using my Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36 , ends up in that startup_load_error unfortunately.

My apologies; apparently it takes (at least) two SSUAOs:

2 hours ago, Mathwiz said:

Took a look inside; AIUI, the add-on is basically nothing more than a SSUAO:

(Edit: My apologies. Apparently it takes at least two SSUAOs! Sneaky devils)

general.useragent.override.skype.com = Mozilla/5.0 (X11; Fedora; Fedora; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

general.useragent.override.skypeassets.com = Mozilla/5.0 (X11; Fedora; Fedora; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

Try those on MyPal.

When you browse web.skype.com, the add-on changes your user agent, but keeps it changed for every site connected to thereafter, so there may be more I haven't discovered yet.

Share this post


Link to post
Share on other sites
36 minutes ago, Mathwiz said:

My apologies; apparently it takes (at least) two SSUAOs:

When you browse web.skype.com, the add-on changes your user agent, but keeps it changed for every site connected to thereafter, so there may be more I haven't discovered yet.

yeah adding the other one and having those two doesn't change the end result unfortunately...

at least u got some progress and understanding of the addon, but i guess the fact that it keeps it changed + every other one connected to it is the factor here that we can't replicate to fix it on the lower firefox versions

i doubt it is a "windows xp" thing when with the addon it works on firefox 50 but with just spoofing as it always worked it gets that error thingy on mypal (firefox 27/28) as that addon can't do some insane magic that is nu-reproducable

regardless thanks for the attempt!

Share this post


Link to post
Share on other sites

We just have to identify all the other places Skype connects to. It can't be that many....

Incidentally, why doesn't the add-on load in NM 28? It identifies as FF 60.9 in Firefox compatibility mode....

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Mathwiz said:

When you browse web.skype.com, the add-on changes your user agent, but keeps it changed for every site connected to thereafter,

... Not what the extension author claims, BTW:

rOyus6m.jpg

22 minutes ago, Mathwiz said:

why doesn't the add-on load in NM 28? It identifies as FF 60.9 in Firefox compatibility mode....

... Elementary, my dear Watson! :P The addon is of the Web Extension type (since hosted on AMO currently), as such won't install/work in Pale Moon and forks...

(NB: Screengrab was taken with latest Serpent 52.9.0; it has a default SSUAO for AMO

general.useragent.override.addons.mozilla.org;Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.9) Gecko/20100101 Firefox/52.9 )

Edited by VistaLover

Share this post


Link to post
Share on other sites

Well, I added one more SSUAO (for live.com) and Web.Skype.com works just fine with Serpent (with no add-on) but not with NM 28.

I wonder if there's some obscure pref that needs to be toggled for NM 28 to work?

Share this post


Link to post
Share on other sites
9 minutes ago, Mathwiz said:

I wonder if there's some obscure pref that needs to be toggled for NM 28 to work?

Perhaps they're checking whether the browser is WebRTC enabled? Serpent does support it, whereas New Moon doesn't...
WebRTC is, of course, required for audio/video calls, it shouldn't be required for simple messaging, but what do I know...??? :lol:

  • Like 1

Share this post


Link to post
Share on other sites

That was a really good suggestion! So I tried disabling WebRTC by toggling media.peerconnection.enabled in Serpent to false.

Unfortunately, Web.Skype.com still signed me in just fine, so I guess that wasn't it after all.

I'm afraid I'm stumped on this one.

Share this post


Link to post
Share on other sites
52 minutes ago, Mathwiz said:

Well, I added one more SSUAO (for live.com) and Web.Skype.com works just fine with Serpent (with no add-on) but not with NM 28.

I'm afraid I'm stumped on this one.

New Moon 28 has a default SSUAO for "live.com" that flags it as Firefox/52.9 (Pale Moon):

general.useragent.override.live.com;Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.9) Gecko/20100101 Firefox/52.9 (Pale Moon)

OTOH, Serpent doesn't have this by default :P; did you in fact modify the above SSUAO in NM28 to:

general.useragent.override.live.com;Mozilla/5.0 (X11; Fedora; Fedora; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

??? :dubbio:

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/23/2019 at 5:14 PM, Mathwiz said:

Skype Web works even though you admit you're on WinXP?

Earlier reports said you had to lie & say you were on Windows 10

Sure it does. At least on Chromium.

https://preview.web.skype.com/

(I'm using a VPN, so I've hidden the IP address). Anyway, this is what I'm using to spoof my Chromium 54 as Chromium 75:

"C:\Programmi\Advanced Chrome\chrome.exe" --user-agent="Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3732.0 Safari/537.36"

4ce37g0.png

 

Of course, calls don't work as the extension and the MSI fail to install. I don't know why you are all having so many issues... I've never tried it with Firefox, though, but on Chromium it has always worked flawlessly and I'm reporting my real OS: Windows XP as the last thing on earth I wanna do is to make the Win10 net market share larger.

Edited by FranceBB

Share this post


Link to post
Share on other sites
10 hours ago, VistaLover said:

New Moon 28 has a default SSUAO for "live.com" that flags it as Firefox/52.9 (Pale Moon):

general.useragent.override.live.com;Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.9) Gecko/20100101 Firefox/52.9 (Pale Moon)

OTOH, Serpent doesn't have this by default :P; did you in fact modify the above SSUAO in NM28 to:

general.useragent.override.live.com;Mozilla/5.0 (X11; Fedora; Fedora; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

??? :dubbio:

Yes; I changed it to the latter UA in NM 28 and added the same UA to Serpent. (I wanted them to be as similar as possible.) And in Serpent I can sign on to web.skype.com fine, but NM 28 gives me the same sign-on error as the OP gets with MyPal.

7 hours ago, FranceBB said:

I don't know why you are all having so many issues... I've never tried it with Firefox, though....

Web.Skype.com works fine in FF 48+ (with the aforementioned add-on) and Serpent (with the aforementioned SSUAOs), as well as Chrome of course. But NM / MyPal are lighter-weight browsers that run better on the OP's PC. I was trying to help because I suspect that's a common situation.

7 hours ago, FranceBB said:

... the last thing on earth I wanna do is to make the Win10 net market share larger.

Well, I doubt they estimate market shares based on UA's reported to skype.com, since that would be a very biased sample. ("How about that; 100% of the users of this Micro$oft site that requires Win 10 are using Win 10! Surprise, surprise!") So even if you did have to report Win 10 to skype.com, you could still report XP to everyone else.

  • Like 1

Share this post


Link to post
Share on other sites

Well, for now the only solution for me is to use it on a chrome (that is spoofed to latest version) coz then at least the skype for web is useful or rather usable (and not a slow mess)

I guess the "why" one can't get it to work on Mypal/palemoon is a mystery hehe

Share this post


Link to post
Share on other sites

Try the string I use in my NM28:

 

general.useragent.override.web.skype.com -----> Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

Share this post


Link to post
Share on other sites
4 hours ago, Sampei.Nihira said:

Try the string I use in my NM28:

 

general.useragent.override.web.skype.com -----> Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36 

nope. and no "useragent string" of any other will ever change the startp_load_error

it is not a simple fix as putting a different useragent. the useragent is fine as it detects it as "possible to run" (meaning it doesn't say that the browser is not supported)

it's just something specific they changed that affects mypal (palemoon 27/28)

Share this post


Link to post
Share on other sites

Another update from mere seconds ago : officialy the skype program (the latest official 7.36 version available for xp) just died.

suddenly i got the skype sound that i was logged out and i am getting a "Sorry we couldn't connect to skype. please check your internet connection and try again" crying smile with 'retry' doing nothing.

i guess they officially killed their latest working program version on XP :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...