Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Tihiy

OldNewExplorer 1.1.9

Recommended Posts

Is it with KB3000850? Any clear reproduction steps?

 

The bug has been around since the beginning at least from what I remember. Certain Windows don't have the glass on the navigation bar even with the option selected.

Share this post


Link to post
Share on other sites

Tihiy is there any news on the glass area bug in some open windows. It seems to not work at times and requires me to re-enable glass on the nav area.

 

This might be an interface bug with O-N-E itself?  Seems that you can actually check all the sub-options below "Use command bar instead of Ribbon" without having that parent option checked:

 

post-315582-0-46611100-1417820608_thumb.

 

In that case most of the sub-options will actually take effect (!?)  But a "Ribboned" window will not show the "glass on navigation bar", even with "Minimize the Ribbon" enabled (most likely because the Ribbon object is preventing that from happening).  Note in this screenshot that the other sub-options (Hide caption text, Hide caption icon, etc.) are still in effect:

 

post-315582-0-01164100-1417820627_thumb.

 

Personally I prefer the flexibility of the other "sub-options" actually working independently of the Ribbon being enabled or disabled.  I would like to see all of those options un-indented in the config GUI to indicate this fact.  But (based on what I understand about how the Ribbon affects Glass) I believe that the "Enable glass on navigation bar" needs to remain a sub-option of "Use command bar instead of Ribbon" and needs to be unchecked and grayed out when the parent option is not enabled.  (Edited to correct that last sentence!  :blushing: )

 

More on the effects of the Ribbon on Glass and blur here: http://www.msfn.org/board/topic/170850-aero-glass-for-win81-131/?p=1090261

... and here: http://www.msfn.org/board/topic/170850-aero-glass-for-win81-131/?p=1090263

Edited by PeterMS

Share this post


Link to post
Share on other sites

I just noticed that the Install/Uninstall buttons are actually invoking C:\Windows\SysWOW64\regsvr32.exe to register/deregister both OldNewExplorer32.dll and OldNewExplorer64.dll.  If OldNewExplorer64.dll is truly 64-bit then shouldn't it be handled by C:\Windows\System32\regsvr32.exe?

Share this post


Link to post
Share on other sites

I just noticed that the Install/Uninstall buttons are actually invoking C:\Windows\SysWOW64\regsvr32.exe to register/deregister both OldNewExplorer32.dll and OldNewExplorer64.dll.  If OldNewExplorer64.dll is truly 64-bit then shouldn't it be handled by C:\Windows\System32\regsvr32.exe?

I believe this because not all explorer windows are opened in a 64 bit process so both 32bit and 64 bit must be enabled.

Share this post


Link to post
Share on other sites

Can this feature be included?

 

This is Address Bar remover. When it is running, explorer windows have no Address bar (Navbar, Rebar).

 

The executable is attached, and here is the AHK source code:

#NoTrayIcon#NoEnvGui +LastFoundhWnd := WinExist()SetControlDelay, -1SetBatchLines -1DllCall( "RegisterShellHookWindow", UInt,hWnd )MsgNum := DllCall( "RegisterWindowMessage", Str,"SHELLHOOK" )OnMessage( MsgNum, "ShellMessage" )ReturnShellMessage(wParam,lParam) {If (wParam = 1 ) ; HSHELL_WINDOWCREATED := 1{WinGetClass, WinClass, ahk_id %lParam%if (WinClass = "CabinetWClass") {ControlGetPos, ,y1,,ha,ReBarWindow321, ahk_id %lParam%SendMessage, 0x0082,,,ReBarWindow321, ahk_id %lParam%Control, Hide,, WorkerW1, ahk_id %lParam%Control, Hide,, ReBarWindow321, ahk_id %lParam%ControlGetPos,,y2,,h1,ShellTabWindowClass1, ahk_id %lParam%ControlMove, ShellTabWindowClass1,, y1,,y2-y1+h1, ahk_id %lParam%ControlMove, ReBarWindow321,,,,0, ahk_id %lParam%WinSet, Redraw,, ahk_id %lParam%Sleep, 100SendMessage, 0x0082,,,ReBarWindow321, ahk_id %lParam%Control, Hide,, WorkerW1, ahk_id %lParam%Control, Hide,, ReBarWindow321, ahk_id %lParam%ControlGetPos,,y2,,h1,ShellTabWindowClass1, ahk_id %lParam%ControlMove, ShellTabWindowClass1,, y1,,y2-y1+h1, ahk_id %lParam%ControlMove, ReBarWindow321,,,,0, ahk_id %lParam%WinSet, Redraw,, ahk_id %lParam%Sleep, 100SendMessage, 0x0082,,,ReBarWindow321, ahk_id %lParam%Control, Hide,, WorkerW1, ahk_id %lParam%Control, Hide,, ReBarWindow321, ahk_id %lParam%ControlGetPos,,y2,,h1,ShellTabWindowClass1, ahk_id %lParam%ControlMove, ShellTabWindowClass1,, y1,,y2-y1+h1, ahk_id %lParam%ControlMove, ReBarWindow321,,,,0, ahk_id %lParam%WinSet, Redraw,, ahk_id %lParam%Sleep, 100SendMessage, 0x0082,,,ReBarWindow321, ahk_id %lParam%Control, Hide,, WorkerW1, ahk_id %lParam%Control, Hide,, ReBarWindow321, ahk_id %lParam%ControlMove, ShellTabWindowClass1,, y1,,y2-y1+h1, ahk_id %lParam%ControlMove, ReBarWindow321,,,,0, ahk_id %lParam%WinSet, Redraw,, ahk_id %lParam%}}}

h_1416749644_6681554_abfce282f0.png

 

But I think it would be better to add such feature as a checkbox.

 

P.S. I have updated the script (November, 1015)

Edited by Anixx

Share this post


Link to post
Share on other sites

I just noticed that the Install/Uninstall buttons are actually invoking C:\Windows\SysWOW64\regsvr32.exe to register/deregister both OldNewExplorer32.dll and OldNewExplorer64.dll.  If OldNewExplorer64.dll is truly 64-bit then shouldn't it be handled by C:\Windows\System32\regsvr32.exe?

 

I believe this because not all explorer windows are opened in a 64 bit process so both 32bit and 64 bit must be enabled.

 

Yes I do understand that principle, just don't understand why the 32-bit regsvr32.exe is being used to register the apparent 64-bit DLL.  I believe the proper way to register the different bit-ness parts would be like this:

C:\Windows\SysWOW64\regsvr32.exe <PathTo>OldNewExplorer32.dllC:\Windows\System32\regsvr32.exe <PathTo>OldNewExplorer64.dll

???

 

(Edited to remove spurious switch for regsvr32.exe)

Edited by PeterMS

Share this post


Link to post
Share on other sites

No longer Works on Windows 10 build 9901


 


doesnt change anything and metro apps stops working


Share this post


Link to post
Share on other sites

 

No longer Works on Windows 10 build 9901

 

doesnt change anything and metro apps stops working

 

 

Old-New-Explorer was no longer compatible since the 2nd preview build (Which I remember it being 9860), and then the last Tech Preview build for Windows Insiders (which is 9879).

 

Windows Insider participants won't get a new Tech Preview Build release until 2015 when Windows 10 hits Consumer Preview. Build 9901 is a very early build of the Consumer Preview.

Edited by DoubleSAnimations

Share this post


Link to post
Share on other sites

Thanks for this wonderful piece of sotware.

I find old explorer much quick and productive to work with.

Detail pane to the bottom is a real life saver for me. :)

Share this post


Link to post
Share on other sites

Having an apparent issue with this tool in Windows 8.1, specifically with the preview pane. I have no idea why, but whenever I have this tool installed, images will occasionally stop loading midway, fill up with various shades of purple and green, or sometimes won't even load at all (in a few cases, the thumbnail for the image even glitched as well). I found that rotating the image a few times will eventually fix this, though the problem often returns after restarting the computer.

 

I haven't run into the glitch at all when having this program uninstalled, and when I tried the old shell32 details pane mod, the same problem occurred. I don't get why it's happening, since no one else has apparently reported it and I don't get why a details pane mod would cause problems for the preview window, but it's incredibly annoying for me to work with. Does anyone know why it might be happening?

Share this post


Link to post
Share on other sites

wait, what? no way, i installed and it's not hiding the ribbon, i'm on 9926 build too, x86

Share this post


Link to post
Share on other sites

Same here, not working, it does still work with some of the options but ribbon does not hide nor does it show the details pane at the bottom.

Share this post


Link to post
Share on other sites

can you maybe add an option for Win7/8 to make the favorites alignment similar to Vista where it was pinned on top and always accessible?

Share this post


Link to post
Share on other sites

I wonder if it might ultimately be possible to restore a reasonable Alt-Tab view to Windows 10...  Replacing the entire screen with rearranged smaller views of the windows I have open...  Maddening.

 

-Noel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...