Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Woes installing 98SE on new 80g WD HD

Recommended Posts

I just confirmed the drive is 'Advanced Formatted', and from what I understand that means 4k instead of 512b...


With so many used and new normal HDDs, how in heavens did you find a 4k sectored one?

Yes, I think it may be a show-stopper. Let me think about it some more. I have to go now, but I'll be back later tonight.

So, for the moment, either get a normal HDD or stand-by and do nothing, please, until my next post.

Link to post
Share on other sites

The WD utility will wipe anyway enough data, at the minimum first and last million sectors:

You don't actually need to 00 out anything but the first (say) 100 sectors.

Anything else is overkill, including the WD utility and ActiveKill disk.

If you want to completely wipe a disk use the secureerase utility:


that will use the internal ATA commands and will be faster than *any* software based solution.


Comeon :), you know better than suggesting to wipe a whole hard disk, and WHEN this is needed, to suggest anything but the internal ATA commands.... :whistle:

We have at least one report:



that a "same" 250Gb drive took 85 minutes vs. around 210 (using DBAN)

It yould be interesting if you could do a comparison test of the ATA command and Active Kill Disk (dos extender) on any "spare" disk you may have handy.

JFYI, a carpenter's comparison ;):



The "advanced format" does NOT apply to your drive:


as you can see you have 156,301,488 sectors, which multiplied by 512 makes roughly the 80 Gb.

So that drive has "standard" sectors, not the "advanced format" 4 Kb ones.

Some disk drives may have a jumper, but I don't really think that an 80 Gb one has them.

WHERE exactly did you learn that your disk is "advanced format"? :unsure:


Link to post
Share on other sites

Post a picture or a scan of the HDD's label. You can put it in the scanner, if you have one, with cover open and just scan it, but take care not to look that way, while the scanning is in progress, because the light may hurt your eyes.

Link to post
Share on other sites

if you take 4,096 and divide it by 512 you get 8. The drive is 80gigs. FDisk and all other partition manager software pre-2001 report is as a 10gig.

After reading how a 4k HD gets mangled by 512 software and partitioning.. I have deduced the drive is in fast a 4k drive.

Installing W2k or XP... the drive is properly seen and handled as an 80gig.

Installing *anything older* and the drive is seen as an 80gig, but handled as a 10gig.

One of the times the drive was mangled, but still booted, I tried to access various files across various partitions. The partitions 'looped' into phantoms. And media files being accessed would on occasion cause VFAT errors.

So long as I only accessed the first 500ish megs on the hard drive, it all seemed okay except for cosmetics in My Computer. The first time I accessed D;\ it worked fine, but the 2nd time it said the disk wasn't formatted.

In the beginning, I suspected partition damage somehow, so I got into the habit of copying over 2 gigs of mp3s and about half a gig of videos to test it with. Looking at my notes, I can safely conclude the files that 'nerfed' the drive were all beyond the initial 500megs of the drive. Sometimes the copy would 'just work', other times it would only get so far in and BSOD VFAT.

another member PM'd me the post link I reposted earlier... and after reading their entire story and the WD white papers... and some basic math... I do believe the drive is using 4k clusters internally, while the OS I am attempting to use is interacting with the drive as if it uses 512b internally.

A previous poster shared a link about LBA and BIOS stuff. Thank you very very much, as this was a great primer for the deducing required to reach my conclusions. The page gave me an understanding of how a drive head of 4096 size could mangle a track written in 512 size. Hard to explain that idea properly at this time... but it does explain every single thing I have seen happen, in a nice, tight little package all at once.

And for the record, this IS the thing that changed in hard drives in the last 5 years.

Edited by DeadDude
Link to post
Share on other sites

Oh yeah, one of the FIRST things I did was use the WD life thingy to zero out the first 100 megs and last 500 megs... or reverse that...

it was MUCH faster.

I ain't taking another step (no 0'ing) until the 4k thing is sorted...

Standing by, Capt'n!



Link to post
Share on other sites

Western Digital had a program, called "Data Lifeguard Disc Tools", for installing their disk drives. The software came in both DOS and Windows versions. More recent versions of their hard drives now come only with installation software by Acronis, which software requires at least Windows XP. But Data Lifeguard appears to be still available, either from Western Digital or from third-party download sites (such as MajorGeeks or Softpedia). For Western Digital, try here: http://www.wdc.com/wdsearch/?sc=&sl=en-US&sq=data+lifeguard+98se&x=0&y=0 .

I believe the Data Lifeguard software runs on any hard drives, providing either the old drive or the new drive is any Western Digital. I also noted Data Lifeguard versions which run on either PATA of SATA hard drives.

To try Data Lifeguard, set up your old 40G drive as drive C. Set up your new 80G drive as an additional drive. Install Data Lifeguard (it will install under Windows in Drive C). Run Data Lifeguard to format your new drive and copy the operating system and data from the old drive to the new drive. After installation, switch cables and jumpers, as necessary, to make your new drive "Drive C". Then reboot.

You may be having issues with your Master Boot Record (MBR) for 98SE, which is possibly not being written properly by your other methods. Data Lifeguard, in copying an original 98se hard drive, should fix the MBR.

Edited by rilef
Link to post
Share on other sites

found out my cam is useless... LoL

here's my attempt at copying all text data for ya to inspect.

PATA / 8MB Cache


S/N: WCAV3E898896

MDL: WD800AAJB - 00J3A0

WWN: 50014EE1AF077CA2

DATE: 18 AUG 2011


DCX: 9009JES38

5VDC: 0.65A

12VDC: 0.50A

R/N: 701596

Circle with arrow splitting it in half


C backwards R U us


KCC - REM - WDT - 1596

Fragile symbol of broken glass

trashcan with 'x' over it

ecs in tiny print bottom right corner of label

bar code next to plug, on bottom of drive:

2061-701596-A00 19R

about 5 spaces away from that is:

XC 8G17 05NH 9 005060 2065

greenboard on bottom of hard drive has the following printed:





in a box:


in green print at edge:

2060-701596-001 REV A

The bottom of the drive, the 'motherboard' appears to be lacking a LOT of components. I realize this doesn't have to mean anything at all... but this is the first drive that appears to be lacking an entire chip that I have seen. Place is labeled "J2"... so it makes me think Jumpers... but whatever... blah blah.

Hope I posted the bits you were interested in!

Link to post
Share on other sites

Humor me...

Find and download Hex Workshop (trial available) OR HDHacker.

Hook BOTH drives up and boot the GOOD drive.

Using EITHER tool, read Sector 0 of the PHYSICAL drive of the problem-HDD

Hex Workshop will ONLY read as many bytes as the BIOS indicates (unless it's boogered). HDHacker should ONLY show roughly 4-5 lines of data. This SHOULD be about 512b.

That model is an 80-gig and I sincerely doubt it has "Advanced" sectors (also pulled the specs). NO WAY (as jaclaz said)!!!

Jumper settings -


Place is labeled "J2"... so it makes me think Jumpers...
Jumpers should be on the END where the CABLES hook up. You DID say (P)ATA and you have indicated as much in your (markings) post.

Is the BIOS set to AUTO for the HDD? Have you got the "limiter" jumper on HDD? Set the jumpers ONLY like the document says.

Bottom line... you are doing something wrong...

Link to post
Share on other sites

I just confirmed the drive is 'Advanced Formatted', and from what I understand that means 4k instead of 512b...

does that mean I'm dead in the water?

Is RPM 'advanced format' aware?

It looks like I messed up the drive majorly from using utilities/partitioners/etc that aren't 4k aware....?

Does any of this make sense to someone out there? I thought a low level format would place a 512b format and remove the 4k?

Whether the internal Sectors are 4K or 512B is not an issue here. It will only affect performance.

4K Logical Sectors would be a major issue, but are only used in USB Drives larger than 2TiB.

Standard tools and software can be used without problems. Special tools are only needed if you want the Hard Drive to run faster.

Link to post
Share on other sites

jaclaz *is* right (of course, as always!): HDDErase is faster than Active KILLDISK. The latter remains useful when one wants to zero out just some parts of a HDD, but HDDErase is way faster for a full disk wipe, and the results are equivalent. Now, that said, here's what a WD Advanced Format Drive looks like:


Your 80 GB does *not* have the phrase "Advanced Format Drive" anywhere on its label, hence it uses 512 byte sectors.

That said, you may proceed as per my original instructions, but using HDDErase instead of Active KILLDISK, in the first step. HDDErase also is a DOS program, so very little has changed in those instructions. You can proceed, as agreed.

Link to post
Share on other sites

Actually on the thread DeadDude found (actually NOT that one, but near it ;)) :


there is an interesting report.

An advanced format drive (even if "internally" has 4 Kb sectors) should expose outside a 512 byte one.

The XP alignment issue is seemingly only EITHER:

  • jumper 7 and 8 -> add a fake sector so that XP Disk Manager starts first partition on sector 64 instead of 63
  • Advanced WD format -> simply a "modified" partitioner that uses multiples of 4 x 512 as addresses

The thingy on VIsta :ph34r: or 7 is not needed as they will anyway normally start at 2048.

This is consistent with the "scarce" literature available and with "common sense".

It would be interesting to try partitioning such a drive under Vista :ph34r: or 7 with the Registry patched to respect cylinder boundary. :unsure:

The thread reports the fact that - probably due to a mis-configuration in the factory - the particular drive talked of there does not "expose" the right sector size.

So it seems like this is possible, though I find very queer that it happens on such a smallish (for today's standards) disk size as 80 Gb.

I would try contacting WD support, as what Deaddude bought was a disk with 156,301,488 sectors (of 512 bytes each).

In the meantime can't you simply test BOTH RPM and Partition Logic and report which geometry they recognize?


Link to post
Share on other sites

alright, I zero'd it out.

I ran WD lifeguard

Used it to make partitions.

Loaded RPM.

RPM says Unknown IPL

I zero'd it again.


Still Unknown IPL ????!!

Using it to create primary partition as I type this.

After partition created, RPM formatted it.

Now, RPM says "Standard IPL"

Going to add 2nd partition next... and if that appears fine...

I am going to try the install to this drive...

NOTE: RPM **IS** user friendly. All options labeled on-screen. Lots of power at fingertips. Seems very simply to use. VERY simple.

maybe toooo simple...? :P

great find, wish I knew about it sooner!

Link to post
Share on other sites

NOTE: RPM **IS** user friendly. All options labeled on-screen. Lots of power at fingertips. Seems very simply to use. VERY simple.

maybe toooo simple...? :P

Apparently YES :ph34r:, if you expect to have an IPL right after having Zeroed out a disk..... :whistle:

The disk is ALL 00's->the IPL is all 00's-> it is an "unknown" IPL (does it makes more sense now?) ;)

Can you post WHICH drive geometry RPM finds?

You know, like in :angel :

In the meantime can't you simply test BOTH RPM and Partition Logic and report which geometry they recognize?


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...