Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Legolash2o

win6x_registry_tweak

Recommended Posts

Hey guys, thanks for this tool. I just ran it on an online win10 system to remove defender and other packages. The tool runs, messages its removing packages, then exits but the list of packages from the /l command shows Defender etc. still there. What am I missing? Thanks.

Share this post


Link to post
Share on other sites

I thought I'd make a friendly request here for someone to compile the latest version of install_wim_tweak to run on .NET4(.6). This way, one shouldn't have install an entire .NET runtime on Windows 10 in order remove a couple of components.

 

Done. Check the first page.

 

The only thing I did was to download the source, change .NET version in project properties and build :)

  • Upvote 2

Share this post


Link to post
Share on other sites

 

I thought I'd make a friendly request here for someone to compile the latest version of install_wim_tweak to run on .NET4(.6). This way, one shouldn't have install an entire .NET runtime on Windows 10 in order remove a couple of components.

 

Done. Check the first page.

 

The only thing I did was to download the source, change .NET version in project properties and build :)

 

Fantastic, thank you so much! :)

Share this post


Link to post
Share on other sites

Hi

 

I used this tool to get rid of Cortana from my Windows 10 Pro and it worked fine. The method used was from this thread here:

 

http://superuser.com/questions/949569/can-i-completely-disable-cortana-on-windows-10

 

It got rid of three packages and after a reboot, it was done.

 

However, if I want to re-install Cortana later, how do I go about doing it please?

 

Thanks.

Share this post


Link to post
Share on other sites

Just keep doing updates it'll come back.

 

That's not particularly 'helpful'!

 

I was hoping for something more technical than sticking a wet finger in the air and hoping the wind will blow in the right direction.

 

What I've done so far is taken the Win 10 installation files (from the Win 10 USB update tool), converted the install.esd to install.wim and navigated to the 'sources\install.wim\Program Files\WindowsApps\' folder, but there's no sign of Cortana there to re-install, so not sure how to proceed?

 

Any suggestions please?

 

Further edit:

 

I found it under:

 

X:\sources\install.wim\Windows\SystemApps\Microsoft.Windows.Cortana_cw5n1h2txyewy\

 

How do I re-install it from there, please?

Edited by MrWhatever

Share this post


Link to post
Share on other sites

Why go through all this trouble? If you wanted Cortana then you should have kept it, failing that AFAIK then you are going to have to reinstall windows 10.

 

Just experimenting, that's all. :)

 

I didn't realise it was a permanent deletion of the package at first. But, I don't want it anyway.

 

However, all knowledge is useful, and it would be useful to know how to re-install things like this if for example my daughter's laptop were to have stuff removed that she later wanted putting back.

 

Reinstalling Windows 10 seems like using a sledgehammer to crack a nut.

 

There must be an easier way to re-install single packages?

Edited by MrWhatever
  • Upvote 1

Share this post


Link to post
Share on other sites

Feature Request :)

@Legolash2o: Is it possible 'install_wim_tweak' to export particular componenets in a separate folder or as packed CAB files? (something like 'SXS_Extractor')?

Share this post


Link to post
Share on other sites

 

 

I thought I'd make a friendly request here for someone to compile the latest version of install_wim_tweak to run on .NET4(.6). This way, one shouldn't have install an entire .NET runtime on Windows 10 in order remove a couple of components.

 

Done. Check the first page.

 

The only thing I did was to download the source, change .NET version in project properties and build :)

 

Fantastic, thank you so much! :)

 

 

Thank you sir. I downloaded code myself and was looking at fixing but too many other things. Especially removing Cortana +1. No more 3.5 except for a few other programs I have. Is that the latest source also?

Edited by maxXPsoft

Share this post


Link to post
Share on other sites

I experienced a strange bug when storing the wim-file and the mount folder on a RAM-drive created by ImDisk on Windows 10 x64. Install_Wim_Tweak supposedly runs through successfully, removing the specified packages in the process, but in reality no packages are removed and no errors are reported. I didn't experience any issues when all files were located on my SSD. I somehow have the feeling that it's a path issue due to the way IM implements the RAM-drive, but then Install_Wim_Tweak should at least throw some errors.

 

Anyway, thanks for this tool. I found it to be very useful :)

Edited by Xiaopang

Share this post


Link to post
Share on other sites

I experienced a strange bug when storing the wim-file and the mount folder on a RAM-drive created by ImDisk on Windows 10 x64. Install_Wim_Tweak supposedly runs through successfully, removing the specified packages in the process, but in reality no packages are removed and no errors are reported. I didn't experience any issues when all files were located on my SSD. I somehow have the feeling that it's a path issue due to the way IM implements the RAM-drive, but then Install_Wim_Tweak should at least throw some errors.

 

Anyway, thanks for this tool. I found it to be very useful :)

I have same experince, but in my scenario I have added (dism /enable-feature) NETFX3 and after that I want to remove some components with 'install_wim_tweak', and 'install_wim_tweak' output just 'OK' without numbering removed components as 1/1 or 4/6 and so on...

Share this post


Link to post
Share on other sites

I switched to SoftPerfect's RAM Disk which solved my problem with Install_Wim_Tweak not properly removing packages. It's quite a bit slower, but apparently more accurate. I'd still prefer IM due to its painless implementation and higher speed, so any bugfix for Install_Wim_Tweak would be very much welcome. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...