Jump to content

How to install Windows from USB- WinSetupFromUSB with GUI

Recommended Posts

So Setup ignores boot order and honors on what channel they are connected on. Similar behavior should be when installing from a CD too.

Using XP Setup Boot CD for Install of XP on second harddisk gives in fact the same problem.

XP bootfiles are made on first harddisk and Bootsector is changed into NTLDR-type.

Only the arcpath in boot.ini made on first harddisk is now correct referring to booting Windows from rdisk(1).

Using USB_XP_Setup.exe to make $WIN_NT$.~BT folder and XP bootfiles on second partition of second harddisk (HD 1),

ensures that TXT-mode is NOT making bootfiles on first harddisk (HD 0) and that BOOTMGR-type BootSector of Windows 7 is kept unchanged. The XP Setup Source is in folder XP3_911 on USB-stick being HD 2

Interesting in this case is the $winnt$.inf file in which floppylessbootpath has defined setting as:


In that case the second partition of second harddisk has also the correct drive letter C: in the drive listing,

whereas for Install from CD and the small ISO USB-boot were giving drive letter C: to the first partition of first harddisk,

allthough in all cases the BIOS Boot priority was such that second harddisk was set as first HDD boot device.

But the question remains:

How to trigger that TXT-mode is behaving for Install from CD and the small ISO USB-boot correct as to make the XP bootfiles on the Install Drive on second harddisk, when this is set in BIOS as having the highest boot priority.

Edited by wimb
Link to comment
Share on other sites

What seems strange in $winnt$.inf? I find it perfectly normal.

The active partition on the boot disk (rdisk(0)) gets first drive letter C:, and hard disk numbering is according to disk drivers and bus enumeration, not ARC path, ignoring BIOS boot order or which was the boot device. \device\harddiskX\partitionY numbering differs from the ARC path, we would have been so lucky if it doesn't ;)

If you map hd0 to hd2, hd2 to hd1 and hd1 to hd2 all should be fine. But this is workaround, not a proper solution. We cannon know in advance what user intentions are in order to do similar mapping. It could be covered in readme, or message box.

I am more interested in putting USB disk as last HD, or even hd21, shifting all internal one position up, and go with the default behavior. Will play with this once I figure out why on some machines USB disks do not get drive letters at start of GUI, this is priority and I haven't stopped working on this.

And yes, doing all this from some kind of PE has some advantages, but we talked about the limitations many times, not going in that subject again.

Link to comment
Share on other sites

Well i downloaded the last version and tried to install my winxp sp3 English version, everything fine until the first reboot after copying windows files , it gave me this error HAL.DLL missing , and i can't even enter the first menu where we choose wich step to take

It boots the pen and goes straight to the error : HAL.DLL missing

Any ideas why ?

Link to comment
Share on other sites

Was that 0.2.3 version or 1.0 beta?

If 0.2.3- Did you move the FIXED/REMOVABLE radio button? WinSetupFromUSB.log file in program directory would be helpful. Zip it and attach it with your reply.

If 1.0 beta- how many internal disks do you have?

Link to comment
Share on other sites

Change this in winsetup.lst on USB stick root:

map (hd0) (hd1)
map (hd1) (hd0)

on both places


map (hd0) (hd2)
map (hd1) (hd0)
map (hd2) (hd1)

Change also

chainloader /I386/SETUPLDR.BIN


cat --locate=rdisk(1) --replace=rdisk(2) /I386/TXTSETUP.SIF
chainloader /I386/SETUPLDR.BIN

Replace grldr in root with grldr from this archive:


Try installing again.

On which disk are you installing Windows?

On the partitioning screen which one of the internal disks is numbered first and which one is second?

Added: When you do the above changes start the program again and select only syslinux option, press GO and ignore the warning about NTFS. This is to put back grub4dos MBR.

Do you have a USB card reader as well on that machine?

Link to comment
Share on other sites


I'm trying to build a multiboot 16GB usb flash disk..

But always get som errors..

First I tried just to boot grub4dos from it, and make that loading a Windows 7 iso.

That worked fine, until where I select what type of windows 7 I want to install..

It asks for a cd-rom device driver.

Then I tried to boot a winpe image, and then start 7 setup from that, and then it worked for 32 bit, but not 64-bit.

And after a little more searching i found this topic here :)

And instead of trying this on my flash disk, I iused a 160GB usb disk.

I partitioned it to 4 partitions, and installed norwegian xp pro sp3 and windows 7 32-bit (english, norwegian and litauian) on first partition, and 64 bit win 7 on second partition.

It started just fine with grub, but I still get the "missing cd-rom device driver" when I try to install windows 7.

I used "WinSetup-1-0-beta4" to partition, format, install grub, and install windows on my usb drive.

Link to comment
Share on other sites

Ja9, I think it has something to do with your source. Is it original?

I've had the same issue until used the original Windows 7 which came with the laptop, no more "missing device driver" errors.

Link to comment
Share on other sites

Ja9, I think it has something to do with your source. Is it original?

I've had the same issue until used the original Windows 7 which came with the laptop, no more "missing device driver" errors.

My images is from the MSDN site, I only have deleted the ei.cfg (so I have all versions instead of just Pro) file from the iso's, and added norwegian and litauian lang-packs.

They are both working from dvd disc, and I have also used one of them from usb once (that time I used microsoft's program, or something else to make the flash drive bootable).

Link to comment
Share on other sites

I have no other clues, Vista/7 setup move to USB is quite straightforward, nothing is changed or added to the source. Either way should work as the others, the only difference is how BOOTMGR is launched, but it should not matter, or maybe does ? :unsure:

Link to comment
Share on other sites

Ok, then I try agian.. but this time on the flash drive.

This is what I do:

Run WinSetupFromUSB, select the flash drive, run "Bootice", Perform Format.

Then I select USB-HDD mode (mutli partition).

There I make 2 partitions this time.

1: 11288MB (NTFS)

2: 4000MB (NTFS)

3: 0MB

4: 0MB

(So I can use the first one as windows 7 32-bit + some image files, and the last partition as windows 7 64-bit).

I then click "Process MBR", and selects Grub for DOS, and click "Install/Config", and "save to disk", and then i go back and click "Process PBR", selects Grub4DOS.

After that I install Windows 7 32Bit to first partition, and Windows 7 64-Bit on the other partition.

After this is done I'm goin to thest the flash drive and see what happends.. will update this post or someting when I'm done ;)

If anybody can see something wrong in what I'm doing, please correct me :)

Link to comment
Share on other sites

I don't think Windows 7/Vista will see the second partition in case of removable drive, such as your USB stick. You are limited to the first partition, unless you "flip" the removable bit using the appropriate manufacturer tool, but this is another story.

To stay on the safe side, first try with a single partition only, not multipartition, while partitioning in BootIce.

Link to comment
Share on other sites

Ok, I found out that now.

The files got copied to the second partition instead of the first one.. for some reason..

In my computer I only see one partition, and that is the letter K:, and is the second partition..

But in Disk management I se both, but something is really wierd there.. This first partition is letter K: and the secon one has no letter, and I can't assign one.

So.. My computer reports that K: is about 4GB (second partition) and disk management reports K: as the first partition and about 11GB :S

But as you say, if I partition it as one partiton.. can I have both Windows 7 32 and 64-bit at the same time?

Think i read about it somewhere, that it was not possible.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...