Jump to content

How to install Windows from USB- WinSetupFromUSB with GUI

Recommended Posts

ilko_t, yes I tried. I need IIS on the USB stick, actually.

I tried install from CD, not installed. I saw a "blue screen error" to GUI part of installation. I thought of doing this will solve the problem. (?? If possible GUI part install complate... with this method (select and run GUI part from another apps)...) I can not tell..

because of your software and HOWto notes, now, I have learned to install windows from the USB stick. I can install windows from USB to any netbook. Thank you very much for your help and software.

Link to comment
Share on other sites

First try - After booting up with usb and then selecting "XP Setup", then selecting "First part of XPpSP3 setup from partition 0". It loaded the drivers and as soon as it said it was starting windows I got a BSOD.

I have a Sandisk Cruzer 8gb USB drive - formatted using RMPREPUSB with the following settings:


-Boot as HD (2 PTNS)

-Using the XP NTLDR boot options

Any ideas where to begin trouble shooting?

Link to comment
Share on other sites

What's the error code on the blue screen? This is the important part :)

If it is 0x0000007B try the modified ntdetect.com :



I've tried to put "codebox" tags around the log you posted, but weirdly the entire log disappeared. Please when posting such large text, put

[code-box]large text[/code-box]

around it. Remove the dash of course.

Link to comment
Share on other sites

Ok, I now have the ntdetect.com file on my USB and I try it again and now I have an error 19 - cannot mount selected partition.

It comes up with Booting 'First part of XP setup from partition 0'

root (hd0,0)

Filesystem type is ntfs, partition type 0x7

map --mem /Winsetup/XPpSP3.ISO (0xff)

Autodetect number-of-heads failed. Use default value 255

Autodetect sectors-per-track failed. Use default value 63


Error occurred while savedefault

map (hd0) (hd1)

map (hd1) (hd0)

map --hook

root (0xff)

Error 19: Cannot mount selected partition

Press any key to continue

Link to comment
Share on other sites

Try reformatting it with BootIce, FAT32 or NTFS, single or multiple partitions. You'd have to experiment a bit to find out which one works in your setup. There is no "universal" set of settings.

Link to comment
Share on other sites

I got a big stop when trying to use last version (1.0b3) on a french XP. After 1st screen (1line; "1st and 2nd part"), I get to choose 1st or 2nd step, then when I choose 1st step, it stops with (sorry I checked, I have no log at this part of the process)

map --mem /WINSETUP/XP Édition familialeduSP3pourÉdition familiale.ISO (0xff)

Error 11: Unrecognized device string. or you omitted the required DEVICE part which should lead the filename.

I believe this is due to the accent on the E from "Édition familliale" which character does not appear on my Windows Explorer screen (it appears as a little square) in the filenames created on the sticks (both iso and directory).

I had no problem yesterday on the same files with (the much older) version 0.2.1 which is working in a totally different way.

I tried correcting the names and accordingly in Winsetup.lst but I suspect the name of the folder is badly linked somewhere as only the name of the iso is written in the winsetup.lst. Cheers.

Link to comment
Share on other sites

Thanks for this, a few thins have to be corrected, I need Strings section of various other languages to be able to make it compatible.

Please post Strings section of txtsetup.sif.

Added: Attached version should do the trick, just put it alongside the old exe and run it. Please test and let me know. WinSetupFromUSB.log file would be very helpful, along with Strings section from txtsetup.sif.


Link to comment
Share on other sites

this is on the original (hologram) cd before SP3 and other addons/nLite:

wks_id = "Microsoft Windows XP dition familiale"

wks_id_vga = "Microsoft Windows XP dition familiale [mode VGA]"

cancel_id = "Annuler l'installation de Windows XP"

9x_id = "Microsoft Windows"

Problem: it appears differently on my screen (I now see by previewing my post that it also appears differently than when I pasted the text) :huh:


Link to comment
Share on other sites

Not in txtsetup.sif. I found this in Layout.inf

cdname = "CD-ROM Windows XP dition familiale"

productname = "Windows XP dition familiale"


spcdname = "CD du Service Pack 1 pour Windows XP dition familiale"

+this on an other cd:

spcdname = "CD du Service Pack 2 pour Windows XP dition familiale"

You see the "É" doesn't even appear in the text files.

Edited by Ponch
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...