Jump to content

Last Versions of Software for Windows 98SE

Recommended Posts

On 10/28/2022 at 11:29 PM, DougB said:

> I haven't been able to use Ringo's builds on all machines.

Interesting -- i have never had a problem with RamonUn's "Ringo" MPlayer builds. In fact, it's my default "Send To" media player -- by far the most up-to-date MPlayer for Win9x, and it runs on native Win9x (doesn't need KernelEx). Actually, i never had a problem with Sherpya's "MPlayer On Windows" builds either, or Redxii's "Mplayer For Windows" builds... that is, until they went 'beyond' KernelEx.

> I usually use a build from Sherpya. I think r34401 (12-7-2011) is the last to work with Win98.

The final KEx build from Sherpya that worked for me on 'plain' KernelEx (no KExt) was r37199 2014-May-11.

> But the builds from redxii ... when used with KernelEx (default settings). Seems you can use up to r37203 (5-17-2014).

Same experience here.

Note that Sherpya has also released a more-recent ("experimental / unsupported") native-Win9x player (doesn't need KernelEx) build r38116 in late 2018. Search the page for "Win98 SE build":


And if i might add: My all-time favorite MPlayer is MPlayerWW by William Wang. It seems that development has stopped and its website is gone, but the last version was r37356, 2015-Jan-13. MPlayer code is embedded within a nice, skin-able GUI executable. It requires basic KernelEx. This is my system default media player! You can still get it at:


- Doug B.

I have a question. Does the GUI load properly with this player? When I tried similar MPlayers, the GUI's usually failed to load and the playback buttons would often cause a crash.

Link to comment
Share on other sites

Some Sherpya build versions, earlier than I have listed above, have a GUI. I don't know which ones, but a couple worked well.

I guess someone should make a cheat sheet, for the Mplayer key controls. Maybe even a tutorial on how to use Mplayer and Mencoder to video chat/screen cast. Ffmpeg and Vlc have some use there too.

The documentation for Mplayer/Mencoder is pretty long. But the key to using it, without the GUI, is the config file and key controls. Then you can just drag video/audio/playlist files over a shortcut to mplayer.exe. Off the top of my head, [ Volume down = 0 up = 9 ] [ Skip 12 seconds backward = <- forward = -> ]  [Skip minute backward = \/ forward = /\ ] [ Fullscreen = f ] [ Pause = space ] [ Framedrop = d ] [ Subtitles = v ] [ On screen display = o ].

I know this has worked in Linux, for aspect ratio. You'd thing it would work with Windows too.

In mplayer\input.conf

F1 switch_ratio 0
F2 switch_ratio 1.3333
F3 switch_ratio 1.7778
F4 switch_ratio 1.85
F5 switch_ratio 2.3

Here is a larger list of keys.

I know this is a lesser reply then you had hoped for. But I mean well.

Link to comment
Share on other sites

> Does the GUI load properly with this player? When I tried similar MPlayers, the GUI's usually failed to load and the playback buttons would often cause a crash.

If you're asking about MPlayerWW, then yes -- the GUI has always worked fine for me (under basic KernelEx).

To hopefully shed further light on your question, remember that the original/traditional MPlayer executable (as in Ringo, Sherpya, Redxii, and Linux from which the Win versions were ported) has no real GUI -- it's a command-line-interface executable (MPlayer.exe) that opens up a separate graphic window in which the media is actually played, and which has a primitive keyboard interface. The CLI window will spit out *lots* of progress messages unless you set "Quiet" or "Really-Quiet" in the config file (or as a command-line option).

The issue that i've encountered with almost-all other MPlayer GUIs is that they're just front-ends that load a separate MPlayer.exe file with whatever additional command-line options. Similar to your experience, none have worked even half well for me -- frustrating. MPlayerWW is different: the MPlayer executable file is *not* called from a separate GUI executable file -- in MPlayerWW, the MPlayer code is integrated right alongside the GUI code in a single executable (exe) file. So never a problem... at least, in my experience. (You can still set up MPlayer default behavior in config files.)

But i fear i'm getting too far off main topic here, as this thread is dedicated to native-Win9x applications, and MPlayerWW requires KernelEx. I do apologize to the list for this. But i did want to address your question.

- Doug B.
Link to comment
Share on other sites

1 hour ago, DougB said:

Sherpya, Redxii, and Linux from which the Win versions were ported) has no real GUI

Some of the early Sherpya releases came with Mplayer's original GUI (gmplayer). I believe others compiled it too. Just can't remember who. It was skinable. I think the default skin was a CyberLink PowerDVD clone.

Link to comment
Share on other sites

  • 2 months later...
  • 2 months later...

I'm looking for a FFmpeg release, newer then Sherpya's 2011, compatible with Win98. But, until then, there is LibAV.

LibAV is very similar to FFmpeg, as it was a controversial fork. The command names are different, but the arguments/options are close.

For example: FFMPEG would be AVCONV (AVCONV -I FILENAME -C:V H264 -C:A COPY FILENAME), and FFPLAY would be AVPLAY.

The last version of LibAV, that works with Win98, is 11.3. However, it was not complied with SDL support (AVPLAY). But that can be fixed, without recompiling, by also downloading 10.1. After extracting both archives, enter the 10.1 "bin" folder > rename "AVPLAY.EXE" to AVPSDL.EXE > copy both AVSDL.EXE and SDL.DLL to the 11.3 "bin" folder, and then get ready to dust off your Hex editor.

You'll also need a copy of LIBGCC_S_SJLJ-1.DLL placed in the 11.3 "bin" folder.

AVSDL.EXE is linked to older LibAV shared libraries. But this is relatively easy to fix, since they are only one version number different. For example, it may ask for AVCODEC-55.DLL, but the new one is AVCODEV-56.DLL. So try to run AVSDL.EXE, then use your editor to search for and rename the missing library (AVCODEC-55.DLL > AVCODEC-56.DLL). There are about five different DLL strings to search/rename.

It may not be necessary to rename AVPLAY.EXE to AVSDL.EXE. I've only done that, since I've only been able to test the 11.3 version with a non-accelerated video driver. For me, it only gives a black screen. The modified SDL 10.1 version worked fine. If you are using a 3D card, with proper accelerated drivers, the 11.3 version might work. Still, renaming allows both options.

I'm not sure how the 11.3 LibAV compares with the 2011 FFmpeg. The date of the files, in 11.3, vary between late 2014 and early 2015. Sadly, I'm not sure if LibAV can capture the Desktop. The 2011 FFmpeg version came out before the Dshow Desktop Capture source commit. Likely neither can be used for capturing the Desktop to video. I think Mencoder, from Mplayer, can do it. I haven't looked into it yet. VLC can do it, but it is slow. Also, there is Virtualdub. But, it doesn't capture, with my video driver.

It seems the FFmpeg/LibAV break, with Win98, happened when people switched to MinGW-w64, for building Win32. If I get around to it, I'll see if I can't budge out a newer FFmpeg or LibAV, with the old MinGW; unless someone points out an already existing one(s).

Edited by awkduck
Link to comment
Share on other sites

  • 3 months later...

Dxirc, is an IRC that works with Win98 (KernelEx). It has SSL, DCC, and handles scripts. I recommend the dxirc-1.30.0-fox-portable.zip package. The intended portable part of the package is useless. The folder you want is "\dxirc\App\dxirc". Once it is save elsewhere, the previously underlying folders/files can be deleted.

The setup.exe package is fine, but it includes both the QT (unusable) and Fox user interface files.

The client is mostly functional. I've had to manually enter custom folder locations (logs, DCC, scripts, etc.). The browse window does not work correctly, but it allows you to manually type your locations. Alternatively, you can open the "dxirc.ini" file, with notepad. The folder locations can be modified there.

The application will also create settings folders/files at the root directory, of the drive you ran it from (\foxrc\dxirc-fox.ini and \dxirc\dxirc.ini). This can be fixed, to some degree.

You'll need a hex editor, to modify "dxirc-fox.exe" and "libFOX-1.6.0.dll".

For "dxirc-fox.exe" you need to search for the string "dxirc.ini" (without quotations).

* = 00 (zeroed out)

Change \*dxirc*\dxirc.ini*AppData to **prefs*\dxirc.ini********

Now "dxirc.ini" will be saved/loaded from the "prefs" folder, from inside the main "dxirc" folder.

For "libFOX-1.6.0.dll", I essentially just prevent the creation of the "\foxrc\dxirc-fox.ini" folder and file.

Now search for the string "USERPROFILE"

Change USERPROFILE*\foxrc to USERPROFILE**foxrc

In my option, the settings saved in "dxirc-fox.ini" are pretty insignificant. You'll probably never notice them being gone. However, it is simple to change back.

If you haven't already, you'll want to adjust your Windows TCP settings. Maybe with TCPOptimizer (ver 3.0.8). If you keep the default Windows TCP settings, things will crawl.

Also, Dxirc does not come with a populated server list. You'll need to add the servers to the list.

Link to comment
Share on other sites

  • 5 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...