Jump to content

Methanoid

Member
  • Posts

    101
  • Joined

  • Last visited

  • Donations

    $0.00 
  • Country

    United Kingdom

Everything posted by Methanoid

  1. Thread is people wanting USB 3.0 controllers working under W2K with USB 3.0 speeds... do they ALL work under W2K as USB 2.0 controllers? All I need is a USB 2.0 controller under W2K (I'm doing virtualisation passthrough and only have USB 3.0 controllers - AMD onboard - I might have a Renesas/NEC controller SOMEWHERE!!)
  2. THANKS.... This really helps with the partition planning. I wasn't aware you could install 2K/XP on non primary partitions but I now know so (I probably forgot, it was 20 odd years ago I last used 2000!). But the Primary partition is still the boot partition and your 2X or XP drive will be drive D or E then? Or can I hide 2k/XP etc from 98 and hide 98/XP from 2K etc? - Your post seems to say I can ;) FYI, this guy reports no issues booting all 3 on same partition (although I take your point about partition sizes - didn't know, just assumed if 98 will be happy with C as 128Gb then 2k/XP will be) I know AROS installs Grub so happy to use that. Grub can do all the hiding of other partitions yes? In summary then is this feasible (install order same also) Primary FAT32 (8Gb prob) with Win98, and boot files for 2K/XP/7/10? How big can I go? Rest of SSD as Extended Vol for Sharing (100-odd GB) - FAT32 I guess Vol for 2K (5GB) Vol for XP (10GB) Vol for 7 (30GB) Vol for 10 (40GB) Vol for AROS (8GB) which installs Grub - https://aros.sourceforge.io/documentation/users/installation.php#installing-aros-along-with-windows-r-dos-r
  3. Hi, appreciate some comments/input please guys n gals! I have some C2D kit and want to use it for retro OS use (not just one). I suspect W98 will be the "harder" but wanted to check some plans before I do stuff to only have to re-do it for lack of planning I have: Gigabyte G33M-S2 (onboard RTL8111 LAN, USB) with 4Gb DDR2 Ram, a selection of CPUs inc Pentium Dual Core, Core2Duo, Core2Quad and Xeon 771 Quad ;-) Geforce 7600 GS 256Mb single slot (also have a GT740 dual slot) Soundblaster Live PCI My intention is to install Win98, Win2K, XP on one FAT32 partition of a 240Gb SSD (probably 20Gb or so), plus Win10, AROS (an Amiga-like OS) and maybe a FAT32 sharing partition. BIOS settings - I'd prefer to use AHCI (so Rloew's patch presumably). I want USB 2.0 enabled. Any gotchas? So first question is around partitioning. I understand W98 has a 128Gb limit but does that matter if I use the first 20-30Gb for its partition? Also I assume due to having an SSD I need to format on a modern OS to ensure partition alignment (W10 or Linux - does it matter?) Random question but does anyone know of a list of Win98 exclusive games or Win2K exclusives? Otherwise I might as well run those in XP. I have a better GT740 spare which is supported in 2000/XP but what would the result in 98 or 98-DOS be - would that make those unusable or would they, like in some retro OS like Amithlon, use the VESA mode and would work and the overall speed boost would compensate for lack of proper drivers? I could fit the GT740 in main PCIE slot (blocks one PCI), SB in PCI and 7600GS in 4x PCIe Slot so have both on hand. Bootloaders - all 3 on 1 partition does work (saw a nice YT video) and AROS installs GRUB, that would boot all OS. Any gotchas to worry about? Installing 98 - any recommended process? I have spare IDE & SATA DVD drives, USB DVD & pen drives. My list of Rudy Loew's patches to apply is likely ● SATA support for Windows 9x ● >4GB RAM support for Windows 9x ● AHCI CD DOS Driver ● AHCI for Windows 9x ● PTCHCDFS - To correct displayed size of DVDs on Windows 9x ● >4GB file support for Windows 9x ● 48 bit LBA support for Windows 9x (HDD up to 2 TB) ● Windows Driver Model (WDM) API Extender PLUS I will need LoneCrusader's INF files for the mobo Given I'd like AHCI and more than 1Gb Ram etc so need patches what's the best process for installation? Format partition to FAT32 on modern machine (as earlier) and copy files to partition ready for install (but they how do I format it as DOS compatible to boot up before installing W98) or do i need a 2nd FAT32 partition?! Some advice as to best process would be great!
  4. Thanks.. I'm also same LAN chipset ;-) And Onboard USB works? If so then all i need add is my SB Live... My 7600 will run with either driver set :-D
  5. Carlos isn't a regular here to reply to PMs. Does anyone know what chipset drivers are needed for P41/G41/G31 chipset family for Win98 and if they allow USB to work also? I have a G33M-S2 (PCIE + 2 PCI slots) so GF-7600 PCIE plus SB Live and either PCI LAN or PCI USB card?
  6. Thanks @cov3rt and @win32 for the advice. I think I am gonna pass for now... Tried installing XP on a Core2Duo box and had so much hassle I thought I'd nLite an XP with unattended setup... and found nLite hates running on Win10 and it so much hassle. Maybe if I find some patched XP and 2K on some warez site I might install but for now my "retro" OS is gonna be Win7 LOL!
  7. Just mentioning for the record I have my original hologram style Win2K CD still but not used Win2K for MANY years. I used to mess with nLite for XP a lot building custom unattended setups etc. Now thinking to have a play again with Win2K and KernelEx etc but there are TOO many options and patches to install! Obviously we'd want to start with an SP4 ISO but I am somewhat surprised we don't have a single (or a few) sources of packs that can be integrated with nLite or similar to build a fully patched ISO. Watched some videos and people are installing pages of patches after SP4 install. I suspect many people who want to run W2K will use multicore CPUs now so thread on that topic is relevant. Just wondering if anyone has done a nice Wiki page or a guide post as to how to assemble that "perfect" ISO ?? I'd do it myself but I really don't feel I have a clue these days....
  8. Thanks guys I have KVMs and I have monitors with multiple inputs. Given I expect to boot into XP 90% of time and Win98/DOS only 10%, I would be happy to use monitor to switch when needed. So, just set BIOS priority to PCI and disable device not needed in XP. @Goodmaneuver your post had me wondering.. is there a reason why I should bother with PCI FX5200 when surely a PCIe card with 10x (or more) performance of that card would be sufficiently quick to make the difference even with a VESA or Std Driver? Do I need an FX5200 for DOS or would a modern (RX570 for example) blow it out of water?
  9. How does it work? ;-) Seriously though, if i have a machine with 2 GPUs, one PCIe for XP and one PCI for 98. If I boot into 98 how do I stop 98 seeing a GPU it cannot use (the PCIe one has no drivers)? If I boot into XP how do I ensure it uses the better PCIe GPU. I am sure I have seen something here about it but I cannot find the right search terms to find the thread.
  10. I didnt know Rudy but I can certainly see (returning here after some years away) that he did a helluva lot towards this community and helping extend the life and usability of older OS's. I found the quoted post when looking for WDMEX guidance. I confess the Readme.txt didnt help me a lot. The TLDR suggests WDMEX helps use 2k/XP drivers on 98 ... Would that allow me to run a more modern GPU for 98?? I can find XP drivers for a Radeon HD4850 which is about 10 years too new on 98's scale so would be great to be able to use that for a range of OS's
  11. Thank you for just what I was looking for... I should visit MSFN more often!
  12. Didnt work for me with IE8 installed.. anyone else?
  13. Thanks, I was beginning to think I'd have better gone back to my SP2 original. Coincidentally I noticed a WMI issue in the Event Log even when I had re-added the WF/ICS service back. So, back to SP2, then SP3 integrate and OnePiece pack. Can I do that in one session or separate only?
  14. Yes, your point is? I choose to use that rather than use my SP2 original as it came with SP3 pre-integrated. Just saved time. No problem. Now, do you have something constructive to add to solving the problem?
  15. I can fix the missing Firewall by this script but I should not need to really.... net stop winmgmt rd /s /q %systemroot%\system32\wbem\Repository rundll32.exe setupapi,InstallHinfSection WBEM 132 %windir%\inf\wbemoc.inf net start winmgmt for /r %%i in (%systemroot%\system32\wbem\*.dll) do regsvr32 /s "%%i" for /r %%i in (%systemroot%\system32\wbem\*.exe) do "%%i" /regserver winmgmt /clearadap winmgmt /kill winmgmt /unregserver winmgmt /regserver winmgmt /resyncperf
  16. Whatever I do I seem to be losing the Windows Firewall. Now that isnt a particular problem in that I have a Firewall in my router but it seems that removal of the service prevents some other things working so I have re-done my install CD so many times trying to get to the cause of this and also a strange bug I have where clicking on the Start button can sometimes cause the machine to partially hang until Explorer.exe is restarted. Any ideas? My Last Session.ini is below [Main] Env = 1.4.9.1 - 2.0.50727.3603.Microsoft Windows NT 5.1.2600 Service Pack 3 Target = Windows XP Professional SP3 - 5.1.2600.5512 - English (United States) [Tasks] Remove Components Unattended Setup Integrate Drivers Hotfixes and Update Packs Tweaks Create a Bootable ISO Options [Components] ;# Applications # Briefcase ClipBook Viewer Defragmenter Games Internet Games Pinball Screensavers WordPad ;# Drivers # Asynchronous Transfer Mode (ATM) Cameras and Camcorders Display Adapters Display Adapters (old) Ethernet (LAN) IBM PS/2 TrackPoint IBM ThinkPad ISDN Logitech WingMan Microsoft SideWinder Modems Multifunctional Portable Audio Printers Scanners SCSI/RAID Serial Pen Tablet Sony Jog Dial Sound Controllers Tape drives Toshiba DVD decoder card Wireless Ethernet (WLAN) ;# Hardware Support # Brother Devices Gravis Digital GamePort Iomega Zip drive Multi-port serial adapters Ramdisk Smart Cards ;# Keyboards # Albanian keyboard (AND ALL EXCEPT UK English!!) Zulu ;# Multimedia # Music Samples Tablet PC ;# Network # MSN Explorer ;# Operating System Options # Manual Install and Upgrade Tour ;# Directories # DOCS ETH0 SUPPORT VALUEADD ;# Compatibility # Compat01 Compat02 Compat03 Compat04 Compat06 Compat07 Compat08 Compat09 Compat11 Compat13 Compat14 Compat16 [KeepFiles] msconfig.exe [RemoveFiles] clock.avi yahoo.bmp swtchbrd.bmp [Options] CABMerge ClassicSetup BlackSetupBack ProfilesDir = "%SystemDrive%\Documents and Settings" TargetPath = "WINDOWS" temp_dir = %USERPROFILE%\Local Settings\Temp AdvTweaks [Patches] [services2] [Tweaks] Boot and Shutdown-Logon Page-Classic Boot and Shutdown-Numlock-On Desktop-Internet Explorer icon-Show Desktop-My Computer icon-Show Desktop-My Documents icon-Show Desktop-My Network Places icon-Show Desktop-Recycle Bin icon-Show Explorer-Add 'Command Prompt' to folder context menu Explorer-Associate additional file types with Notepad Explorer-Change Windows Explorer folder view-Details Explorer-Classic Control Panel Explorer-Disable Prefix: Shortcut to Explorer-Preset Places Bar to-C:, D:, E:, Desktop, My Network Places Explorer-Remove Send To on context menu Explorer-Show Drive Letters in front of Drive Names Explorer-Show extensions of known file-types Explorer-Show Map Network Drives buttons in Explorer bar Explorer-Show Statusbar in all windows Internet Explorer-Disable Download Complete notification Internet Explorer-Disable Internet Explorer link creation Internet Explorer-Disable Market Place bookmark Internet Explorer-Disable Media Player 6.4 created bookmarks Internet Explorer-Disable Outlook Express link creation Internet Explorer-Enable Google URL-Search Internet Explorer-Keep IE URL-History for-10 Days Internet Explorer-Set Homepage-www.google.com Internet Explorer-Set IE-Cache limit to-20 MB Internet Explorer-Set Internet Explorer to accept 10 connects at a time Internet Explorer-Set popup-blocker to high My Computer-Remove Manage from Context Menu My Computer-Remove Search from Context Menu My Computer-Remove Shared Documents Performance-Disable Last accessed Timestamp on files Performance-Disable Optimize harddisk when idle Performance-Disable paging of kernel and core-os Performance-Disable Tracking of Broken Shortcut Links Performance-Speed-up Access to AVI Media Files Performance-Use Windows classic folders / No Tasks Sidepanel Privacy-Remove Alexa Start Menu-Disable and remove Documents list from the Start Menu Start Menu-Disable Highlight newly installed programs Start Menu-Do not use Personalized Menus Start Menu-Hide Search button in Start Panel Start Menu-My Computer-Display as a link Start Menu-My Documents-Display as a link Start Menu-My Music-Display as a link Start Menu-My Network Places-Display as a link Start Menu-My Pictures-Display as a link Start Menu-Remove Help and Support Start Menu-Remove Logoff User Start Menu-Remove Pinned Apps List from Start Panel Start Menu-Remove Search For People from Search Start Menu-Remove Search the Internet from Search Start Menu-Remove Set Program Access and Defaults Start Menu-Remove User name Start Menu-Remove Windows Catalog shortcut Start Menu-Remove Windows Update shortcut Taskbar-Disable Balloon Tips Taskbar-Disable Group similar Taskbar buttons Taskbar-Disable Hide inactive icons Taskbar-Disable Language-Bar Taskbar-Lock the Taskbar-No Windows Media Player-Accept Privacy Statement Windows Media Player-Disable auto-add music to library Windows Media Player-Disable starting with Media Guide Windows Media Player-Optimize fullscreen mode behavior [unattended] UnattendMode = 1 ComputerType = Automatic AutoLogon = Administrator OOBEOff CustomLocales Resolution = 1280x1024 BitsPerPel = 32 bit (True Color) Vrefresh = 60 Hz DisableSRestore MaximumDataStorePercentOfDisk = 12 RestorePointLife = 30 DefaultThemesOff DefaultStartPanelOff DesktopTheme = Windows Classic|Windows Classic style|Normal IISInstall = 2 AutoUpdates = 3 AutoUDay = 5 AutoUHour = 15 AUMinor ProgFilesPath = "\Program Files" [DesktopThemes] C:\WINDOWS\Resources\Themes\Luna.theme C:\WINDOWS\Resources\Themes\Windows Classic.theme [NetAdapter1] connname = "" macaddress = "" ipaddress = "192.168.0.1" subnetmask = "255.255.255.0" defaultgateway = "" dnsserver1 = "" dnsserver2 = "" winsserver = "" netbiossetting = "0" ipxnetworknumber = "00000000" ipxnetworkframetype = "0xFF" [GuiRunOnce] [Drivers] D:\My_Utils\Win Sources\_My_Drivers\USB Apple Mobile Device\USBAAPL.inf,0 D:\My_Utils\Win Sources\_My_Drivers\VGA Radeon (Oct 09)\CX_83739.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Asus ACPI\atk2000.inf,0 D:\My_Utils\Win Sources\_My_Drivers\TV BGT3540_(Pinnacle 3010ix)\BGT3540_6.0.0.49_32bit\BGTCap.inf,0 D:\My_Utils\Win Sources\_My_Drivers\SND SB128_Driver\ctpci2K.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Printer Epson R220\E_DF1AIA.INF,0 D:\My_Utils\Win Sources\_My_Drivers\Intel Chipsets\2008s4el.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Wind VGA\igxp32.inf,0 D:\My_Utils\Win Sources\_My_Drivers\LAN Marvell_Yukon\yk51x86.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Nvidia 9300\SMU\smuc.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Nvidia 9300\SMBUS\nf4sys.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Nvidia 9300\Ethernet\nvenetfd.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Nvidia 9300\Awy\nvawy.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Nvidia 9300\AHCI-SATA\nvgts.inf,BUSDRV D:\My_Utils\Win Sources\_My_Drivers\HDMI Audio (Nvidia) Asrock\nvhda.inf,0 D:\My_Utils\Win Sources\_My_Drivers\TV Pinnacle PCTV 2000i\RoyalTS.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Realtek Card Reader\RtsUStor.inf,0 D:\My_Utils\Win Sources\_My_Drivers\HDMI Audio (ATI)\HDAATI.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Wind WiFi Driver\net8187Se.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Realtek HD Audio\HDA.inf,0 D:\My_Utils\Win Sources\_My_Drivers\Realtek PCIE LAN\Netrtle.inf,0 [Hotfixes] D:\My_Utils\Win Sources\_Addons\01_OnePiece_Windows_XP_Post-SP3_UpdatePack_v2.9.0_ENU.7z D:\My_Utils\Win Sources\_Addons\02_ProgramAddons_dtoolsawx.cab D:\My_Utils\Win Sources\_Addons\03_xable_Full-Unlocker-v1.8.7_addon.cab D:\My_Utils\Win Sources\_Addons\04_ELiTE_AddOn_AcroReadLite92030.7z All drivers are latest available from manufacturers. Likewise the Addons above. I use OnePiece pack for adding WMP11 and .NET 1.1 (although it doesnt seem to install .NET 1.1 at all according to the Javascript response I get when querying in IE8). Apart from the addons above, all other customisation is done by installing via RunOnceEx.cmd (as I was removing addons in case of conflicts). Any ideas?
  17. Links down (or at least the one I tried is) 32bit nForce IDE drivers v9.99.09 mod by Fernando (download link) - not working
  18. http://www.msfn.org/board/index.php?showto...st&p=795493 has info about Reg entry to make Opera the default browser I wonder if anyone knows how to package it with things like customisations - a bit like Jonny Boy's Firefox Addon maker???? I'm getting to think Opera is pretty cool!
  19. RTFM dude.... try an Unattended Install .. there is guide here to do an unattended of JUST the stuff you want. You need ORK.exe
  20. Big time FAIL for me... previous versions worked well (but didnt store status of addons).... this one manages to stop ALL addons from working and I cannot access the options on the addons even though they are allegedly working. Having given up on the idea of having some addons installed but not loaded I am now just looking for an older working version of this. I'm not ungrateful, really. BTW, is there any way to improve the install speed? It takes about 5 mins for FF silent install to install whereas if I did it manually I could do all config and install in around 2.... Is there some strange way it installs? (C2D @ 3.2ghz) EDIT: Rebuilt it again, as far as I can tell exactly the same (well the addons and source install were identical) and it worked fine.... whatever!??!
  21. Is there a way to shrink Frontpage? I just tried with my Office CD2 (Frontpage) and it barfs with error 25003 "MS Office Frontpage setup cannot continue because the installation source has been corrupted" But its quite happy to install as normal - its just OfficeShrink wont work on it (FP2003).... I know I could overwrite my shrunk O2K3 with FP2003 but then I'd bloat it by 300Mb when Frontpage is only 130Mb or less....
  22. I know this is now superceding Mara's Slipstreamer but every time I have used this on an English O2K3 with SP3 and all latest fixes it still finds them all on Windows Update and asks me to re-update...which kinda defeats the object. Is it broken? All I am doing is taking my CD, making an Admin Install, integrate latest fixes and make an unattended MST... and every time same result....
  23. When copying files from your system, it copies all extensions as long as they are one of these places. They are the firefox\extensions folder, the profiles folder and the profiles\extensions folder. The file "extensions.rdf" stores all of the registered and unregistered extensions and there location. If this file is not present when Firefox starts up, it will scan the extensions folder and create a new extensions.rdf file. Currently, Firefox Addon Maker does not copy that file, so it is not present the first time that Firefox is run. Therefore, it creates a new file with every extension being registered. I will add an option to keep that file in future. Or, if you do not want to wait for another update, you can PM me and I will tell you what to do. I can wait (thanks). Its really a great product.. I'm totally a Firefox user now and having a custom installer is just what the doctor ordered. I'd struggle to think of much else you could add to this.. maybe a v1.0 Release should be close?
  24. I'm not sure what you mean. I believe that all extensions are copied into the addon. I would have to look at extensions that are disabled and see if they are being recognized in a new install. I'm pretty sure it only copies installed/active extensions. Ideally I'd like it to copy all and preserve their active/disabled status.


×
×
  • Create New...