Jump to content

Vistapack, 1.6.0 Released


Recommended Posts

4)i am sorry but thats a bug of the revolution pack made by tihiy.

Its out of my hands. Look if the revolutions pack is there in the software panel in the control panel.

Uninstall there if needed.

Actually it's a problem in windows 2000. Checking this option sets the ShellIconBPP to 16-bit, which was the highest value before xp arrived. On the other hand RP works in 32-bit mode and has to force this value into the registry by itself. So leave the checkbox alone (unchecked).

Link to comment
Share on other sites

Thanks for the reply.

1) i made it so that it wont install if you dont have the .net2 installed. Thought that was enough...
Maybe there's a problem with how you're checking if .NET 2.0 is installed. The settings panel got installed even though I didn't have .NET 2.0 installed. Instead, after installation of the Vista Pack completed and after rebooting, I tried to open the settings panel but got an error message saying that I need to have .NET 2.0 for this to work. So it does get installed regardless of whether .NET 2.0 is installed or not. Maybe because I had .NET 1.1 installed? Either way, the settings panel worked fine after installing .NET 2.0. I forgot to mention last time that I tried this in a VM. Maybe that has something to do with it too.

I'll reinstall the Vista Pack to comment on the rest.

Link to comment
Share on other sites

2)The first time you have to save the settings, to be able to load on startup.
OK. That works :)
3)To skin the taskbar, rightclick on your clock and open tclock panel(settings), and there choose to load settings. You will open a window in the tclock dir, and there is a ini file with the settings.

click that and hit ok. that should aply the vista skin.

The VM froze as soon as I hit Apply. I closed the VM window and started it again... It's now freezing a few seconds after login. If I move the cursor in front of the Windows Taskbar, I get this Vista animated graphic for what used to be an hourglass in earlier versions of Windows. 5 minutes later, it's still frozen. Here's a screenshot of what's visible (or what is not)...


Link to comment
Share on other sites

@ tomcat, hi man...

could you please look at the ini file in the tclock dir and check if it needs some adjustments to your language...

that was the reason it hangs, at least for xibad it was so check that out.

translate it and please post it for me so i can include it.

i will attach the new one to this post so make sure to grab it and trans it ok?

thanx for the help man


Link to comment
Share on other sites

Ok I got a coupla issues:

1 - VDrive Doesn't work from your pack because of the way it has been compiled it HAS to be named "vistadrive.exe" otherwise it will get confused and just plain not work right.

2 - Several strings in the sysdm.cpl are still in another lang (German?) makes for a very confusing system properties.

Plus a quick question = How do you get the wallpaper applied during setup? I really need to know this one for myself so if you don't want the public to know would you please pm me with the regstring or script for the wallpaper change?

Link to comment
Share on other sites

damian666, if you do the following in TClock3:

1. Tray/Clock fill tab: set Fill Style to "skin tray"

2. Format tab: check "Custom format" check box and enter "h:nn tt" in the text box below it

3. Full Skinning tab, Clock subtab: set SkinSource to QuickLaunch and Frame to 1

4. Click Apply

Does this fix your clock area so it looks like the rest of the taskbar? You should be able to achieve something like this:


Edited by WildBill
Link to comment
Share on other sites


I'm not really sure what you want me to do with that file. I checked English.ini in the TClock folder and don't see anything language specific. It all seems "internal code" to me and not something I'd get in a dialog window or something. The only thing I'm not sure of is the locale. My system locale is English US, but the user locale is English UK. The ini file here uses 1033 which is English US. Is that intended or doesn't it really matter? I haven't tried changing it to English UK (or to 1043 as in Dutch.ini).

Other than the locale, the only difference between your Dutch.ini and my English.ini is the paths but they seem OK to me.

BTW... In Safe Mode, the system doesn't hang. That's where I was checking English.ini from.

I also noticed that if I use Ctrl-Alt-Del in "normal" mode, I get two "End program" boxes that could be relevant; one is for the TClock program and the other for AutoIT.exe.

Edited by Tomcat76
Link to comment
Share on other sites

@ wildbill, hi man, nice to hear from you, i will check it out.

i do have a skinned trat, but it looks just a bit different, so will try this.

and a question, can i make tclock load the first time with the settings.ini that i want through registry or something?

because now the user has to do it his/her self...

please let me know

@tomcat, well then i will check it out here, there has to be a problem...

the two boxes are for the Vdrive and yes, tclock.

but thats not relevant imho.

so will let you know man


Link to comment
Share on other sites

I just uploaded TClock3 0.3.0, which adds a commandline option:


Where filename is the name of an .INI file (filename only, do NOT specify a path) that is in the same folder as TClock3Test.exe. It will force the program to load the .INI file on startup. The filename should not contain any spaces for it to work.

I haven't tested it, but the code was really simple so go ahead and try it. Look for the TClock3 topic in the Win2k forum to get it...

Link to comment
Share on other sites

Hallo Damian,

nice pack you created for Windows 2000. I´ve used your latest pack from 6.6.2007 on a german Windows 2000 Professional. Here are some bugs i´ve found:

1. In control panel there is another language "Algemeen". It should read in german "Allgemein".

The picture on the left side has false dimensions.


2. In control panel the software panel crashes. 1. Attempt gives an empty window:


2. attempt gives following error message:


3. You changed the icon for logoff but not for exit windows:


4. The new bootlogo was not applied to my system although i activated it in the installer

If i find some other bugs i will post again.


Edited by hpj2
Link to comment
Share on other sites

@hp2j, hi man.

thanx for the bug report, will check out the translation, and the graphics.

but that other thing, well i dont use mshta.exe????

so why would it give that error?

hmm, will check it out thanx.

@ wildbill, thanx for the extra coding man.

i will gladly use that!!!:)

see you guys!


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...