Jump to content

HFSLIP - Test releases


Tomcat76
 Share

Recommended Posts

I normally don't use the RDP client, but while testing KB925876 update mstsc.exe is not replaced by the newer lhmstsc.exe file. This results in that the RDP client fails loading on Windows XP SP2.

fix:

hfslip 1.7.6 changes (line 1980)

ECHO>>WORK\HFSLIPCMDP1.TXT IF EXIST %%SYSTEMROOT%%\SYSTEM32\DLLCACHE\mstsc.exe DEL/Q/F %%SYSTEMROOT%%\SYSTEM32\DLLCACHE\mstsc.exe
ECHO>>WORK\HFSLIPCMDP1.TXT COPY/Y %%SYSTEMROOT%%\SYSTEM32\lhmstsc.exe %%SYSTEMROOT%%\SYSTEM32\DLLCACHE\mstsc.exe
ECHO>>WORK\HFSLIPCMDP1.TXT DEL/Q/F %%SYSTEMROOT%%\SYSTEM32\mstsc.exe
ECHO>>WORK\HFSLIPCMDP1.TXT REN %%SYSTEMROOT%%\SYSTEM32\lhmstsc.exe mstsc.exe

BTW KB952155 contains version RDP 6.1. Might be cool if HFSLIP also supports that version ;)

Edited by Acheron
Link to comment
Share on other sites


The problem I had with the busted OE6 was due to corrupt source.

Now, everything seems to slipstream properly and nothing busted.

However, when I run MU, I am prompted to up KB 898461. It looks like I am not t the only one reporting this anomaly. I also get one High Priority update which is KB 942763. Putting these two files in the HF folder do nothing. HFSlip does not slipstream/integrate these two updates, and I still be prompted to update these 2 updates.

Attached is my log file.

HFSLIP.7z

Edited by kenlau
Link to comment
Share on other sites

Windows Update now wants to see KB898461 on XPSP3, yes.

HFSLIP needs to be updated for this because the update doesn't contain SP3 binaries, but I prefer to make it a test release and wait a few days before making it a final in case it's just an error.

Link to comment
Share on other sites

Windows Update now wants to see KB898461 on XPSP3, yes.

HFSLIP needs to be updated for this because the update doesn't contain SP3 binaries, but I prefer to make it a test release and wait a few days before making it a final in case it's just an error.

What about KB942763? Can I use the pre-SP3 time zone updates you have on the HFSlip site? I never used it, so I am not very sure if I can include it now with SP3.

Link to comment
Share on other sites

@kenlau

The newest version of the HFSLIP time zone plugin is compatible with SP3.

@Neo2x

I removed it from both lists because it isn't shown on Windows Update, but I'll put it back to avoid the confusion.

Edited by Tomcat76
Link to comment
Share on other sites

Regarding KB898461, I let WU install it to see what would happen. WU then asked for a roots update that appears to be from May. Roots Update. This is with SP3, IE7 and hotfixes from the dynamic SP3 list. I am not 100% sure, but I believe this only happened after I started using the latest WU agent. I think the previous version of WindowsUpdateAgent30-x86.exe worked fine, WU did not ask for KB898461. I think I still have the old version and will test.

Edit: WU does ask for KB898461 using the previous version of WU Agent. I did use the roots update I linked to and WU does not for that after installing KB898461.

Edited by krose
Link to comment
Share on other sites

I'm sorry but my problems were due to some problem that hfslip.cmd was never called from svcpack.inf. However the fixes I posted before are necessary to fix the mstsc.exe problem.

Edited by Acheron
Link to comment
Share on other sites

Thanks Tomcat76. You really put some effort in to support XP SP2. Well I am moving to XP SP3 this month a HFSLIP supporting mulitple Service Pack levels is still useful, imagine deploying XP images within companies with a strict upgrade policy.

Edited by Acheron
Link to comment
Share on other sites

The Microsoft Installer has been updated from version 3.0/4.0 to version 4.5, and is available here. Should it work already, or will it need to be added in to the latest beta of HFSLIP?

Edited by jimmsta
Link to comment
Share on other sites

HFSLIP asks me, do i want to overwrite

Source\DOSNET.INF to Sourcess\DOSNET.INF

Source\TXTSETUP.SIF to Sources\TXTSETUP.SIF

WBEMOC.INF too

1.7.9 Final was same too.

I say NO?!

WindowsXP-KB922120-v5-x86-TRK.exe not integrated.

SP3 does not included LLTD

PS: Temp solution for me

Changed all SP2 to SP3 in 922120 hotfix. Files copied, inf entries created.

WindowsXP-KB922120-v5.1-x86-TRK.exe :D

Edited by eryen
Link to comment
Share on other sites

I dont know why but HFSLIP creates DOSNET.INF, TXTSETUP.SIF etc. in SOURCESS folder.

Then Start to copy all SOURCE files to SOURCESS :/

At that moment ask me do i over write files.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...