Jump to content

Maximus-Decim Native USB Drivers


Recommended Posts


Many thanks for the INF update.

I have posted it at my site, here:


File [66 KB, iexpress installer = copies USBSTOR.INF to %windir%\INF]:


I'd like to ask a favor:

Could you please use the INF I posted at URL above [attached below] for all future NUSB updates?

This modified USBSTOR.INF is a little smaller, because I removed all unnecessary spaces.

I also modified this line to read [just like the original USBSTOR.INF from WinME setup CD]:


Please take a look, and let me know if you want to make any other changes.

If you do make other changes, please post here the new INF, so I can upload it at my site.

Thanks in advance.

Best wishes.


Link to comment
Share on other sites

Maximus Decim Native USB ver.2.3

I had v. 2.2 up to now and all devices did work for me, up to 1 GB. :)

Minor problem: for some of them confirming the driver is required,

few clicks, but found automatically, no private drivers.

This thing needs a better webhost: it is too small and to good for

rapidshare !!! :yes:

I have put it on my site, you can download from here:


Hope this helps.

Please update two italian exe (2.3&2.4 versions) allocated in the discussion of my forum.

Edited by Max_04
Link to comment
Share on other sites

  • 2 weeks later...

Rapidshare is...well, I know of a forum where I could say exactly what I think of it. Let's just say a big pain in the seatware. I dread trying to download from there. Anything over a few hundred K might as well forget it

Link to comment
Share on other sites


The nusb23e.exe driver looks like just what I need to allow our Compaq Deskpro EN running Windows 98 SE to read the 128 MB flash drive in a pen (no manufacturer found - made in China) that I received as a gift. However, I can't get it to install on our computer.

Here is the system that I am working with:

Microsoft Windows 98 SE

Compaq Deskpro EN

Intel Celeron, 850 MHz

Motherboard: Intel Solano i815E

USB1 Controller: Intel 82801BA ICH2 ­ USB Controller 2 [b-1]

When I try to install the driver, I get one of the following messages. Is there anything I can do to successfully load the driver?

1) A required resource cannot be located.

2) The ¹¹ package is not compatible with the version of Windows you are running.

3) This program has performed an illegal operation and will be shut down.

If the problem persists, contact the program vendor.

NUSB23E caused an invalid page fault in

module NUSB23E.EXE at 0167:010043e1.


EAX=00000104 CS=0167 EIP=010043e1 EFLGS=00010246

EBX=00000000 SS=016f ESP=0056faec EBP=0056fc34

ECX=00000001 DS=016f ESI=010a4d28 FS=2b3f

EDX=ffffffff ES=016f EDI=17f64d6b GS=0ed6

Bytes at CS:EIP:

80 3f 00 0f 84 9d 00 00 00 6a 00 ff 15 ec 11 00

Stack dump:

00000001 00000000 0100abb4 00000004 00000000 00000000 1d57004d 35cc0000 bff86abb 81817ed0 00000000 bff80a2a 00000004 00000000 00000054 0056fb38

Thank you very much,

Link to comment
Share on other sites

  • 3 weeks later...


Great stuff on this forum, nice to see that some there's still some love por win98. :D

I was wondering if someone could re-upload the usb drivers in Spanish, I've had success using the English ones but I would really like to have them in my mother language.

Thanks a lot! :thumbup

Link to comment
Share on other sites


I'd like just to know if I can Installed Maximus Decim Nativus USB ver 2.2 on my computer.

I had an "Unknow device" (yellow exclamation mark) on the USB controller in the Device Manager. I have only 1 USB 1 and I had a pcmcia Card driver USB2.2

Let me know if this driver only works for USB 2.0

Thanks for your help

Link to comment
Share on other sites


I'd like just to know if I can Installed Maximus Decim Nativus USB ver 2.2 on my computer.

I had an "Unknow device" (yellow exclamation mark) on the USB controller in the Device Manager. I have only 1 USB 1 and I had a pcmcia Card driver USB2.2

Let me know if this driver only works for USB 2.0

Thanks for your help

You need driver for your USB 2.0 controller, NUSB project contains just mass storage driver, not USB controller driver.

Here is the list of known USB 2.0 Win 9x drivers: http://www.msfn.org/board/index.php?s=&amp...st&p=517622

You can identify your USB controller using Everest:

[ Intel 82801FB ICH6 - Enhanced USB2 Controller [B-2] ]

Device Properties:
Device Description Intel 82801FB ICH6 - Enhanced USB2 Controller [B-2]
Bus Type PCI
Bus / Device / Function 0 / 29 / 7
Device ID 8086-265C
Subsystem ID 1462-6250
Device Class 0C03 (USB Controller)
Revision 04
Fast Back-to-Back Transactions Supported, Disabled

the important information is Devide ID and Subsystem ID.


Edited by Petr
Link to comment
Share on other sites

  • 4 weeks later...

Yeah ... the thing is great, all sticks up to 1 GB worked for me so far ... but:

There is a serious BUG resulting in data corruption. :(

Corruption occurs in following situations:

1 (always?): Defragmenting the stick and click "Abort" button. Data is corrupted. Aborting

Defrag on the HD does NOT suffer from this bug.

2 (?): Performing several write/erase/write operations while free space is low (<20%) or

even touches 0.

Link to comment
Share on other sites

  • 2 weeks later...

USB tools here:


* USB Diagnostics Tools (English):

Intel USB System Check (USBREADY.EXE) tool [533 KB]:


Microsoft USB View tool detects current manufacturer USB IDs:


USBVIEW.EXE 5.1.2600.2180 [57 KB]:


Current USB IDs:


Microsoft USB View tool from Windows 2003 SP1 DDK:


USBVIEW.EXE 5.1.2600.1106 [84 KB]:


Intel USB System Check (USBREGED.EXE) tool [556 KB]:


Link to comment
Share on other sites

I played again with Mitsumi USB FDD and I found the solution of the blue screen problem - to use DISKTSD.VXD 4.90.3000 and the old DISKTSD.VXD (4.10.2223) to rename to DISKTSD1.VXD. But not 100%.

Just replacing 4.10.2223 by 4.90.3000 does not work, the system won't boot and in the bootlog appears:

[00151BDA] Dynamic load device  C:\WINDOWS\system\IOSUBSYS\disktsd.vxd
[00151BDA] Dynamic load failed C:\WINDOWS\system\IOSUBSYS\disktsd.vxd : [00151BDA] Not a valid device - possibly corrupt

After installing nusb, inserting the USB Floppy causes blues screen with error in DISKTSD.VXD.

After renaming old and copying new disktsd.vxd I was able to use the USB floppy with no problem.

BTW, in Windows Me everything works fine.

Then I tried to use 98SE2ME, at first the option installing just the USB drivers, second time option 2 - install everything.

In both cases plugging the USB floppy into the PC did not cause the blue screen, but in the device manager appeared yellow exclamation mark and the FDD did not work. The above described procedure with renaming and copying DISKTSD.VXD did not help.

I have shortly looked into the 4.90.3000 code and there are only very few differences in comparison to 4.10.2223 so it is possible that the 4.10.2223 version could be modified to work correctly - but I don't know how.

Has anybody successfully tested any USB Floppy with NUSB? Maybe the support should be completely removed and NUSB should not install its drivers for floppy USB, either in general, or at least for Mitsumi.

There is a driver supplied by Mitsumi, that could be added to NUSB. This driver contains (besides of INF files)

mtmvsd.vxd 3.16.00

mtmusbfd.sys 3.16.00

mtmfdvsd.pdr 3.16.00

Maybe ot could work for other FDDs too?

I will try some additional testing tomorrow.


Link to comment
Share on other sites

Please help: :unsure:

1. Will these drivers work on Dell GX 110?

2. Do i have to remove universal serial bus controller driver before installation?

Thanks in advance for any help.

What do you mean exactly?

nUSB is not USB Controller driver but USB Storage driver.

It is not dependent on your USB controller provided it is supported by your operating system (OHCI, OHCI Controller) or separate driver (EHCI controller).

So you should not remove your USB controller driver, but the USB Storage drivers (if any) should be uninstalled and removed from the system.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...