Jump to content

Maximus-Decim Native USB Drivers

Recommended Posts

Maximus Decim Native USB ver.3.5 and 3.6

See Post #772



Maximus Decim Native USB ver.3.3
*Native (without installation of additional drivers for each type) support USB flash drives, digital photo
and videocameras and other similar devices.
*Universal Stack USB 2.0 (without installation of additional drivers for each chipsets) with uninstall.
1.Remove ALL drivers USB flash drives.
2.Remove ALL drivers USB 2.0 controllers.
3.Remove ALL unknown devices.
4.Install NUSB 3.3 and reboot.
5.After detection new USB 2.0 controllers (if it will occur) too it is necessary to be reboot.
Remember! You install it at own risk!
English: nusb33e
Russian: nusb33r

What's new?
*Add CDVSD.VXD 4.90.3004
*USBSTOR.INF 1.08 - add EKE USB Floppy (VID_0424&PID_0FDC), add USBCompliance (for usbu2a.sys), small fix for USB FDD

Maximus Decim Native USB ver.3.2
English: nusb32e
Russian: nusb32r


What's new?
*Add USB FDD + DISKTSD.VXD 4.90.3001
*Fix USB2.INF for ATI chipsets
*explorer.exe ver 4.72.3612.1700

Maximus Decim Native USB ver.3.1
English: nusb31e
Russian: nusb31r


What's new?
*Downgrade USBSTOR.SYS (4.90.3000.1), removed wdmstub.sys
*CnMemore replaced Skymedi

Link to comment
Share on other sites

Thanks for the Great work.

I've been trying to make it work on my Japanese Win98se.

I just want to report that finally, I got it work! Yes!!

The trick is that after installing Maximus Decim's patch, I replaced user.exe and user32.dll in system directory with Japanese WinME (4.90.3000) files.

(with manually updated ie6sp1 and xpsp2 tricks by MDGx. I don't know how these affect above system files, though.)

Interface is still English, but it works perfect. :thumbup

Link to comment
Share on other sites

Hi Maximus,

I tried 2.1 and it worked for my Fuji camera, except I would get an additional prompt asking me to use the taskbar icon to STOP the camera first...

In connecting/disconnecting the camera, there is no harm, so is there a way to get rid of the prompt?

Also (and more important), I have an older Visioneer 7600 USB scanner that 2.1 didn't work with...will 2.2 work with it?

Link to comment
Share on other sites

Also (and more important), I have an older Visioneer 7600 USB scanner that 2.1 didn't work with...will 2.2 work with it?

These drivers are not for all USB devices, jasinwa. They're only for storage based USB devices such as flash disks, cameras.

Link to comment
Share on other sites

thx Gape...got it...it was hard for me to know, as it is noted in maximus-decim's post

....and similar devices.

I figured a USB scanner is a similar device!!

but I understand it is a storage device....so it is Ok to run usb2.2 along with my scanner driver...


Link to comment
Share on other sites

  • 2 weeks later...

Hi Maximus,

I think it would be good to separate this language independent USB driver from language dependent Q242975 hotfix, what do you think?

This would mean that the USB driver could be used on any langauge version Windows.


Link to comment
Share on other sites


My hard drive in IDE to USB-2 external enclosure is working very well with your driver.

When I changing it with DVD burner LG 4163b, Win98SE can't recognize it.

Any suggestion?

is it works in another WinOS (ME/2K/XP/2K3) without any addon driver?

in order to make it working i need the next info from any other OS where it works:

1. Run regedit.

2. Export into reg-files the next brunches from the registry (XP/2K/2K3):



3. Zip regs and send 'em here

Link to comment
Share on other sites

Hello Maximus,

I have problems with this USB package and Mitsumi USB Floppy drive.

The system is freshly installed Windows 98 SE + drivers + SE SP 2.0 RC3 + NUSB2.2, motherboard is i845 chipset with ICH-4 southbridge.

When I insert this floppy into USB connector, at first looks like at least twe drivers are properly recognized, but then BSOD appears with message:

A fatal Exception 00 has occured at 0028:C1C24DD4 in VXD DiskTSD(03) + 00011EB4 - the current application will be terminated.

After reboot there is yellow exclamation mark at USB Floppy Disk in Storage devicess class in Device manager.

If I remove the driver from device manager, an re-insert the USB connector, the blue screen appaered again.

What is installed in registry:





"DeviceDesc"="Mitsumi USB Floppy"













"DeviceDesc"="USB Floppy Disk"












"DriverDate"=" 4-11-2005"

"DriverDesc"="Mitsumi USB Floppy"


[HKEY_DYN_DATA\Config Manager\Enum\C29A52C0]








[HKEY_DYN_DATA\Config Manager\Enum\C2A168E0]








With Windows XP and with Mitsumi supplied driver and Windows 98 SE everything works without any problems.

Also several various USB flashdisks works fine with NUSB2.2 on the same computer.

Any idea?


Link to comment
Share on other sites

The same BSOD on completely different configuration and the same Mitsumi floppy drive - ICH-2 USB, Czech version of Windows 98 SE.

Any idea how to solve the problem? This floppy drive is explicilty written in the original Win ME INF file, so it should be supported. I will also try to install Windows ME to see if it really works.


Link to comment
Share on other sites


it's a really strange problem - Mitsumi USB Floppy with id VID_03EE&PID_6901 - it should be supported.

All info from the registry provided here is quite correct.

Have U Disktsd.vxd ver. 4.10.2223 installed? If not - try this one, if so and it does not working, try to replace it with WinME version.

Unfortunately i don't have Mitsumi USB Floppy to check this one by myself...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...