Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
bishooman

WPI_2.7_Final by the Brain & Gresh

Recommended Posts

thanks dog... (like black people says it)

Want is to sort those categories...

can u check my work pls

notice i dont have any reg keys bec. they dont register using the 2.98a version i downloaded

850a1_wpipicture.jpg

I removed the attached wpi bec. it contained so many bugs.

Share this post


Link to post
Share on other sites

Brain & Gresh

WPI is great !!!

but... what about "dependence" ?

it's possible insert feature like "if i select A then automaticali select B,C,D...."

and deselect ofcouse...

sample:

i want choose MUI, if a select MUI so automaticali select MUI for Media Player 10 (if MP10 selected, if not selected MP10 - so not select MUI for MP10)

and many other samples like automaticaly select "all software for cd-burning" and other.... or simple select Group Multimedia, or Office....

i'm not programmer so i don't know how hard release this, but i think this will great feature.... if it's not so hard to realize...

ps. sorry for my bad english...

Share this post


Link to post
Share on other sites

@Astalavista

I cant say wether the switches work because i dont have all the software.

On some of your entries you have blank commands such as

regb[pn]=['']
cmd3[pn]=['']
rega[pn]=['']

These should be deleted, will come up with an install error.

your f2 switch so far as i know should be -f2 not /f2

This so far as i know is the old way of doing it

cmd1[pn]=['Drive','CommandLine 1']

change the two programmes with this.

otherwise it looks ok.

another tip,

if you want to change the colours on the tip box it is in the config.js

on your version at the top

Style[0]=["black","black","#FFb200","#FFD980"

it is this part of it.

The firts black is the colour of the title of the box, the second is the tip text colour, the next is the border colour '#FFb200', and then the desc background colour '#FFD980'.

another tip.

to check if everything is going into the regestry. make a backup of generate.js

and delete

WshShell.Run("rundll32.exe iernonce.dll,RunOnceExProcess", 10, true);

this is in the generate.js two times at the bottom. Delete both of these.

Now you can run WPI select all and install. Go into your registry at

HKLM\\SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\RunOnceEx

and see what is there, but dont forget to delete all entries under this otherwise on next beet it will try and install the programmes :D

Leave the RunOnceEx there but delete the 'title' entry. See piccy

leave the standard/Default in there though

post-70-1103195147_thumb.jpg

Share this post


Link to post
Share on other sites

LOL

what is a f2 switch?

/f are u ref. to taskill /f?

pls explain i am a noob when it comes to wpi. pls master teach me. I am a little grasshopper

Share this post


Link to post
Share on other sites

Ok grasshopper

Installshield applications will fail to install when executed from RunOnceEx on CD, unless a log file location is specified. An example of this is shown below, adapt this example for your InstallShield applications (shown in bold):

REG ADD %KEY%\045 /VE /D "Kerio Personal Firewall 2.1.5" /f

REG ADD %KEY%\045 /V 1 /D "%CDROM%\apps\KPF\Setup.exe -s -f2\"%systemdrive%\kerio.log\"" /f

so your entry

cmd1[pn]=['%cdrom%\\Software\\Photoshop\\setup.exe /s /sms /f2c:\Photoshop.log']

should be

cmd1[pn]=['%cdrom%\\Software\\Photoshop\\setup.exe /s /sms -f2c:\Photoshop.log']

Share this post


Link to post
Share on other sites

i hope someone can help solve why my reg keys are not registering.

i noticed that REGEDIT /S is being used could this be it?

ae8a7_Snap1.jpg

cmd1[pn]=['%cdrom%\\Software\\Yahoo\\Yahoo.EXE /S']

cmd2[pn]=['pskill.exe ypager.exe']

cmd3[pn]=['%cdrom%\\Software\\Yahoo\\yahooreg.exe']

rega[pn]=['%cdrom%\\Software\\Yahoo\\yahoo.reg']

dflt[pn]=['yes']

forc[pn]=['false']

cat[pn]=['Application']

ordr[pn]=[240]

pn++

this is inside my reg key

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]"Yahoo! Pager"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update]

"AUOptions"=dword:00000002

Share this post


Link to post
Share on other sites

yes they install manually

if i go to the cmd and type regedit /s yahoo.reg

but when i use wpi it doesn't what gives.

Share this post


Link to post
Share on other sites

@Astalavista

I don't know what your problem with regkeys is. I install tons of them throughout my WPI, and they ALL work PERFECTLY.

Here are some examples:

regb[pn]=['%cdrom%\\Tweaks\\RegTweaks.reg']

rega[pn]=['%cdrom%\\Applications\\mp3splitjoin\\mp3splitjoinreg.reg']

rega[pn]=['%cdrom%\\Applications\\dt\\daemon.reg']

I will point out, like BritishBulldog, that any blank entries should be removed from config.js. I don't know if thats the problem, but try to remove anything that's not being used.

Share this post


Link to post
Share on other sites

funny thing is these work perfect for me.........

prog[pn]=['Main Registry Tweaks']

desc[pn]=['60 Plus Registry Tweaks.<i>Required</i>']

rega[pn]=['regedit /s %cdrom%\\software\\regtweaks.reg']

dflt[pn]=['yes']

cat[pn]=['Tweaks']

pn++

prog[pn]=['Remove Desk Top Icons']

desc[pn]=['Remove My Documents Network Places Internet Explorer']

rega[pn]=['regedit /s %cdrom%\\software\\rdticons.reg']

dflt[pn]=['yes']

cat[pn]=['Tweaks']

pn++

prog[pn]=['Remove Recycle Bin Icon']

desc[pn]=['romove desk top icon of recycle bin']

rega[pn]=['regedit /s %cdrom%\\software\\rdtrbi.reg']

dflt[pn]=['yes']

cat[pn]=['Tweaks']

pn++

prog[pn]=['Sygate Registry Tweak']

desc[pn]=['removes sygate registration nag']

rega[pn]=['regedit /s %cdrom%\\software\\sygate.reg']

dflt[pn]=['yes']

cat[pn]=['Tweaks']

pn++

prog[pn]=['Registry Tweak for McAfee AV']

desc[pn]=['registry tweak to allow context menu only anti virus to run']

rega[pn]=['regedit /s %cdrom%\\software\\mcafeecm.reg']

dflt[pn]=['yes']

cat[pn]=['Tweaks']

pn++

prog[pn]=['SyncBack Registry Tweak']

desc[pn]=['Sets up the great backup program to customers previous settings']

rega[pn]=['regedit /s %cdrom%\\software\\syncback.reg']

dflt[pn]=['no']

cat[pn]=['Tweaks']

pn++

prog[pn]=['Registry Tweak for WMP10']

desc[pn]=['Cancel first run tweak for Windows Media Player 10.']

regb[pn]=['regedit /S %cdrom%\\software\\wmp10.reg']

dflt[pn]=['yes']

cat[pn]=['Tweaks']

pn++

Share this post


Link to post
Share on other sites

@bonedaddy

what version of WPI are you using?

i added your registry commands to the 2.9.8 version and got this as in the picture.

double REGEDIT command in the registry....

with this version you dont have to enter the 'REGEDIT /S' it is automatically added by the script

WshShell.regWrite(KeyBase + "\\"+e+"\\", programs.prog, "REG_SZ");

  if (true) { // set to false, if you want just the display but no real installs

   if ((programs.regb != null)&&(path(programs.regb) != '')) WshShell.regWrite(KeyBase + "\\"+e+"\\1","REGEDIT /S "+path(programs.regb), "REG_SZ");

WshShell.regWrite(KeyBase + "\\"+e+"\\4",path(programs.cmd3), "REG_SZ");

   if ((programs.rega != null)&&(path(programs.rega) != '')) WshShell.regWrite(KeyBase + "\\"+e+"\\5","REGEDIT /S "+path(programs.rega), "REG_SZ");

  }

post-70-1103205199_thumb.jpg

Share this post


Link to post
Share on other sites

that is what i am talking about we are NOT using the same version.

a06lp

that is why yours work and mine doesn't

Share this post


Link to post
Share on other sites

open the generate.js and search for REGEDIT

if it finds it in there twice like above then you dont have to add it to your command line.

If not then add REGEDIT /S.

@Astalavista

in the WPI you sent me it is there so you dont have to enter it in your config.js

this below should work

regb[pn]=['%cdrom%\\Tweaks\\RegTweaks.reg']

I think it is hard to find which version we are using as it is not shown anywhere

Share this post


Link to post
Share on other sites
that is what i am talking about we are NOT using the same version.
a06lp

that is why yours work and mine doesn't

i am using 2.9.8a...the current version.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...