Jump to content

Could the Next Firefox ESR Version Be Supported on Windows 7/8x ?


Recommended Posts


I don't think Firefox 128 ESR would support OS prior to Windows 10 (8.1 still works unofficially). Rather they'll extend Firefox 115 ESR, maybe up to 115.20.0 or something like.

Link to comment
Share on other sites

I'm divided on how I feel about that.  I like the idea of extending a browser that still works the way I like, however some sites I use for health benefits through work do not work on ESR 115, even when spoofing a user agent.  Well, I guess we'll see. :)

 

Link to comment
Share on other sites

12 hours ago, Jody Thornton said:

This is the site I wish I could use on ESR 115 :(

https://my.canadalife.com/sign-in

 

No chance in Hell. It doesn't even work with Chrome 121. The wheel is constantly spinning, that's it.

I didn't look into the error console, sorry.

Link to comment
Share on other sites

14 hours ago, BW134 said:

I don't think Firefox 128 ESR would support OS prior to Windows 10 (8.1 still works unofficially). Rather they'll extend Firefox 115 ESR, maybe up to 115.20.0 or something like.

Exactly! For me, looks like they simply want to make noise in a desperate attempt to draw a couple of more users.

Link to comment
Share on other sites

9 hours ago, Jody Thornton said:

This is the site I wish I could use on ESR 115 :(

https://my.canadalife.com/sign-in

 

It works if you spoof the Firefox version to the latest version 128. Spoofing the OS is not needed.

The User Agent should look like this :

	Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:109.0) Gecko/20100101 Firefox/128.0
	

Link to comment
Share on other sites

2 hours ago, Dixel said:

No chance in Hell. It doesn't even work with Chrome 121. The wheel is constantly spinning, that's it.

I didn't look into the error console, sorry.

Thanks Dixel.  It does work in Supermium so at least I'm covered on the Vista notebook. :)

 

Link to comment
Share on other sites

Posted (edited)
2 hours ago, superleiw said:

It works if you spoof the Firefox version to the latest version 128. Spoofing the OS is not needed.

The User Agent should look like this :

 

	Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:109.0) Gecko/20100101 Firefox/128.0
	

Outstanding!  Thank you so much! :D

Edited by Jody Thornton
Link to comment
Share on other sites

23 hours ago, Jody Thornton said:

Thanks Dixel.  It does work in Supermium so at least I'm covered on the Vista notebook. :)

 

No wonder, Supermium has a newer engine, the fact Firefox works with just spoofing could point to its inability to transmit Client Hints sneaky "feature" info.

Check here.

https://browserleaks.com/client-hints

Link to comment
Share on other sites

I mean... even if they don't extend the "official" support, we have plenty of options for 7/8.1

As stated in many different posts, the latest Firefox (128 ESR!) works on both 7 and 8.1 with some modifications. Back in the days of XP/Vista this would have been great news, as there weren't any Extended Kernels for them in 2017/2018 but now that we have some projects that extend software support, I really do not care anymore about official EOLs.

XP : OneCore API

Vista: Extended Kernel

7: VxkEx

8.1: Mostly some tweaks to installers

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...