Jump to content

My Browser Builds (Part 2)


Recommended Posts

1 hour ago, dencorso said:

BUG REPORT: The previous build od Basilisk 52, namely 20200222 fails to load both (the correctly installed)  Open H264 Video Codec and the Primetime Content Decription Module again. Reverting to 20200110 fixes it, so it's something incorporated after it.

Since I saw no report about that issue, I presume the latest version (20200229) has it, too, but still had no time to test whether that's true or not..

is 20200110 is the last version that loads Open H264 Video Codec and the Primetime correctly? if so I may able to trace which rev causing this.

Edited by roytam1
Link to comment
Share on other sites


3 hours ago, dencorso said:

fails to load both (the correctly installed)  Open H264 Video Codec and the Primetime Content Decription Module

I have repeatedly written about a problem with plugin support.

https://msfn.org/board/topic/180462-my-browser-builds-part-2/?do=findComment&comment=1177415

https://msfn.org/board/topic/180462-my-browser-builds-part-2/?do=findComment&comment=1177422

https://msfn.org/board/topic/180462-my-browser-builds-part-2/?do=findComment&comment=1177760

Edited by Dr. Drill
Link to comment
Share on other sites

So 20200215 already had the issue...  <1177760>.
And on <1177415> you traced it to:

On 2/7/2020 at 10:41 PM, roytam1 said:

- Issue #26 - Part 2c: Remove dependence on gmp/widevine-adapter/* (4c9689f68)

which was incorporated on 20200208 for the 1st time!
And the last working build, according to <1177422> was 20200131 (aka 20200202)!

Well, you did a good job and reported timely. Please accept my apology at having missed your bug report. :blushing:
I guess all the off-topic posting going on at the time did distract me, after all... even if that's really no excuse for me not to have noticed your reports, @Dr. Drill.  Thank, you! :yes:

Link to comment
Share on other sites

4 hours ago, roytam1 said:

is 20200110 is the last version that loads Open H264 Video Codec and the Primetime correctly? if so I may able to trace which rev causing this.

The version I have seems to be 2020-01-31

Edited by Omntech
Link to comment
Share on other sites

today's pm and bk builds are replaced with following changes:

Revert following changes for fixing Primetime issue:
- Issue #26 Part 2a: make more EME code conditional. (99118e38e)
- Issue #26 - Part 2b: Stub out GMPDecryptorProxy functions. (d44c61bf6)
- Issue #26 - Part 2c: Remove dependence on gmp/widevine-adapter/* (4c9689f68)
- Issue #1392 - Change --enable-eme to MOZ_ARG_ENABLE_BOOL and remove MOZ_EME_MODULES (832d84d2c)
- [Basilisk] Issue MoonchildProductions/UXP#1392 - Remove usage of MOZ_EME_MODULES (3a165cd)

so please test if Open H264 and Primetime will load again or not.

Edited by roytam1
Link to comment
Share on other sites

@roytam1 <--

http://o.rths.ml/gpc/files1.rt/home.html
So far , RT is updating ICEAPE-UXP on a weekly basis , thanks!

This last RT update , it was 20200229 date , but displayed under HELP (Menu)
as being still as 20200222 date update. Mentioned as information , not a real complaint.

So , RT ICEAPE-UXP seems a streamlined version of the normal
SEAMONKEY 2.49.5 (WinXP compatible) official version (Sept. 2019).

And RT ICEAPE-UXP Browser has Language Packs avaiable for easy installation.
https://www.hyperbola.info/
So , above URL is home website of ICEAPE-UXP Browser that RT updates it for WinXP OS.
So , click (Menu) PACKAGES there , and then "keywords" (box) = "ICEAPE" (click SEARCH button)
You should see 20 Language Packs Listed. You have to 'drill down' into the archive compressed
FILE (tar) using 7-ZIP to finally get to the Language Pack EXTENSION (*.XPI). But it is there and works.
https://www.hyperbola.info/packages/?q=ICEAPE
 
RT ICEAPE-UXP Browser works rather well here on my Old Laptop with WinXP OS.
And the Language Packs are a winning feature over RT BNAV Browser , to my way of thinking.
Hopefully , the Language Packs will keep working as RT does his weekly updates.
RT yet again providing an excellent WinXP OS Browser solution , one that supports Language Packs.

Added observation --> RT's Support Level of his Browsers , is fairly amazing.

Edited by TechnoRelic
Link to comment
Share on other sites

5 hours ago, roytam1 said:

so please test if Open H264 and Primetime will load again or not.

I checked https://o.rths.ml/basilisk/basilisk52-g4.5.win32-git-20200229-6e6ffb8-uxp-ae8eb4d4c-xpmod.7z

Unfortunately, installed plugins do not work and are invisible in about: addons. The console says:

20:29:54.686 1582993794684    addons.manager    ERROR    Exception loading provider GMPProvider from category "resource://gre/modules/addons/GMPProvider.jsm":
SyntaxError: illegal character (resource://gre/modules/GMPUtils.jsm:75) JS Stack trace: @GMPProvider.jsm:22:1 < startup@AddonManager.jsm:948:11 < startup@AddonManager.jsm:3025:5 < observe@addonManager.js:65:9 1 Log.jsm:753
    App_append resource://gre/modules/Log.jsm:753:9
    log resource://gre/modules/Log.jsm:389:7
    error resource://gre/modules/Log.jsm:397:5
    startup resource://gre/modules/AddonManager.jsm:953:11
    startup resource://gre/modules/AddonManager.jsm:3025:5
    observe resource://gre/components/addonManager.js:65:9

 

20:31:08.416 Failed to load module resource://gre/modules/GMPInstallManager.jsm. 1 XPCOMUtils.jsm:279
    XPCU_moduleLambda resource://gre/modules/XPCOMUtils.jsm:279:9
    get resource://gre/modules/XPCOMUtils.jsm:198:21
    _delayedStartup/< chrome://browser/content/browser.js:1845:7

 

20:31:08.417 SyntaxError: illegal character 1 GMPUtils.jsm:75
    <anonymous> resource://gre/modules/GMPInstallManager.jsm:29:1
    XPCU_moduleLambda resource://gre/modules/XPCOMUtils.jsm:273:9
    get resource://gre/modules/XPCOMUtils.jsm:198:21
    _delayedStartup/< chrome://browser/content/browser.js:1845:7

In build https://o.rths.ml/basilisk/basilisk52-g4.5.win32-git-20200201-2d98a15-uxp-64c8c65cf-xpmod.7z Adobe Primetime CDM, Google Widewine CDM & Cisco OpenH264 plugins are visible in about:addons.

Link to comment
Share on other sites

3 minutes ago, Dr. Drill said:

I checked https://o.rths.ml/basilisk/basilisk52-g4.5.win32-git-20200229-6e6ffb8-uxp-ae8eb4d4c-xpmod.7z

Unfortunately, installed plugins do not work and are invisible in about: addons. The console says:


20:29:54.686 1582993794684    addons.manager    ERROR    Exception loading provider GMPProvider from category "resource://gre/modules/addons/GMPProvider.jsm":
SyntaxError: illegal character (resource://gre/modules/GMPUtils.jsm:75) JS Stack trace: @GMPProvider.jsm:22:1 < startup@AddonManager.jsm:948:11 < startup@AddonManager.jsm:3025:5 < observe@addonManager.js:65:9 1 Log.jsm:753
    App_append resource://gre/modules/Log.jsm:753:9
    log resource://gre/modules/Log.jsm:389:7
    error resource://gre/modules/Log.jsm:397:5
    startup resource://gre/modules/AddonManager.jsm:953:11
    startup resource://gre/modules/AddonManager.jsm:3025:5
    observe resource://gre/components/addonManager.js:65:9

 


20:31:08.416 Failed to load module resource://gre/modules/GMPInstallManager.jsm. 1 XPCOMUtils.jsm:279
    XPCU_moduleLambda resource://gre/modules/XPCOMUtils.jsm:279:9
    get resource://gre/modules/XPCOMUtils.jsm:198:21
    _delayedStartup/< chrome://browser/content/browser.js:1845:7

 


20:31:08.417 SyntaxError: illegal character 1 GMPUtils.jsm:75
    <anonymous> resource://gre/modules/GMPInstallManager.jsm:29:1
    XPCU_moduleLambda resource://gre/modules/XPCOMUtils.jsm:273:9
    get resource://gre/modules/XPCOMUtils.jsm:198:21
    _delayedStartup/< chrome://browser/content/browser.js:1845:7

In build https://o.rths.ml/basilisk/basilisk52-g4.5.win32-git-20200201-2d98a15-uxp-64c8c65cf-xpmod.7z Adobe Primetime CDM, Google Widewine CDM & Cisco OpenH264 plugins are visible in about:addons.

alright will have a look few hours later, gotta sleep now

Link to comment
Share on other sites

18 hours ago, Dr. Drill said:

So have I and it's hard to know if I'm the only one with the problem or if it's a bug. The plugin for google hangouts (npgoogletalk.dll) appears dead but is it with them or the browser?

Edit: google hangouts may be for US/Canadian residents only so not really testable for anyone else.

Edited by DanR20
Link to comment
Share on other sites

7 hours ago, Dr. Drill said:

I checked https://o.rths.ml/basilisk/basilisk52-g4.5.win32-git-20200229-6e6ffb8-uxp-ae8eb4d4c-xpmod.7z

Unfortunately, installed plugins do not work and are invisible in about: addons. The console says:


20:29:54.686 1582993794684    addons.manager    ERROR    Exception loading provider GMPProvider from category "resource://gre/modules/addons/GMPProvider.jsm":
SyntaxError: illegal character (resource://gre/modules/GMPUtils.jsm:75) JS Stack trace: @GMPProvider.jsm:22:1 < startup@AddonManager.jsm:948:11 < startup@AddonManager.jsm:3025:5 < observe@addonManager.js:65:9 1 Log.jsm:753
    App_append resource://gre/modules/Log.jsm:753:9
    log resource://gre/modules/Log.jsm:389:7
    error resource://gre/modules/Log.jsm:397:5
    startup resource://gre/modules/AddonManager.jsm:953:11
    startup resource://gre/modules/AddonManager.jsm:3025:5
    observe resource://gre/components/addonManager.js:65:9

 


20:31:08.416 Failed to load module resource://gre/modules/GMPInstallManager.jsm. 1 XPCOMUtils.jsm:279
    XPCU_moduleLambda resource://gre/modules/XPCOMUtils.jsm:279:9
    get resource://gre/modules/XPCOMUtils.jsm:198:21
    _delayedStartup/< chrome://browser/content/browser.js:1845:7

 


20:31:08.417 SyntaxError: illegal character 1 GMPUtils.jsm:75
    <anonymous> resource://gre/modules/GMPInstallManager.jsm:29:1
    XPCU_moduleLambda resource://gre/modules/XPCOMUtils.jsm:273:9
    get resource://gre/modules/XPCOMUtils.jsm:198:21
    _delayedStartup/< chrome://browser/content/browser.js:1845:7

In build https://o.rths.ml/basilisk/basilisk52-g4.5.win32-git-20200201-2d98a15-uxp-64c8c65cf-xpmod.7z Adobe Primetime CDM, Google Widewine CDM & Cisco OpenH264 plugins are visible in about:addons.

archives updated, please try again

  • Upvote 1
Link to comment
Share on other sites

On 2/24/2020 at 8:24 AM, ArcticFoxie said:

But again, it doesn't work "upstream" either, so *I* don't expect Roytam to 'fix it' (but I also see that a shame as patches are "cherry-picked").

if you want this to be fixed, test with latest build first. if latest build doesn't fix that, please find out last working build and first non-working build, and give out page url for reproducing problem.

Link to comment
Share on other sites

  • Dave-H changed the title to My Browser Builds (Part 2)
  • dencorso unpinned this topic
  • dencorso locked and pinned this topic
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...