Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Mathwiz

Force "multiprocess mode" in FF 52

Recommended Posts

my New Moon latest build on XP on i5-3450 is 31.85 Seconds. my bk55 latest build is 29.69 Seconds.

my New Moon 27 latest build is 33.63 Seconds (for reference)

Share this post


Link to post
Share on other sites

On 5/11/2019 at 5:26 PM, Dave-H said:

I tried the acceleration test which @mockingbird linked to, and my Firefox on XP only makes 20fps!

FF52 = 18

SP55 = 20

NM28 = 16

Share this post


Link to post
Share on other sites
On 5/10/2019 at 6:08 PM, Dave-H said:

Glad you fixed it @mockingbird!

Having assessed things for a day or two, I can report that the performance of Firefox 52.9.1 ESR on my system is now vastly improved since I finally managed to enable multiple processes.
On script-heavy sites like Facebook and YouTube, it was always quite slow and hesitant loading and updating pages, with scrolling being jerky and inline Facebook videos stopping and starting. Now it's much faster and smoother, in fact I would say it's pretty much as good now as the "latest and greatest" 64 bit Firefox 66 on Windows 10!
It is now a bit of a RAM hog, it's sometimes using nearly 1GB of RAM with two processes running, but as I only very rarely use it with loads of other stuff running as well, it's not a problem for me, although it might be if you have less that 3GB of accessible RAM.
I've not had any stability problems (touch wood!) and all my add-ons seem to be performing normally, despite me getting an add-on compatibility warning when I first tried the tweak.
I have dom.ipc.processCount set to 4.
All in all, I would personally well recommend doing this tweak.
YMMV of course, but it's definitely been a great performance improvement on my system!
:yes:

@Dave-H Only see this thead looking for something else

I have tried the dom.ipc.processCount but set it to 3

One thing I noticed was the CPU usage going down on some sites, scrolling is a little better, One thing I noticed is the low CPU usage on most sites, but switch to FB it increases to a 50-60% usuage (sometimes higher) wonder if this is the high amount  of scripting

What does browser.tabs.remote.force-enabled do and the others i have seen mentioned

......

On a side note, Can we disable the plugin container, in the past I noticed it was mainly needed to help play flash games, and removing it, there was no adverse effect and FF ran smoothly without it, but now If I disable or remove it FF complains Primetime has  has stopped and need to reload page

Share this post


Link to post
Share on other sites
Posted (edited)

You can't enable multi process with just that setting, the others mentioned earlier in the thread have to be set as well, especially browser.tabs.remote.force-enabled which overrides the fact that multi process is specifically disabled on XP systems.
Look in your Windows Task Manager, if there is only one firefox.exe process running, it's not enabled.
I wouldn't worry about the plugin container process, at least on my system it only runs when I visit a site that uses Flash.
I can't see that there would be any great advantage in disabling it unless you have a bad resource shortage problem.
It does keep the browser more stable, as before it was introduced a crash in a plugin could take the whole browser down!
:)

Edited by Dave-H
Addition

Share this post


Link to post
Share on other sites
Posted (edited)

@Dave-H how do i revert back to only seeing 1 FF process, I did reset the dom.ipc.processCount back to one

pretty sure I didn't make any other changes yet I see 2 if i cancel one i get a opps a tab has crashed or cancel other FF closes

would it be this dom.ipc.plugins.enabled  set to false

Edited by DrWho3000

Share this post


Link to post
Share on other sites

If you haven't made any other changes apart from to that one setting, you shouldn't be seeing multipole processes.
What are your settings in these parameters?

browser.tabs.remote.force-enable
browser.tabs.remote.autostart
browser.tabs.remote.autostart.2 (may not be present)
extensions.e10sBlocksEnabling
dom.ipc.processCount

:dubbio:

Share this post


Link to post
Share on other sites

I got

browser.tabs.remote.autostart.2  set to true

browser.tabs.remote.force-enable set to  true

dom.ipc.processCount set to 1

browser.tabs.remote.force-enable  isn't there

there is some extensions.e10sBlocks there by default NOT touched but NOT extensions.e10sBlocksEnabling

would it be one of these

i can't think that I did do any other changes

Usually make a backup of the prefs before making changes, but neglected to this time, lucky i had a little older one

 

Share this post


Link to post
Share on other sites
Posted (edited)

browser.tabs.remote.force-enable seems to be in your list twice.
Which one is right?! Is it there or isn't it?
:dubbio:

Edited by Dave-H
Addition

Share this post


Link to post
Share on other sites

this is what I got

user_pref("browser.startup.page", 3);
user_pref("browser.tabs.remote.autostart.2", true)

comparing the one I am using now to the one I had, seems this is the one missing pref


user_pref("browser.tabs.remote.force-enable", true);  isn't in what I am using Now, 

but is in the other what I had, so "maybe this is the culprit and "may" have did it without thinking

 

Share this post


Link to post
Share on other sites

If you don't have browser.tabs.remote.force-enable present now, you shouldn't be seeing multiple processes, as I couldn't get it to work until I added that setting.
This is what I have -

browser.tabs.remote.force-enable=true
browser.tabs.remote.autostart=true
browser.tabs.remote.autostart.2 - not present and apparently not necessary, can be removed by resetting it and restarting the browser.
extensions.e10sBlocksEnabling=false - this setting will prevent any problems with some add-ons being blocked when multi-process is enabled.
dom.ipc.processCount=4

These settings seem to work fine for me.
:yes:

Share this post


Link to post
Share on other sites
Posted (edited)

after removing user_pref("browser.tabs.remote.force-enable", true)

from original prefs and placing back this prefs back in, seems this was the culprit causing to have 2 FF processes

Now only have 1 FF process, not 4 or 2 i was having

unless it was something else, only thing I removed went from multi process to 1

very strange

Edited by DrWho3000

Share this post


Link to post
Share on other sites

OK, well up to you if you want to keep multi process enabled or not.
I found that it gave a significant performance improvement on sites like Facebook.
You do need a lot of free memory to use it though, so I wouldn't recommend it if you're very short of RAM!
:)

Share this post


Link to post
Share on other sites

Not sure if 2GB of ram would be enough to do this, so will err on side of caution

thnx for that

Share this post


Link to post
Share on other sites

As always it depends on what else you have running at the same time as the browser.
I've seen Firefox eat nearly 1GB of RAM with multi process enabled.
Just experiment with it, and if it causes issues, just changing browser.tabs.remote.force-enable to false should disable it.
:)

Share this post


Link to post
Share on other sites

currently FF process is sat at 620.000k but have seen it go as high as 800-900,

but this I suppose is how many tabs you have open and the scripting on webpages

currently sat at 1.24GB of Ram usuage , but I do have IRC, uTorrent and DC++ running aswell they are pretty nominal at arounf 10k of mem usage

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...