Jump to content

Backporting newer browsers to Win9X with KernelEx

Recommended Posts


I increased the max version in the install file and afterwards the installation of HyperBK ran smoothly. Thanks.

Supplement: On my XP Youtube doesn't work up to FF42.0 anymore.


Link to post
Share on other sites

The Youtube's block is also artificially created...

This is into html code :html5_disable_vp8_only_browsers=true

Changing this value from true to false, currently, the video playback runs again. 

I've tested it now with Firefox 10 on Windows 2000 and this video :) :


  • Like 1
Link to post
Share on other sites

I don't know if exists a specific extension for firefox. Just to be clear, like opera and its internal editor html.
I only changed the value, saving the page on the disk as complete page, and opening the html file with notepad.

An update about this thing: unfortunately, i noticed that doesn't work with all videos (copyright limitation (like embedded videos)?) :dubbio: 

Link to post
Share on other sites
On 9/3/2018 at 1:43 PM, cov3rt said:

for the font related problem, i did not find that "MICROSS.TTF" file in my windows 7 system, even though youtube worked just fine, maybe that's a 9x specific file or something? i guess i'll just have to test a 98SE system hopefully in the near future. 

I find micross.ttf on this win-7 system (sp1, 32-bit, ultimate) and I don't remember adding it, so I have to assume it came standard.  From what I've read, micross.ttf is a standard (default) font that installs with win-2k and XP (and in my case I'm assuming 7 also) but not 98.  I copied this file (638 kb, 6/10/2009) to my win-98 system and used the above-mentioned registry entry, and MS word and Coreldraw both now show Microsoft San Serif.  I have hundreds of installed fonts on my 98 system (perhaps close to 1000) because so many came with Coreldraw 9 (that I installed many years ago).  This micross.ttf file is odd or strange - because it is so large compared to 99% of my other font files.  And it's odd because it does not contain italic or bold or underline versions (which it should, given it's file-size).

Edit:  I spoke too soon.  For the hell of it, I rebooted with bootlog and yup, micross.ttf wasn't loaded.   Error code 16 I think it said.  So I'll poke around and see what other versions I can find.

Edited by Nomen
Link to post
Share on other sites
On Mittwoch, 3. Oktober 2018 at 1:15 PM, Commodore said:


I tested an arbitrary youtube site and found indeed that value in its source code. But in FF9.0.1 there's no possibility to change text/values in source code view; it's just for viewing.

I tried to save a youtube site ("completely") and to edit the *.html file with a hex editor, but in the so created website the youtube video still didn't work.

How exactly did you proceed?

For now, the only method to view youtube is that method with bookmarklets. Maybe it would be possible to write a more comfortable bookmarklet or extension, which will automatically create download links while visiting any youtube site. Another disadvantage is that you have to wait until the video is downloaded; only then you can watch it (e.g. with media player classic). OK; that's not such a big problem if the video is "small" or short.

On Sonntag, 7. Oktober 2018 at 6:17 PM, Nomen said:

For the hell of it, I rebooted with bootlog and yup, micross.ttf wasn't loaded.   Error code 16 I think it said.  So I'll poke around and see what other versions I can find.

You could try the version I've uploaded.

Additional: Maybe it's necessary to activate micross.ttf in "Display properties -> Appearance". I've set it as standard font in some settings there (a long time ago).

Link to post
Share on other sites

Hi Diamant.
The only intention of my previous report was for academic demonstration that the issue is also due to artificial limitation.

Have you tried with the same video that i indicated above?

Another link that works: https://www.youtube.com/watch?v=4An1BrG2u_4

I noticed that if i copy the address (right click on the video window in a browser that works) of some videos (those that can be seen changing the value), they have this format: https://r3---sn-hpa7znse.googlevideo.com/videoplayback? + more parameters (only for vp8 encoded videos?)

Other videos haven't a http URL, but mediasource: + alphanumeric string (only vp9 / mse codec?). These are the videos on which the change has no effect.

In the first category i found personal video (e.g. No commercial song here) and, once the address has been identified, we can watch this videos also only using the embedded HTML5 player of Firefox or Opera.

Now, a lawful (i believe) and sufficiently fast way to watch youtube's videos directly (when so avalaible) that i can suggest is as follows.

Using the Y2mate service through a custom search engine (i used Opera, as in the example image), you just copy the ID video and search it.
The Y2mate's page contains different options for obtain audio or video files, but, if avalaible, an WEBM option with a download button. Selecting it, without waiting for the entire download, Opera starts the video (or only audio) streaming.

Please, test it and report your feedback

search opera.jpg

Edited by Commodore
my mistake (i wrote direct instead of watch!)
Link to post
Share on other sites

Very interesting, wasn't aware that simple webm-links can still play standalone in old browsers!
(provided the system has enough resources, which mine hasn't, but luckily I prefer to download anyway).

Anyway, can confirm that webm-links do play live in K-Goanna74 too, no waiting until the whole file is downloaded (98se with KernelEx)
What I'm using is a slightly modified userscript. This brilliant original one:

Inside have switched on webm, added 3gp links and some other formats, have made the links visible always (without JS) etc.
Am very happy with it, especially that 3gp-240p has much smaller filesizes as mp4.
That's a little prob with webm, the files are the largest, even 50% larger as mp4 with 360p.

But my modifications are very un-professional, and have no clue how modified scripts should be posted 'orderly'? Perhaps someone can use it anyway, so here just as draft, hoping someone else takes over...

Link to post
Share on other sites

Why do I feel the need to submit my test results from https://www.ssllabs.com/ssltest/viewMyClient.html to demonstrate that roytam1's Retrozilla actually supports TLS 1.2? Why am I struggling to create a JPEG file to give evidence of this fact on this Dell Pentium III Laptop with a scant 128MB? Why do I sort of want to hug the gentleman who previously stated I could make those security errors go away by rolling back to KernelEx 2016.16?

And, most importantly...how is it that I am able to submit this post near the end of 2018 on an operating system that hasn't been supported for so long, I'm not even sure when Microsoft stopped supporting it?

You guys are crazy. And you're sucking me right in with you. Help!

  • Like 1
Link to post
Share on other sites

@RetroidAll hope is lost, I've been sucked since at least...2010 :P

It's not about the OS, but the API that it uses, if the API is useful enough, you can do useful stuff...also driver support!

Opera 12.02 supports TLS 1.2 if you enable it, it's not by default.

Link to post
Share on other sites










Just out of curiosity, are you guys using 98SE for functional work, or just toying around to see what's still possible? 




@dencorso  You are making me feel old. It really doesn't feel like it's been that long. I even remembered to run "msinfo32" to get a machine report, although I forgot how to find how many MHz my CPU is actually trying to clock at on this machine. Might need third-party software for that.

@MrMateczko  Thank you for the kind words. You encouraged me to go check out Opera again, as my first attempt turned out to be a dismal failure. Turns out I had downloaded 12.12, not 12.02. Oopsie. I feel like somebody just turned the lights back on so I can see the msfn site again. However, the Javascript execution here in Opera is really crushing my poor little Pentium III's performance. I do also have XP dual booted on this old fella, so I am going to check and see if this is a win98 specific thing or if it's just a sign that a nearly 20 year old machine is going to have inherent limitations browsing the modern web. 

Link to post
Share on other sites

So as many of you probably already know, this Javascript engine in Opera 12.02 has abysmal performance. In XP, I had installed Opera 20 (just had it laying around on my NAS) to compare with version 12.02, and the performance in the Chromium Javscript engine is vastly superior, even on this 500MHz Pentium III machine. I wonder if a Chromium-like optimized Javascript engine was ever built for the Win 9x platform. Will do some additional research after I finally shut off this poor slug :-)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...