Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
burd

USB 2.0/3.0 drivers

Recommended Posts

Hey Guys I Recently Installed Windows Vista For Testing reasons and making it a full fledged working O/S,Though Ive bumped into the problem of the usb,my pc has 6 usb3.0 ports and no 2.0 ports and vista cant use any usb ports,are there any usb 3 drivers i can use or perhaps usb 2.0 ones will do aswell as long as they work?

I have a Windows Vista Home Premium X64 SP2

A Working Nvidia GTX 1060

Need USB though now

Share this post


Link to post
Share on other sites

18 hours ago, burd said:

I have a Windows Vista Home Premium X64 SP2
 

And what motherboard USB hardware?

jaclaz
 

Share this post


Link to post
Share on other sites

You can disable XHCI in the BIOS, like i did, to get the usb ports working under xp (solely as usb 2.0, though).

Mine was MSI Z170A Gaming 7 but it got blown a few days ago for nothing good. I am planing to get it a new board or to send it for service

Share this post


Link to post
Share on other sites

If only Manufacturers could use unique names.

Alternatively having their own site search engine capable of finding their own product name (MS-1785) would be a nice improvement.

That should be a laptop GT72VR 6RD, is it this one?

https://www.msi.com/Laptop/GT72VR-6RD-Dominator.html

I believe that motherboard actually has 3.1 USB ports.

Have you already tried the "standard" drivers here? :dubbio:

http://download.msi.com/nb_drivers/usb/ASMUSBHost_V116381WHQL.zip

jaclaz


 

Share this post


Link to post
Share on other sites
16 hours ago, jaclaz said:

If only Manufacturers could use unique names.

Alternatively having their own site search engine capable of finding their own product name (MS-1785) would be a nice improvement.

That should be a laptop GT72VR 6RD, is it this one?

https://www.msi.com/Laptop/GT72VR-6RD-Dominator.html

I believe that motherboard actually has 3.1 USB ports.

Have you already tried the "standard" drivers here? :dubbio:

http://download.msi.com/nb_drivers/usb/ASMUSBHost_V116381WHQL.zip

jaclaz


 

Yes I have,It either gives error code 10 or 39 in device manager

Share this post


Link to post
Share on other sites
16 hours ago, Dibya said:

You can disable XHCI in the BIOS, like i did, to get the usb ports working under xp (solely as usb 2.0, though).

Mine was MSI Z170A Gaming 7 but it got blown a few days ago for nothing good. I am planing to get it a new board or to send it for service

Hey Dibya,I tried xhci but,Only my keyboard works,but the minute i use my mouse the full Vista O/S becomes slow until i turn it off.

Share this post


Link to post
Share on other sites

Maybe try an older version of the "ASMedia USB3.0 eXtensible Host Controller" drivers, maybe 1.1623?

http://drivers.softpedia.com/get/MOTHERBOARD/ASMedia/

http://drivers.softpedia.com/get/MOTHERBOARD/ASMedia/index6.shtml
 

actual VID and PID of your controller might help in understanding if some other (non MSI) drivers might work.

jaclaz


 

Share this post


Link to post
Share on other sites
15 hours ago, jaclaz said:

Maybe try an older version of the "ASMedia USB3.0 eXtensible Host Controller" drivers, maybe 1.1623?

http://drivers.softpedia.com/get/MOTHERBOARD/ASMedia/

http://drivers.softpedia.com/get/MOTHERBOARD/ASMedia/index6.shtml
 

actual VID and PID of your controller might help in understanding if some other (non MSI) drivers might work.

jaclaz


 

Yes Trying the ones you've said(1.1623)


EDIT: The Minute i Install it i get BSOD and when i install drivers from here http://download.msi.com/nb_drivers/usb/ASMUSBHost_V116381WHQL.zip it installs but,it doesnt work and a new device is added in device manager,will post screenshot asap

Edited by burd

Share this post


Link to post
Share on other sites
3 hours ago, jaclaz said:

Maybe try an older version of the "ASMedia USB3.0 eXtensible Host Controller" drivers, maybe 1.1623?

http://drivers.softpedia.com/get/MOTHERBOARD/ASMedia/

http://drivers.softpedia.com/get/MOTHERBOARD/ASMedia/index6.shtml
 

actual VID and PID of your controller might help in understanding if some other (non MSI) drivers might work.

jaclaz


 

how to acquire the vid and pid?

Share this post


Link to post
Share on other sites

This Device Gets Added,Intel USB 3.0 Extensilbe Host Controller

Notice the other have been successfully installed and no exclaimation mark,yet its not working

vs.jpg

Share this post


Link to post
Share on other sites

Probably it'll activate just one pair of USB connectors, not all of them. RTFM to find out which ones.

Share this post


Link to post
Share on other sites
14 hours ago, dencorso said:

Probably it'll activate just one pair of USB connectors, not all of them. RTFM to find out which ones.

my mouse doesnt work using this,but my keyboard does,strange drivers :P

Share this post


Link to post
Share on other sites
10 hours ago, burd said:

my mouse doesn't work using this,but my keyboard does,strange drivers :P

Great! :yes:

That's half the problem solved!
Now, do get yourself a MS Wireless Mobile Mouse (or even a corded MS Basic Mouse), for us to have a truly standard mouse to troubleshoot the other half, while using a proven standard and reliable hardware, please. :)

Share this post


Link to post
Share on other sites
14 hours ago, burd said:

how to acquire the vid and pid?

Usually it is a good idea to use SIV:
http://rh-software.com/

to have a detailed overview of all the hardware on a machine, but in your case for just THE VID and PID you just click in device manager on the "Details" tab, then on the dropdown list you choose "Hardware ID", *like*:

Spoiler

5pjQo.png


 

jaclaz

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...