Jump to content

Rebuilding Inno Setups


Recommended Posts

use inctrl5 to find out what all ccleaner original installer puts its files...

I hear ya benners...I did one for dvd x utilities...had like 5 programs...thats not listed because it isnt on the dvd i looked at to make the list...i have some others ive done, but yea...dvd x utilities was a pain until I ran inctrl5 to find out that it actually changes files when you register it...like 3 dlls and 2 sys files, they did a good job on making it almost impossible to install an already regged program...but intelligence will prevail...like i said, ive seen almost every type of install and have been able to modify it...there was one I did for a Fastream product, but in the end, I think I deleted the whole thing...but it installed a service, so I had to figure out all the info for that...but yea, some are really a pain.

Also, DVD Shrink is being continued sorta...a lot of people use the dvd shrink backbone...like easydvdshrink...or a4dvdshrink...both those are exactly like dvd shrink...i have both because on one pc, dvd shrink would turn the screen black and couldnt see anything, so I had to include a 2nd one.

Edited by evilvoice
Link to comment
Share on other sites

Also, DVD Shrink is being continued sorta
good to know, you have done more setups than I, I had forgotten how many of my apps were inno conversion or alterations :-

Alcohol (bit of a cheat), Avicodec, Beyond Compare, bennersvideokit, cdimage, CDR-Win, dvdregionfree, Editpadpro, Folderbox, InCtrl5, lavasoft Ad-Aware, Mailwasherpro, Mozilla Firefox (another cheat),Grabit (ISP tweaked), Parameteriser, Quickpar ( Contains Quickpar, FSRaid, glue and Powerrenamer), Regcrawler,Regsnap, Resourcehacker, Sspybot, Spywareblaster, Tmpgenc, Trackseraserpro, Viceversapro, Wassociate and


Edited by benners
Link to comment
Share on other sites

at a program that requires registration how can i addthe registration into the setup?


also thanx for the informations. but i can't find inctrl5.

Edited by boooggy
Link to comment
Share on other sites

InCtrl5 my inno setup.

As for the registration, you can export the reg entries to a reg file, and import the reg file into ISTool.

Click on the Registry section in ISTool, right click and select import from file, just be sure to check the values are the same I have had times when binary values in hex format wont enter when the setup is run, and there are sometimes double quotes around file paths.

Another way is to click on the Registry section, right click and select New Item, there you can select the different hives and and enter subkeys and values.

Link to comment
Share on other sites

yea, reg_expand_sz doesnt get entered correctly...it gets imported as a string and the all the hex numbers are the data, which isnt correct, for any of those, you need to input the actual string...for instance %systemroot%\system32 instead of the hex numbers...Also, if a regfile points to the hard drive, try using something like {app} or {win} or {sys} so that c:\ or whatever isnt hardcoded.

a good idea is to look at the inno setup help file and goto index...that gives you most of what you can do.

Update...if your building a install program...when all done, have istool add a uninstall icon...that way it is accessible through start menu...i hate having tons of programs installed and arp takes forever to load...and if anyone wants the code I use for urls, I can post that too...it uses {groupname} and is universal on all scripts.

Blah, here it is anyways...just add this to your script...it is an example, and you will have to change the http://

Filename: {app}\{groupname}.url; Section: InternetShortcut; Key: URL; String: http://users.otenet.gr/~jtcliper/tgf

Name: {group}\{cm:ProgramOnTheWeb,{groupname}}; Filename: {app}\{groupname}.url

Type: files; Name: {app}\{groupname}.url

Edited by evilvoice
Link to comment
Share on other sites

can some one take a look at this its

Registry First Aid v4.1.0 build 707

[Run]Filename: {app}\repl_ag.bat; WorkingDir: {app}; MinVersion: 4.1,4.0

Filename: {app}\readme.txt; Description: View the README file; MinVersion: 4.1,4.0

Filename: {app}\reg1aid.exe; WorkingDir: {app}; Description: Launch application; Languages: en,nl,brpt,cz,dn,fi,fr,ga,gr,it,no,ru,sl,sw; MinVersion: 4.1,4.0

Filename: {app}\reg1aid.exe; WorkingDir: {app}; Description: Programm jetzt starten; Languages: de; MinVersion: 4.1,4.0

Filename: {app}\rfagent.exe; WorkingDir: {app}; MinVersion: 4.1,4.0

im trying to edit it so it will be completely unattended,

what it does is most of it installs silent but then the rfagent.exe runs and tries to update check,

im not sure how to edit out that line can some one help me out pls

Link to comment
Share on other sites


i did what you said and removed that line from run.. now i get the error about language expressions.. saying it contains unknown language

well i tried to fix it by only using english and removing all the rest then editing every line that pointed to another language. but every time i get rid of some thing a new line error pops up with language expression error

can you take a look at my iss file and tell me what i should do if you can

i just want english and thats it,,

this is a clean iss,, the only thing ive done to it was remove the {app}\rfagent.exe line

btw the error first started in the tasks section i tried fixing it from there thats how the errors keep on like a train of dominos


Edited by Lost Soul
Link to comment
Share on other sites

I always have a problem with the languages and just delete any references to them in the script or on the files themselves via the common tab on the file properties.

Languages: en,nl,brpt,cz,dn,fi,fr,ga,gr,it,no,ru,sl,sw;

I downloaded the program and edited the iss file removing all the extra language entries. I added a name in the Program Tab under options so that when the shortcuts are created the folder name will not be "default". and set solid compression and ultra level.

The program compiled silently after I deleted 3 more files from the install run section and ran when clicked so it seems to work, I'll let you fully test it :P


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...