Jump to content

Strange fonts or characters (Opera 12.02)


Recommended Posts

Thanks loblo! (and Nomen for posting this thread) Disabling webfonts also fixed this problem for me. I've noticed occasional weird garbled illegible fonts in a handful of websites ever since I updated to Opera 12.02 a few years ago, but I thought it was a glitch in those particular websites. In recent months though, I've noticed them much more often including mainstream sites such as NY Times, CBS sports, etc.

I have no idea what webfonts are but disabling them also solved some very annoying fonts and missing hyperlinks in several other websites I browse regularly. I've continued to notice fonts changes (for the better) ever since I disabled them. Seems like the default setting should be "disabled" rather than "enabled".

Link to comment
Share on other sites

Webfonts are fonts that are served from the web instead of being on your machine. Their purpose is to allow webpages to render with whatever font they have been designed, and as you've noticed their use is more and more widespread. They may be served by the website using them itself or its eventual content delivery provider (sometimes embedded in css as base64 encoding) or served by webfonts providers such as Google fonts (free) or Adobe (commercial).


Using a browser with no support for webfonts or disabling that feature is no real problem for text rendering  because the browser will simply use the fallback/substitutes fonts that are installed on one's system instead of the intended font.


The problem remains however for the webfonts consisting solely of a variety of glyphs/icons whose use is also more and more widespread and for which there are no substitutes/fallback on one's system.


To address this, the only solution I found was to find some of those fonts and install them on my system. I have 12 installed so far (they cover quite a bit, Web Archive 2, Twitter, Wordpress and many more) and have uploaded  them in case it's useful for someone else: http://www.datafilehost.com/d/fbdbe635. They should all work as intended  apart from the icomoon one. Icomoon webfonts are generated  on demand and the content of the font will be different from site to site using it but at least you'll have nice icons instead of gibberish even if they are not the right ones should you choose to install it.

Edited by loblo
Link to comment
Share on other sites

Thank you so much for those fonts, loblo! The Internet has become a filthy dump where nothing useful or of quality can be found anymore, not without (heavy) payment or intrusive and shameless advertising.


I've been experiencing the same issue as Nomen with Firefox 9.0.1 on 98SE. Unfortunately I can't find the proper settings. If I go to Menu > Options > Content > Fonts & Colors > Advanced > Allow pages to choose their own fonts [...] and enable it, most or all of the text becomes a random series of (capital) letters. if I disable it and go to FontAwesome homepage, for example, the icon fonts won't be displayed, although that particular font is installed. Even with your whole collection of fonts installed, it won't work. Actually it won't work with that setting either disabled or enabled. :(

Default character encoding is set to Unicode (UTF-8), which has an impact on reading/saving some settings files for the current profile and it's best not to tamper with.




Does anybody have a working solution for Firefox 9.x on a 9x system...? :(

Link to comment
Share on other sites

Thanks for the feedback. Do you have KernelEx installed/enabled (for Firefox)? I have the official 4.5.2 installed and running in Default compatibility mode.

I wonder what exactly could be the cause of this misbehavior...

Link to comment
Share on other sites

I've jumpers KEX update 7 installed. The mode makes no difference, default mode, XP or Win2000. I can't remember, that the problem with FF occured in the past with official 4.5.2. I believe the installed fonts have an effect, because of my tests with XP fonts, see above. But the reason in your case may be another.


Also interesting for me is why the problem on XP doesn't occur with regard to Opera. Can then be, loblo your assumption the support for webfonts in Opera is buggy or out of date? Maybe there must be another reason or a further reason.

Link to comment
Share on other sites

Thank you, it kinda narrows the issue down to 98(SE) vs ME, at least apparently.

I really, really wonder if a CJK Windows 9x does experience such issues, because I suspect it's only Unicode vs ANSI here and those versions may be more resiliant to this.

Link to comment
Share on other sites


do you think that this trick of disabling Webfonts download and installing instead those 12 fonts,

could also speed browsing with a old & slow processor or a bad bandwidth,

because the system won't have to download those fonts before displaying the page?


That is to say, could it be useful to disable webfonts even in opera 11 that is not buggy?

Link to comment
Share on other sites

@ loblo
BTW, your explanation that Opera 12.02 is buggy is not that simple because it works fine with XP and Win7.
Must be that the feature run differently between Opera 11 and 12, and Win9x doesn't support the new implementation.

BTW again, the only Font viewer that was able to display such Unicode fonts *in Win 98* was ... CHARMAP.EXE from Windows XP.
All the others I've tried only show the ANSI map characters.

@ Drugwash
Your page: https://duckduckgo.com/?q="noticons.ttf"  is fine here with Win98 SE (KEx 4.5.2, RP 9.7) in Opera 11.01 and 12.02 even with Webfonts download enabled.

Read here if it can help you ( https://en.forums.wordpress.com/topic/alternative-for-wp-dashboard-pages-webfont ):
How to disable the on-the-fly use of downloadable web fonts in your browser?
Firefox option: open about:config, and set gfx.downloadable_fonts.enabled to false.
... Sadly, my above solution is not adequate...


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...