Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

KernelEx 4.5 Core Updates (4.5.2016.17)


Recommended Posts

All the 9x-compatible "toys" that I've built are compressed with UPX and the Unicode ones are compressed with MPRESS (see the repository in my signature).

My connection is metered and HDD free space is getting scarce.

What now?


And if I may ask, just out of curiosity: why is this Flash so important to you people that most discussions here revolve around it? I've kept it disabled on all my computers for years because I consider it one of the most dangerous technologies. Never missed it for a second. If I want access to a YouTube video I just download it through Firefox -> FlashGot -> FlashGet as MP4 and watch it offline in GOM Player. And if web designers are so limited that they can't offer regular menus/elements when no Flash is available then those pages will get blacklisted forever. Simple as that!

Link to comment
Share on other sites

Weird, today it worked !

For 2.9.1. I needed to add to kstub.ini [ntdll.dll]:





and SeaMonkey 2.9.1 loaded but always froze after a few seconds.


Added info: SM 2.7.2 and 2.8. are a little bit more stable than 2.9.1. but also freeze sooner or later.

Edited by MiKl
Link to comment
Share on other sites



Release 9:

I can't run Opera 11.64 / 12.02 with comp. mode Win2000SP4 anymore.

Kext doesn't matter. I testet with a modified, the original Kstub822.ini and without Kext. Then I checked on two other machines. Opera doesn't start. It runs with default options [KernelEX is enabled] only, but of course then the menus are unusable.


Opera starts if I replace Kexbasen 4.5.2015.9 by 4.5.2015.8.


Release 10: I still can't run Opera. Apparently my problem is caused by Kexbasen.dll.

Jumper, I don't know, if the KexApiLog might help:

Opera 11.64.7z

Link to comment
Share on other sites

All issues I reported are gone.  :yes:


I found two new problems related to kexbasen.dll however:


Gimp plugins crash on execution.


I have constant crashes in git.exe when executing console programs in the wonderful Mintty terminal emulator executed from within Git. This is just annoying  as Mintty remains otherwise fully functional as far as I can see.

**********************************************************************Date 12/03/2015 Time 02:15GIT caused an invalid page fault inmodule GIT.EXE at 0177:0046d874.Registers:EAX=00000000 CS=0177 EIP=0046d874 EFLGS=00010246EBX=00000008 SS=017f ESP=008cfd30 EBP=008cfd88ECX=00000000 DS=017f ESI=00000020 FS=7157EDX=8383003d ES=017f EDI=0000001c GS=0000Bytes at CS:EIP:8b 00 85 c0 0f 84 0f 02 00 00 31 ff 31 db eb 12 Stack dump:009e051c 008cfd64 008cfd68 00000000 008cfd60 00000004 bff6bb26 8339e9ec 00000080 7c001f5e 7c049638 008cfda4 00000000 009e0400 00000000 00000008 **********************************************************************Date 12/03/2015 Time 02:16GMIC_GIMP caused an invalid page fault inmodule MSVCRT.DLL at 0177:7c00ef24.Registers:EAX=00000000 CS=0177 EIP=7c00ef24 EFLGS=00210212EBX=0000000b SS=017f ESP=0138f974 EBP=0138f9a4ECX=015026b0 DS=017f ESI=00000000 FS=3cefEDX=8383003d ES=017f EDI=0000000b GS=0000Bytes at CS:EIP:8b 06 85 c0 75 d4 8b c6 2b 05 c0 95 04 7c 5e c1 Stack dump:00000000 7c00f06e 01502250 01502250 00000000 01502190 7c003773 0000000b ffffffff 00000000 00000000 00000000 0138f9f8 7c02624f 01502250 00000001 **********************************************************************Date 12/03/2015 Time 02:18GIMPRESSIONIST caused an invalid page fault inmodule MSVCRT.DLL at 0177:7c00ef24.Registers:EAX=00000000 CS=0177 EIP=7c00ef24 EFLGS=00010212EBX=0000000b SS=017f ESP=0075fac4 EBP=0075faf4ECX=0107ad30 DS=017f ESI=00000000 FS=52d7EDX=8383003d ES=017f EDI=0000000b GS=0000Bytes at CS:EIP:8b 06 85 c0 75 d4 8b c6 2b 05 c0 95 04 7c 5e c1 Stack dump:00000000 7c00f06e 0107ac50 0107ac50 00000000 0107a880 7c003773 0000000b ffffffff 00000000 00000000 00000000 0075fb48 7c02624f 0107ac50 00000001 

Both problems go away when reverting to original xeno kexbasen.dll and keeping kernelex.dll v11 and kexbases.dll v10.


Gimp 2.8.16 and Git 1.9.5 (including Mintty) uploaded here: http://filebin.net/ztjlv6bw04

Link to comment
Share on other sites

Hi Jumper, when you have the time could you look into browser printing running v10 ?

With SeaMonkey 2.0.14 I can still print without any problems but SeaMonkey 2.1 and higher fail to print anything useful.


If I patch xul.dll with [dll replacements] comdlg32.dll=comdlgEx.dll SM prints only blank pages. Both physical and to PDF.

With original xul.dll SM prints:

- from emails only header and subject but not the actual content

- from websites only blank pages or the website's background if I activate that in the printing dialogue.



Edit: Depending on hardware environment and SM build the above is also sometimes the other way around.

Edited by MiKl
Link to comment
Share on other sites

While testing SeaMonkey 2.3.3. I was hit by a BSOD.

Datum 12/04/2015 Uhrzeit 20:58SEAMONKEY verursachte einen Fehler durch eine ungültige Seitein Modul KRNL386.EXE bei 0001:00002b23.Register:EAX=8f231f60 CS=014f EIP=00002b23 EFLGS=00000606EBX=00004258 SS=598f ESP=00005ab6 EBP=00005b1cECX=00002a90 DS=0177 ESI=8f23c11c FS=0167EDX=0000425f ES=0110 EDI=0000aa3c GS=0097Bytes bei CS:EIP:f3 67 66 a5 1f 52 66 50 e8 d0 23 65 80 4f 05 80Stapelwerte:000000ff ae200000 5b1c0000 5ad80000 0000e99f aac00000 aa400000 a6800000 00000000 01402cd3 22510000 00000840 00000840 0000aaa0 0000a680 00000523

And maybe related:

Datum 12/03/2015 Uhrzeit 23:09EXPLORER verursachte einen Fehler durch eine ungültige Seitein Modul KERNEL32.DLL bei 016f:bff88396.Register:EAX=c003098c CS=016f EIP=bff88396 EFLGS=00010206EBX=01ecffec SS=0177 ESP=01e8ff90 EBP=01e90108ECX=00000000 DS=0177 ESI=00000000 FS=3d87EDX=bff76855 ES=0177 EDI=bff79060 GS=0000Bytes bei CS:EIP:53 56 57 8b 75 10 8b 38 33 db 85 f6 75 2d 8d b5Stapelwerte:

No 'Stapelwerte' were saved.


I am reverting back to kernelex.dll v9 now. Hope to hear from Jumper soon. Thanks !!


Added info: I am sure that Jumper is aware but with the v9/v10 configuration OpenOffice 3.2.1. does not start because of FindActCtxSectionStringA & FindActCtxSectionStringW now implemented in kexbases.

Edited by MiKl
Link to comment
Share on other sites

With full version v9 and SeaMonkey 2.4.1. (un-hexed xul.dll) :

I could succesfully 'print to PDF' a multi-page Email !! Of websites only page 1 is printed - all other pages are blank.



Have tested now SeaMonkey 2.6.1. with v9 and original xul.dll.

- Printing emails is still fine.

- Printing of certain websites works great while others fail with only priting page 1 or only fragments.

Maybe a Java and/or Javasript issue ?

@ Jumper, should I continue to post my print results here or in the dedicated thread ?

Edited by MiKl
Link to comment
Share on other sites

  • 4 weeks later...

Release.11 Changelog:

* some apis added to kexbases

* some forwards removed from kexbasen (use Kexports for updated api lists)

* includes map and pdb files for debugging

* updated installer


The following details are still not quite complete:

KernelEx 4.5.2015.11 file summary changelog

apilibs\kexbasen\ ntdll\ntdll_forwards.c  71 forwards to Advapi32 need code, so moved to kexbases (see below)  11 forwards to Kernel32 moved to kexbases for direct linking winspool\_winspool_stubs.c   1 new stub: XcvDataWapilibs\kexbases\ dirlist  shlwapi added advapi32\_advapi32_stubs.c   4 new SystemFunction0nn stubs (29,33,34,35)  27 new Trace stubs comdlg32\printdlgex.c  Legacy PrintDialogExA and W stubs replaced with code from Ley0k (v4.5.3) kernel32\_kernel32_stubs.c  25 new stubs from jumper's Kstub822.ini file kernel32\gettickcount64.c (new file)   1 new implementation *** increased CriticalSection function robustness. ntdll\_ntdll_stubs.c  10 new Rtl (8), Csr, and Nt stubs ntdll\nt.c (new file)  6 new implementations ntdll\rtl.c (new file based on Ley0k)  ?? new? whats? ntdll\rtlsting.c (new file based on Ley0k)  ?? new? whats? ntdll\_redirects.c (new file)  71 redirects to Advapi32 with BOOL return code converted to NTSTATUS shell32\_shell32_stubs.c  27 new IL (15) and other (12) stubs shlwapi\_shlwapi_apilist.c (new file) shlwapi\_shlwapi_apilist.h (new file) shlwapi\_shlwapi_stubs.c (new file)  10 new stubs user32\_user32_stubs.c  4 new stubs

Kexbasen.dll 4.5.2015.11 api changelog

[WINSPOOL.DRV]+XcvDataW    [NTDLL.DLL]-CsrGetProcessId-LdrGetProcedureAddress-NtAccessCheck-NtAccessCheckAndAuditAlarm-NtAdjustGroupsToken-NtAdjustPrivilegesToken-NtAllocateLocallyUniqueId-NtAllocateVirtualMemory-NtCloseObjectAuditAlarm-NtCreateKey-NtDeleteKey-NtDeleteObjectAuditAlarm-NtDeleteValueKey-NtDuplicateToken-NtEnumerateKey-NtEnumerateValueKey-NtFlushKey-NtLoadKey-NtOpenKey-NtOpenObjectAuditAlarm-NtOpenProcessToken-NtOpenThreadToken-NtPrivilegeObjectAuditAlarm-NtPrivilegedServiceAuditAlarm-NtQueryInformationToken-NtQueryKey-NtQuerySecurityObject-NtQueryValueKey-NtReplaceKey-NtRestoreKey-NtSaveKey-NtSetInformationToken-NtSetSecurityObject-NtSetValueKey-NtUnloadKey-NtWaitForSingleObject-RtlAddAccessAllowedAce-RtlAddAccessDeniedAce-RtlAddAce-RtlAddAuditAccessAce-RtlAllocateAndInitializeSid-RtlCaptureStackBackTrace-RtlCopySid-RtlCreateSecurityDescriptor-RtlDeleteAce-RtlDeleteCriticalSection-RtlDeleteSecurityObject-RtlEnterCriticalSection-RtlEqualPrefixSid-RtlEqualSid-RtlFirstFreeAce-RtlFreeSid-RtlGetAce-RtlGetControlSecurityDescriptor-RtlGetDaclSecurityDescriptor-RtlGetGroupSecurityDescriptor-RtlGetOwnerSecurityDescriptor-RtlGetSaclSecurityDescriptor-RtlIdentifierAuthoritySid-RtlInitializeCriticalSection-RtlInitializeCriticalSectionAndSpinCount-RtlInitializeSid-RtlLeaveCriticalSection-RtlLengthRequiredSid-RtlLengthSid-RtlNewSecurityObject-RtlQueryInformationAcl-RtlQueryRegistryValues-RtlQuerySecurityObject-RtlSetControlSecurityDescriptor-RtlSetDaclSecurityDescriptor-RtlSetGroupSecurityDescriptor-RtlSetInformationAcl-RtlSetOwnerSecurityDescriptor-RtlSetSaclSecurityDescriptor-RtlSetSecurityObject-RtlSubAuthorityCountSid-RtlSubAuthoritySid-RtlValidAcl-RtlValidSecurityDescriptor-RtlValidSid-VerSetConditionMask

Kexbases.dll 4.5.2015.11 api changelog

[KERNEL32.DLL]+AddVectoredExceptionHandler+AttachConsole+CheckNameLegalDOS8Dot3+CheckRemoteDebuggerPresent+CreateMemoryResourceNotification+DebugActiveProcessStop+DebugSetProcessKillOnExit+DnsHostnameToComputerNameW+FindFirstVolumeA+FindFirstVolumeW+FindNextVolumeA+FindNextVolumeW+FindVolumeClose+GetConsoleDisplayMode+GetGeoInfoA+GetGeoInfoW+GetProcessHandleCount+GetSystemRegistryQuota+GetSystemTimes+GetThreadId+GetTickCount64+GetUserGeoID+LeaveCriticalSection+QueryMemoryResourceNotification+RemoveVectoredExceptionHandler+SetCriticalSectionSpinCount+SetFileValidData+WerRegisterMemoryBlock    [USER32.DLL]+ChangeWindowMessageFilter+GetWindowRgnBox+IsWinEventHookInstalled+UserHandleGrantAccess    [ADVAPI32.DLL]+CloseTrace+ControlTraceA+ControlTraceW+EnableTrace+FlushTraceA+FlushTraceW+GetTraceEnableFlags+GetTraceEnableLevel+GetTraceLoggerHandle+OpenTraceA+OpenTraceW+ProcessTrace+QueryAllTracesA+QueryAllTracesW+QueryTraceA+QueryTraceW+RegisterTraceGuidsA+RegisterTraceGuidsW+StartTraceA+StartTraceW+StopTraceA+StopTraceW+SystemFunction029+SystemFunction033+SystemFunction034+SystemFunction035+TraceEvent+UnregisterTraceGuids+UpdateTraceA+UpdateTraceW    [COMDLG32.DLL]~PrintDlgExA~PrintDlgExW    [SHELL32.DLL]+ILAppendID+ILClone+ILCloneFirst+ILCombine+ILCreateFromPathW+ILFindChild+ILFindLastID+ILFree+ILGetNext+ILGetSize+ILIsEqual+ILIsParent+ILLoadFromStream+ILRemoveLastID+ILSaveToStream+PathCleanupSpec+SHCloneSpecialIDList+SHCoCreateInstance+SHDefExtractIconW+SHEnumerateUnreadMailAccountsW+SHFindFiles+SHGetFolderPathAndSubDirW+SHGetIconOverlayIndexW+SHPathPrepareForWriteW+SHRestricted+SHSetLocalizedName+SHSetUnreadMailCountW    [NTDLL.DLL]+CsrGetProcessId+NtAccessCheck+NtAccessCheckAndAuditAlarm+NtAdjustGroupsToken+NtAdjustPrivilegesToken+NtAllocateLocallyUniqueId+NtAllocateVirtualMemory+NtClose+NtCloseObjectAuditAlarm+NtDeleteObjectAuditAlarm+NtDeviceIoControlFile+NtDuplicateToken+NtOpenObjectAuditAlarm+NtOpenProcessToken+NtOpenThreadToken+NtPrivilegeObjectAuditAlarm+NtPrivilegedServiceAuditAlarm+NtQueryInformationToken+NtQuerySecurityObject+NtSetInformationToken+NtSetSecurityObject+NtShutdownSystem+NtWaitForSingleObject+RtlAddAccessAllowedAce+RtlAddAccessAllowedAceEx+RtlAddAccessDeniedAce+RtlAddAccessDeniedAceEx+RtlAddAce+RtlAddAuditAccessAce+RtlAdjustPrivilege+RtlAllocateAndInitializeSid+RtlCaptureStackBackTrace+RtlCharToInteger+RtlCompareMemory+RtlCompareUnicodeString+RtlCopySid+RtlCreateEnvironment+RtlCreateSecurityDescriptor+RtlCreateSecurityDescriptor+RtlCreateTagHeap+RtlCreateUserThread+RtlDeleteAce+RtlDeleteCriticalSection+RtlDeleteResource+RtlDeleteSecurityObject+RtlEnterCriticalSection+RtlEqualPrefixSid+RtlEqualSid+RtlEqualUnicodeString+RtlExpandEnvironmentStrings_U+RtlFirstFreeAce+RtlFreeAnsiString+RtlFreeOemString+RtlFreeSid+RtlFreeUnicodeString+RtlGetAce+RtlGetControlSecurityDescriptor+RtlGetDaclSecurityDescriptor+RtlGetGroupSecurityDescriptor+RtlGetOwnerSecurityDescriptor+RtlGetSaclSecurityDescriptor+RtlIdentifierAuthoritySid+RtlInitAnsiString+RtlInitAnsiStringEx+RtlInitOemString+RtlInitOemStringEx+RtlInitString+RtlInitUnicodeString+RtlInitializeBitMap+RtlInitializeCriticalSection+RtlInitializeCriticalSectionAndSpinCount+RtlInitializeCriticalSectionEx+RtlInitializeResource+RtlInitializeSid+RtlLeaveCriticalSection+RtlLengthRequiredSid+RtlLengthSid+RtlMultiByteToUnicodeSize+RtlNewSecurityObject+RtlOemToUnicodeN+RtlPrefixUnicodeString+RtlQueryInformationAcl+RtlQuerySecurityObject+RtlSetDaclSecurityDescriptor+RtlSetGroupSecurityDescriptor+RtlSetInformationAcl+RtlSetOwnerSecurityDescriptor+RtlSetSaclSecurityDescriptor+RtlSetSecurityDescriptorControl+RtlSetSecurityObject+RtlSubAuthorityCountSid+RtlSubAuthoritySid+RtlSystemTimeToLocalTime+RtlTryEnterCriticalSection+RtlUnicodeStringToOemString+RtlUnicodeToOemN+RtlUniform+RtlUpcaseUnicodeChar+RtlUpcaseUnicodeString+RtlValidAcl+RtlValidSecurityDescriptor+RtlValidSid+RtlxUnicodeStringToOemSize+VerSetConditionMask
Edited by jumper
Link to comment
Share on other sites

I'm having a problem with the 4.5.2015.11 update, for the first time ever.


After replacing the files in the KernelEx folder, Windows would not then load fully.


It gets as far as the desktop, but then an error message saying that "Runonce" has performed an illegal operation pops up, closely followed by a message that "Explorer" has done the same. The load then stops.


The culprit appears to be Kexbasen.dll. If I replace the new 4.5.2015.11 version with the previous 4.5.2015.10 version, leaving the other files as they are, it all comes good.

The update batch file reports a syntax error, but I can't see what it is. It does seem to still execute as it should and put all the new files in the right place.

Any suggestions as to what might be wrong?


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...