Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


thirteenth

Last Versions of Software for Windows 2000

Recommended Posts

On 2016/9/27 at 6:54 AM, pointertovoid said:

Resource Hacker v4.0.0 seems to run properly on W2k. v4.2.5 installs but crashes when opening a document. v4.3.20 installs but crashes at launch.
On extended W2k, v4.2.5 displays icons badly but might run (experimented shortly) and it offers functions that don't work properly on v4.0.

v4.5.30 seems to work on extended kernel.  it shows icons background image is black. :3

The installer may be blocked on HK_CLASS_ROOT\exefile\shell by access right

Share this post


Link to post
Share on other sites

Notepad++ 6.x and 7.x seems to work, except there's no toolbar.

After hacking the version checks in the msi, Adobe Audition 3.0 seems to work as well.

c

Share this post


Link to post
Share on other sites
15 hours ago, cc333 said:

Notepad++ 6.x and 7.x seems to work, except there's no toolbar.

After hacking the version checks in the msi, Adobe Audition 3.0 seems to work as well.

c

Notepad++ 6.x and 7.x needs comctl32.dll v6

Share this post


Link to post
Share on other sites

> Just goes to show that "officially supported" and "won't work" are not synonymous.
Huh? Let's hope not!

Unfortunately: "officially supported" and "will work" are not synonymous.
Fortunately: not being "officially supported" and "won't work" are not synonymous!

lol



Share this post


Link to post
Share on other sites

With BWC Kernel

Also works: :P

Winrar 5.50 final

Foxit reader 8.3.2.25013

aimp 4.50.2026 beta3

Osoft! Ocam 415.0 (problem: the video is flipped)

Notepad++ 7.5.1

Atlantis word 3.0.1

VLC 2.26

SumatraPDF 3.2.10740 prerelease

Ultraiso 9.7.0.3476

 

Not working: :wacko:

CCleaner 5.35

Edited by cuzcoprince
added items

Share this post


Link to post
Share on other sites
13 hours ago, cuzcoprince said:

With BWC Kernel

Also works: :P

Winrar 5.50 final

Foxit reader 8.3.2.25013

aimp 4.50.2026 beta3

Osoft! Ocam 415.0 (problem: the video is flipped)

Notepad++ 7.5.1

Atlantis word 3.0.1

VLC 2.26

SumatraPDF 3.2.10740 prerelease

Ultraiso 9.7.0.3476

 

Not working: :wacko:

CCleaner 5.35

Hi.

CCleaner 5.35 needs XP compatible settings :3

  • Like 1

Share this post


Link to post
Share on other sites

Gaming software:

Origin (legacy version for XP/Vista) - OK

Steam not working.

Edited by Andreasmir

Share this post


Link to post
Share on other sites

It's been over six months since I've posted in this thread, but I wanted to demonstrate that the current versions of Adobe Flash Player 27 (27 0 0 187) still work on Windows 2000. I run Win2K on my T23 with SP4, the SP4 rollup, and UURollup.

The browsers tested are Internet Explorer 5.5 SP2, Firefox ESR Portable 45.8.0, and Chromium 34.0.1847 (the last for SSE/non-SSE2 processors).

The installers can be downloaded from here (Firefox and Chromium), and here (Internet Explorer ActiveX)

fpie27x187.jpg

fpmf27x187.jpg

fpgc27x187.jpg

Share this post


Link to post
Share on other sites

Pale Moon 26.5 for Win2000:

updated test binary:
https://o.rths.cf/gpc/files1.rt/palemoon-26.5.0-20180516.win2000.7z

and updated test binary of K-Meleon 74 with Goanna 2.2(palemoon-26.5) that works in Win2000:
https://o.rths.cf/gpc/files1.rt/KM74-g22-20180516.win2000.7z

base repo: https://github.com/roytam1/palemoon26/tree/oldvc

Changes since last build:
- JSCompartment: disable compiling with optimization, check pointers to avoid crash (6bc036e1f)
- cherry-picked upstream changes (via tbb-esr24): bug811122, bug922603 (2fa0b15ad)
- cherry-picked upstream commit: James Kolb - Bug 889693 - Implement MaskSurface in DrawTargetCairo. r=Bas (d9e56150b)
- Restore Win2000 support code (4/x) nsLocalFileWin::CopySingleFile: reverting part of logic to esr10 to avoid CopyFileExW() failing with ERROR_INVALID_PARAMETER in win2000 (81d6870c3)
- cherry-picked upstream commit: Bug 895964 - "Could not create service for entry Disk Space Watcher Service" r=bent (d08e200dd)
- aboutDialog: remove (Atom/WinXP) tag (9d991aed5)
- sqlite: don't use malloc_usable_size() in debug build, which cause unresolved symbol on linking (39900b646)
- sqlite: downgrade to esr24-bundled version (3.7.11) for better old OS compatibility softoken: don't use SQLITE_FCNTL_TEMPFILENAME for old sqlite compatibility (8e13ffdc1)
- storage: don't use sqlite3_mutex_held()and sqlite3_mutex_notheld() even on debug build, which cause unresolved symbol in vc8 on linking (c7cc15602)
- aboutDialog: add back #expand directive (f293e24e2)

Edited by roytam1

Share this post


Link to post
Share on other sites
On 11/18/2017 at 8:07 PM, sdfox7 said:

It's been over six months since I've posted in this thread, but I wanted to demonstrate that the current versions of Adobe Flash Player 27 (27 0 0 187) still work on Windows 2000. I run Win2K on my T23 with SP4, the SP4 rollup, and UURollup.

The browsers tested are Internet Explorer 5.5 SP2, Firefox ESR Portable 45.8.0, and Chromium 34.0.1847 (the last for SSE/non-SSE2 processors).

The installers can be downloaded from here (Firefox and Chromium), and here (Internet Explorer ActiveX)

fpie27x187.jpg

fpmf27x187.jpg

fpgc27x187.jpg

Do you have a copy of the UURollup and the others? It seems they aren't available online anymore.

Share this post


Link to post
Share on other sites

@~♥Aiko♥Chan♥~ 

they are in my Windows 2000 Important EOL Updates folder:

http://sdfox7.com/2000/Important_EOL_Updates/

UURollup is here:

http://sdfox7.com/2000/Important_EOL_Updates/Windows2000-UURollup-v11-d20141130-x86-ENU.7z

The latest Firefox and Internet Explorer Flash Player installers for Windows 2000 are here:

http://sdfox7.com/2000/Important_EOL_Updates/install_flash_player.exe and http://sdfox7.com/2000/Important_EOL_Updates/install_flash_player_ax.exe

Internet Explorer 32 bit versions are here:

http://sdfox7.com/ie/win32/

  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, roytam1 said:

PM27 requires KernelEx.

I am not using KernelEx or Pale Moon, just the portable version of New Moon. I also have UURollup installed which might make a difference.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×