Jump to content

Silent .NET Maker synthesized 20100118 - W2K/XP/2K3 x86


Recommended Posts


Where can I get Microsoft Visual C++ 2005 Service Pack 1 redistributable runtime package, the last version? I want to replace the net framework builtin package with the latest one using your script?

Can it be done?



Edited by atolica
Link to comment
Share on other sites


There are bugs, I fixed those you mention, will be ready for next version soon. Don't use actual version except for testing purposes.

I could not manage to recreate error with XPS's update.exe file not found. I tried a RunOnce install but it installs fine.

It seems you're meaning that after you set the target os version through .ini file, this error don't appear but this doesn't make sense to me as thnx4thepen have the same error after setting target OS version from .ini file.


You better not use 20091029 except for testing, it contain serious bugs, wait for the next version, soon. What you search is Visual C 8 link in Supported File List section of the guide, I have to clarify it.

Edited by strel
Link to comment
Share on other sites


All bugs I could recreate are now fixed, and some extras added. See changelog.

I have not tested the behavior of SNMsynth installers/add-ons after removing VC runtimes and preinstalled them with runtime packs (in supported files list). Any info on this is welcome.

...in my test of SNMsynth, KB958484 doesn't have its files updated in .NET 3.5(files are still with build number 1), but entries are present in vs_setup.msi. I think you may applies *.msp earlier than NET35SLIMDOWN.mst...

If you're referring to files listed here, these files are not included in the cab file of KB958484.

About the .msi cache installers renaming, seems that finally I was right. It is required, yes, I see the same thing as you with frameworks installed I changed those values in registry and KB951847 fix still worked, but now, looking for the KB951847 not working problem inserted in 20091029 version, I found that what's failing was precisely this.


As of 7-zip 9.07, you must specify the type during extraction of executable files. Otherwise it will extract each individual resource and binary section...

Later you added you were refering to x switch, but this switch is not used to extract the file partially, e switch is used instead. 7za.exe 9.07 beta is supported.

Glowy & thnx4thepen

I still cannot recreate this error you pointed. Check again with the new version.

Enjoy :thumbup

Edited by strel
Link to comment
Share on other sites

Unfortunately the nLite AddOns don't work


description=.NET 2.0 SP2 passive installer
title=.NET Framework(s)



Name of silent installer: 2KDNF20SP2.exe

Same problem for .Net 1.1 sp1

I'll check the other aspects shortly.

Edited by Kurt_Aust
Link to comment
Share on other sites

WU still complains about KB951847: Microsoft .NET Framework 3.5 Service Pack 1 en .NET Framework 3.5 Family Update x86

Langpack and OS detection fixed.

I'll try a rerun without stripping anything out of the package (currently updating VC9 externally and excluding WIC)

Link to comment
Share on other sites

Running the 2K versions as silent installers rather than nLite AddOns appears (as far as I can tell) to work perfectly.

Files seem to be the correct version and Windows Update is happy, I only fired up one .Net 2.0 dependant application for testing though.

For .NET 2.0, the processing order is perhaps not optimal, but works fine:



NDP20SP2-KB971111-x86.exe Required for W2K


Link to comment
Share on other sites

Fixed minor bug (not harming at all) putting some not needed fixes in the .\TMP folder.

New version released!


I made a fresh test and KB951847 is not appearing in win/ms update for me. I need more data.

Link to comment
Share on other sites

Testrun without stripping anything works fine..

I'll do some more testing.

EDIT:Problem is somewhere in the VC packages, so no problem in the script for me anymore. Trying different setups to see what the problem is.

Edited by Glowy
Link to comment
Share on other sites

I've tested the 20091103_SNMsynth version: the pop-up again appear.

I simply executed the installer from the desktop in a Virtual Machine (VirtualBox 2.2.2 Windows XP SP3 Full updated).

I checked the updates installed:



and the software that required .NET Framework 3.5SP1: Paint.NET 3.5 Beta (build 3591) run.

The only problem is this pop-up...


PS thanks for your hard work :)


Link to comment
Share on other sites


Can you confirm this file is where it is supposed to be? I mean try uncompressing the installer and look for this file in its folder.

Has the building process output showed "Updating XPS driver with latest files from XP+2K3 KB971376..." message?

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...