Jump to content

Making Nero 8 a silent install


xavier73
 Share

Recommended Posts

ill be trying an other way to install nero witht he script, instead of pakign the works in a sfx, ill leave all files ina folder and run the install from there on the disc,my guess is in a sfx,the temp files get deleted..so thtas prolly why teh script wasint finding the required files to finish setup,but ill launch it via a cmd file, i should launch it directly from the autoit script but i have some custom things that i want with my nero install,if it dosent work,ill try directly form the compiled autoit exe.if it still dosent work,i think adding support to search optical drives for the said file to finishup might be required.....

Link to comment
Share on other sites


How do i disable clean sofware on vista?

i dont have ccleaner.

Lolol what?

edit:ok finaly got nero 8 working via runonceex, at runonceex,i called the autoit script from a folder instaed of an sfx,and its called directly to the .exe not via cmd.and also,all is being installed from the disc.

Edited by bober101
Link to comment
Share on other sites

So what exactly did you do?

Don't pack it with 7zip or WinRAR, because they are extracted to temp files which are deleted and cannot be called from again when you restart.

Just put the autoit installer and the Nero installer in a directory (such as WPI install directory on your disk) and call it from there, you will get a RunOnce box and the installer will fail, then during next boot the nero installer should run and install successfully during second login.

Edited by ricktendo64
Link to comment
Share on other sites

So what exactly did you do?

Don't pack it with 7zip or WinRAR, because they are extracted to temp files which are deleted and cannot be called from again when you restart.

Just put the autoit installer and the Nero installer in a directory (such as WPI install directory on your disk) and call it from there, you will get a RunOnce box and the installer will fail, then during next boot the nero installer should run and install successfully during second login.

Yes I dont have it is in a folder to the desktop where does the files extract later though.

Link to comment
Share on other sites

@SuperDuy – I have already answered your question, please look here.

I have worked further with the script for you users to test... :D

Changelog: 2.2

* Added: Major internal changes and revamped install routine

* Added: Optional fixed location for already extracted files

* Added: Option to delete extracted and temporary files after successful install

* Added: Optional restart procedure and internal support for 'GUIRun'

The big change is that the installer now tries to install anyway, even if file rename operations are pending and the extracted content can be reused after restart.

Please read the FAQ regarding the installation over at NeroAG site if you still have issues.

Script is found in my signature :hello:

Link to comment
Share on other sites

I have 2 questions about the Nero 8.1.1.0b autoit script.

First:

For the variable $ID, what is wrong with my installation directory code? The script generated an error during install saying my installation directory was not valid.

Here is a screenshot-->post-158493-1193467216_thumb.jpg

Below is the code I used in the .au3 file:

$ID = @ProgramFilesDir & "\Nero"

Second:

I don't understand what I need to put for the $EF variable. I have just been leaving it blank, as I am simply running the .exe package I directly downloaded from Nero. Is that what I should be doing?

$EF = ""; Already extracted folder example: $EF = "D:\Apps\Extracted\Nero8"

Any help to these questions would be greatly appreciated! Thanks a lot for the amazing script, btw!

Edited by radigast
Link to comment
Share on other sites

Any help to these questions would be greatly appreciated! Thanks a lot for the amazing script, btw!

You don't have to specify any path when using this script. Leave these settings blank as it will use the standard directory for your programs anyway. These settings are for more experienced users who want to install in/from a different location and they have to be fixed as it seems it will not work when adding macros like @ProgramFilesDir.

Link to comment
Share on other sites

Hi CE0Ceo,

Thanks for the script. But I still cannot install nero 8 with or without the script. The msg said "the wizard was interupted before nero 8 demo before completely installed" keep appear. Can u help me?

Link to comment
Share on other sites

@Yadzil - This is not an easy problem to solve because there are so many aspects that need to be looked at. I really do hope you don't get this right after an unattended installation, otherwise you are in real trouble finding what is causing this message. :no:

Please look through the installation-FAQ… and if that is not helping, you should try Nero CleanTool. After a quick search on other forums there can be troubles with ASPI-layers and certain configurations, but that one is really rare. Otherwise I'm clueless… :wacko:

Link to comment
Share on other sites

Thanks CEoCeo.

I manage to install Nero 8. Seem Nero 8 needs windows update need to be enable.

But I think this methode is the simplest. Even it like the previous version of nero silent install.

But what the different the swicth '/qb' and '/qb!' that been used in nero version 7?

Link to comment
Share on other sites

I used the script from the first page, then slightly adjusted it it works, also customized...:

@echo off
title Nero 8.1.2.0
echo.
echo Updating DirectX 9c Redistributable...
start /wait Data\Redist\DirectX\dxsetup.exe /silent
echo.
echo VCR...
start /wait Data\Redist\VCRedistSetup.msi /passive /norestart
echo.
echo Nero XML...
start /wait Data\Redist\neroxml.msi /passive /norestart
echo.
echo KB884016 v2...
start /wait Data\Redist\WindowsInstaller-KB884016-v2-x86.exe /passive /norestart
echo.

it works without the first lines, but you do need some of the files in that part

this is the part I edited:

@echo off
title Nero 8.1.2.0
echo Installing Nero Premium 8...
start /wait SetupX.exe /qb! /NORESTART ADDLOCAL="NeroBackItUpCB9D5429,NeroBurningRomBCAFF604,NeroBurnRights72CC518F,NeroStartSmartB035464E" RebootYesNo="No" NERO_SCOUT="FALSE" serialnum_userval="**SERIAL HERE***" AgreeToLicense="Yes" EULA_AGREEMENT=1

as you can see I only installed BackItUp, BurningRom, Burn Rights and SmartStart

full list of avalabel features:

NeroBackItUpCB9D5429
NeroBurningRomBCAFF604
NeroBurnRights72CC518F
NeroCoverDesigner7CE8D626
NeroFastCDDVDBurningPluginC5AB9CFD
NeroHome2FF8B816
NeroMediaHome53BEFA20
NeroPhotoSnapED1EAF52
NeroRecode6035F00C
NeroShowTimeD773A6E2
NeroSoundTrax716FE146
NeroStartSmartB035464E
NeroCDDVDSpeed7DFFCC12
NeroInfoTool7AB7A0CD
NeroVision57D52359
NeroWaveEditorFA3A3F7B
InCDC9AC4AC7

I got these from a NERO 7 installation so they might not all work

to bad smartstart keeps crashing on my pc (vista ultibate x64)

Edited by kid1988
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...