Jump to content

Making Nero 8 a silent install


xavier73
 Share

Recommended Posts


CEoCEo, with your script for Nero 8.1.1.0, the installation of Nero 8.1.1.0b is stopped on first

screen (Nero Ask Toolbar window).

I think that something is missed in the script.

Edited by radix
Link to comment
Share on other sites

Finally the AutoIt script is updated to match the current release... :D

Changelog: 2.1

* ReAdded: Support for 'Ask Toolbar'

* Added: Suppress restart dialog box

* Added: Option to install through 'RunOnce' if file rename operations are pending

* Added: Several error checking improvements

* Updated: String values and comments to be more user-friendly

* Fixed: 'Template Packages' string management

* Fixed: Search for Nero 8 Help File Package

EDIT: Updated script again... 2.11

Minor internal changes regarding reboot prompt issues in any language.

Please test and report back your results.

Script is found in my signature :hello:

Edited by CEoCEo
Link to comment
Share on other sites

Thanks 'CEoCEo' for the script. I will get back with the feedback after I get a chance to use it. I do have one suggestion/request, could you please modify the script so that if one leaves the UserName and CompanyName blank then the default is picked up from the system.

I think the following should be changed,

from:

$UN = "UserName"
$CN = "CompanyName"

to:

$UN = ""; UserName
$CN = ""; CompanyName

Thanks.

Link to comment
Share on other sites

im having problems witht eh script, can u explain how and where does the script look for its self when adding to runonce, as im having trouble ,i get an error that the startup app isisnt found.

Really strange :blink: , it's working here...look at line 118 regarding the RunOnce sequence.

I'm using commands other working scripts are using, simple @AutoItExe to specify where the script is located even if it's compiled or not.

Does this script work for anyone?

Link to comment
Share on other sites

I have the same problem I get the error and then restart then nothing comes up.

How do I disbable cleaners?

And where does it extract to?

Mine doesnt have a documents and settings folder.

Edited by SuperDuy
Link to comment
Share on other sites

Just want to report that RunOnce worked for me.

when is ure installer called,@t12-t13 or at runonceex?

WPI... I got the RunOnce pop up from the autoit installer (it exited on its own) then WPI continued installing the rest of my programs. On reboot Nero setup restarted, it extracted and installed successfully.
Link to comment
Share on other sites

How do I disbable cleaners?
Maybe I can implement this… ;)
And where does it extract to?
It’s extracted to the environment variable %TEMP% together with generated folder NERO*

Thanks again ricktendo64, that’s exactly what the script is intended to do. Maybe we all can conclude that this script doesn’t work @t-12 or @t-13? :unsure:

Link to comment
Share on other sites

Well I did not manage to install it once again...

On first logon installation fails,after restart (second logon) installation continues,extracts,tries to configure and install than BANG...look at the screenie...

1784nero.jpg

Link to comment
Share on other sites

I tried the script in a real unattended install and I am glad to report the installation went of perfectly, except for one small problem:

$UN = ""; UserName
$CN = ""; CompanyName

which seemed to work fine with the Nero 7 scripts, does not work here and I ended up with blanks where there ought to be the User and Company names. I would like to point out that I had simply made the above change to the scipt myself, so in case there are any other required changes that were made by CEoCEo to make this work, then that may be the problem. I compared my script with that of CEoCEo and my simply just making the above change is not enough since the script requires further entries to make it work. Lesson learnt, in future be more careful.

Thanks.

Edited by Sanjay
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...