Jump to content



Recommended Posts

HFSLIP will do that for you!

Follow the instructions and everything will be ok.

Well it wasn't for me. HFSlip refused to work.

Is NLite incapable of integrating DirectX, because whenever someone asks about this people never give a straight answer, they just start talking about other programs or complicated manual methods.

I tried using Ryan DX pack but I keep getting an error during Windows setup. HFSlip won't work either.

As a nice simple solution like USP5.2 will probably never be released, I'm left wondering if I will ever get DX slipstreamed.

Link to comment
Share on other sites

Well it wasn't for me. HFSlip refused to work.


HFSlip won't work either.

hi Quisquose! what do you mean HFSLIP doesn't work? perhaps you should post you concern about HFSLIP here: http://www.msfn.org/board/index.php?showforum=129 ... also, i have never encountered members claiming likewise for users of both nLite & RyanVM's pack ... much so HFSLIP ... :huh:
Link to comment
Share on other sites

What do you mean HFSLIP doesn't work? perhaps you should post you concern about HFSLIP

Hi Kiki, :hello: I did think about posting to that forum, but I'm not really an HFSLIP user (I don't find it very intuitive) and I prefer NLite. I only resorted to trying HFSLIP after repeated attempts to integrate DirectX using NLite had failed (and I was getting so fed up that ANY method that worked would have been acceptable to me).

The issue that I was having occurred when running HFSLIP for the second time. Basically nothing would happen at all. No error messages, no pop ups or anything. I could try running the file as many times as I wanted but it just did nothing. At first I left it for ages (thinking it might be doing something in the background) but it wasn't. I went back and followed the HFSLIP guidelines really carefully, step by step. The program always worked on the first launch (it created all the correct folders as expected) but then when it came to the second time to run it, nothing at all would happen. I tried uninstalling and starting again, but the same problem persisted. So I gave up and came back to NLite (which I am more comfortable with).

You shouldn't be getting any errors slipstreaming Ryan's DX Pack.. what error are you getting? Could you tell us a bit more about your nLite? (i.e. attach your LAST SESSION.INI)

Thanks for enquiring into my problem. The error happens during the text mode part of Windows 2000 setup (after the partioning and formatting have completed). The error message says:

The following file in SIF file used by Setup is corrupted or missing value 0 on the line in section [sourcediskfiles.x86] with key "d3dx9_24.dll"

I checked my files and the file mentioned is actually present (along with other DX files). I also checked my txtsetup.sif and the line referred to by the error message is:

d3dx9_24.dll = 100,,,,,,,2,0,0

but I'm afraid that I don't really understand the contents of the txtsetup.sif file, so I don't know if that value is correct or not.

These are all the DX related files that appear in that particular section of the txtsetup.sif:

d3dx9_24.dll = 100,,,,,,,2,0,0

d3dx9_24.inf = 100,,,,,,,20,0,0,d3dx9_24_x86.inf

d3dx9_25.dll = 100,,,,,,,2,0,0

d3dx9_25.inf = 100,,,,,,,20,0,0,d3dx9_25_x86.inf

d3dx9_26.dll = 100,,,,,,,2,0,0

d3dx9_26.inf = 100,,,,,,,20,0,0,d3dx9_26_x86.inf

d3dx9_27.dll = 100,,,,,,,2,0,0

d3dx9_27.inf = 100,,,,,,,20,0,0,d3dx9_27_x86.inf

d3dx9_28.dll = 100,,,,,,,2,0,0

d3dx9_28.inf = 100,,,,,,,20,0,0,d3dx9_28_x86.inf

d3dx9_29.dll = 100,,,,,,,2,0,0

d3dx9_29.inf = 100,,,,,,,20,0,0,d3dx9_29_x86.inf

d3dx9_30.dll = 100,,,,,,,2,0,0

d3dx9_30.inf = 100,,,,,,,20,0,0,d3dx9_30_x86.inf

d3dx9_31.dll = 100,,,,,,,2,0,0

d3dx9_31.inf = 100,,,,,,,20,0,0,d3dx9_31_x86.inf

Originally I was working with NLite v1.2 Final, but thought I'd try 1.3 beta as well (just in case) but it made no difference. I still get the same error message even when integrating again from scratch with clean source files.

My first reaction was that it was a problem with the DX pack itself, but it's difficult to raise issues with the pack when you are using NLite to integrate it (because you can't really ask for help on Ryan's forum).

My NLite session ini file is attached.

Thanks for your help.

Edited by Quisquose
Link to comment
Share on other sites

Hmm... you might want to try replacing the '100's in there with '1's as I believe 100 is meant for Windows XP SPx (I could be wrong, but 1 should be the default and it's already messing up anyway :P)

Edit: However, keep in mind that Windows 2k may need more than Ryan's DX pack, as DX9 isn't included originally.. I've never used Windows 2k so unfortunately I can't really experiment with it, but..

Edited by Ver Greeneyes
Link to comment
Share on other sites

Why do people bother to integrate these later redistributions of DirectX? I've played almost every recent RPG/FPS out there and never get any errors because of my DirectX. What is the point?

I'm not trying to integrate a "later" distribution, I'm using Windows 2000 (which has no DirectX 9 in it all) and so I'm just trying to get any version of DirectX on to the system.

I don't know about you, but I'm not prepared to run Windows in 4bit (16 colours) @ 60Hz, and if you try to install ATI drivers without DirectX 9 being present on the system, then you will get an instant BSOD crash.

I don't even play any games (I don't have the slightest interest in gaming), I just want the damned thing to work at a decent colour depth and refresh rate.

@ Ver Greeneyes now that you mention it, that section does stand out from the rest of the sif file because of the 100s (which none of the other entries seem to have). I'll edit the txtsetup.sif and see what happens.

If it doesn't work, then at least I know it is more likely that Ryan's pack is to blame (as it not taking into account installation on Windows 2000).

It gives me a direction to investigate further.

Thanks for the heads up.

Edited by Quisquose
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...