Jump to content

Maximus-Decim Native USB Drivers


Recommended Posts

As far as I know, there are No bugs with SYSDM.CPL, LoneCrusader fixed it to display Windows 98 instead of Windows Me, I and drugwash fixed the icon issue. The NUSB 3.6 was never updated with the file from  LoneCrusader and the registry fix from me. The SP covers it all or one can manually do it.

Link to comment
Share on other sites

Yes, and let me get one thing clear. Maximus-Decim was the original finder of that key. His package had displayed the broken icons and we fixed it. I would never take credit for someone else work. Thanks goes to him, LoneCrusader, drugwash. I can update the original NUSB 3.5, adding only the SYSDM.CPL from LoneCrusader and the registry fixed to automate the task. If you interested, let me know if not you can do it manually and all will be fine.

Link to comment
Share on other sites

Thx PROBLEMCHYLD!, it could a great idea for everyone
but I have already done my own upgrade.

BTW, in my registry I have those 2 keys:

They came from the nusb.inf of Nusb 3.6e:
; Silent Driver Install

Link to comment
Share on other sites

  • 1 month later...

Most users probably wouldn't need to remove the USB driver, but can you make this uninstallable for the next release? Trying to uninstall via Add/Remove Programs does nothing.

Link to comment
Share on other sites

  • 3 weeks later...

It's a shame, really: The (not-so-new-anymore) AMD 970 chipset is unstable (edit: commercial Patch by RLoew is available!), once an NVidia GPU driver is installed (all works fine with XP or W10). But it is the forst AMD chipset for a long time, which' USB-implementation actually works flawless with NUSB (given the right settings in BIOS).

Now, as it is instable, i'll try the AMD 870 once more. Unfortunatley, there, USB-components are detected and installed, but don't seem to initialize, so no mouse or USB-stick (or whatever) can be used. All works fine under XP or W10.

Does anyone have any advice (beyond adding a USB2-PCI card, which i already did successfully), or idea?

Use the patch by RLoew...

Edited by ragnargd
Link to comment
Share on other sites

  • 1 year later...

I tried to find controller through SIV info, i found only one and regarding of pci id database was Intel USB 3. 

 In bios is EHCI Hand-off, have tried all combinations.. but i maybe did something wrong with nUSB, or its not working for my USB controller, i dont know..


USB related USB settings (manual copy paste):

Allows you to determine the operating mode for the xHCI controller in OS.
Smart Auto This mode is available only when the BIOS supports the xHCI controller in the pre-boot
environment. This mode is similar to Auto, but it adds the capability to route the ports
to xHCI or EHCI according to setting used in previous boots (for non-G3 boot) in the
pre-boot environment. This allows the use of USB 3.0 devices prior to OS boot. xHCI
controller enabling and rerouting should follow the steps in Auto, when previous boot
routs ports to EHCI. Note: This is the recommended mode when BIOS has xHCI preboot
support. (Default)

Auto BIOS routes the sharable ports to EHCI controller. Then it uses ACPI protocols to
provide an option to enable the xHCI controller and reroute the sharable ports. Note:
This is the recommended mode when BIOS does NOT have xHCI pre-boot support.

Enabled All shared ports are eventually routed to the xHCI controller during the BIOS boot process.
If BIOS does not have pre-boot support for the xHCI controller, it should initially route
the sharable ports to the EHCI controller and then prior to OS boot it should route the
ports to xHCI controller. Note: OS has to provide support for the xHCI controller in this
mode. If the OS does not provide support, all sharable ports won't work.
- 29 -

Disabled The USB 3.0 ports are routed to the EHCI controller and the xHCI controller is turned
off. All USB 3.0 devices

Legacy USB Support Allows USB keyboard/mouse to be used in MS-DOS. (Default: Enabled) 

XHCI Hand-off Determines whether to enable XHCI Hand-off feature for an operating system without XHCI Hand-off support. (Default: Enabled)

EHCI Hand-off Determines whether to enable EHCI Hand-off feature for an operating system without EHCI Hand-off support. (Default: Disabled)



Edited by ruthan
Link to comment
Share on other sites

  • 2 months later...

I'd rather keep things simple and not replace sysdm.cpl. Showing that new hardware dialog box when a new device was added is simply how Windows 98 does things. After I've plugged in all of my flash drives into the machine at least once, I never have to bother with seeing that when I plug one in.

Link to comment
Share on other sites

I simply take 4 files from the NUSB package, USB2.INF, USBPORT.SYS, USBHUB20.SYS, and USBEHCI.SYS, and install the USB controller manually from the INF.

Then I install rloew's 98SE USB Mass Storage driver from his website when I plug my USB flash drive for the first time.

Just don't unplug the flash drive too fast before file operations are done, you'll get a non-destructive BSOD (you can go back to the system, so nothing scary) like with good old floppy disks if anyone remember those struggles :) The flash drive will not be damaged in any way :) And no, hotplug never worked for me.

It's an universal solution for any USB 2.0 controller and any USB flash drives without tinkering with system files in any way, been doing it for years now.

No need for this hotplug, systray, user32, sysdm updating system files nonsense, why making life more difficult?

And no, modern motherboards from Skylake and above, and Ryzen uses USB 3.0 hardware ID exclusively for all USB ports, so no USB drivers for it, you'll need a PCIEx1 USB 2.0 controller.

Link to comment
Share on other sites

  • 2 years later...

Having a big issue with NUSB36e drivers and EVGA P55 FTW mobo with Windows 98SE.

Moving USB mouse around or rapidly typing on USB keyboard causes severe in-game FPS drops - the faster you move/type the more severe FPS drops. Peripherals over (only one available) PS/2 work fine.

Is there any hope for a fix? I have noticed @maximus-decim last post is from 2012... or is there anyone else who still maintains this driver pack?

I have an odd build (multi-boot and what not) and this is probably the only thing left that is not working so it would be nice to not have to scrap it :/

I would suspect it is something with polling rates.

ANY help is much appreciated! Thanks

Edited by duga3
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...