Jump to content

Issues in Win7 browsers (video color range, stutter in games)


test5362

Recommended Posts

The washed out video issue in Firefox is still present as of 115.4.0esr. It's a problem for other users under presumably newer operating systems too, as indicated by this fairly new thread: https://support.mozilla.org/en-US/questions/1421330 (though judging by severity this example may possibly be due to another issue with HDR output, which is unrelated here)

And two older bugzilla threads that also seem to pertain to the issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1727490 https://bugzilla.mozilla.org/show_bug.cgi?id=1726186

The mentioned disabling of VAAPI hardware acceleration via media.ffmpeg.vaapi.enabled=false really seems to amount to the same as the previously mentioned media.hardware-video-decoding.enabled=false workaround, so probably nothing new there. However, I have managed to test this on an older laptop with GT 540M GPU, also Windows 7 x64 with the latest driver from 2018, and actually found that Youtube videos display correctly even with hardware decoding enabled! Using h264ify and verified by looking at video engine load of course, and the GT 540M's decoder is really only good for one 1080p60 h.264 stream at once as one might expect, but still a welcome surprise.

Comparing about:support between the two systems (the PC with washed out Youtube has a GTX 1060), the main points all appear identical, except for differences in gfx.crash-guard flags and such. Right now, I can't say if this difference is caused by video acceleration in Firefox being broken on newer GPUs, some old about:config flag tripping Firefox up (these seem to accumulate over time, but seem to be phased out and be ignored in later versions, or so my understanding anyway), or even some other factor, but it would be helpful if someone with a 10-series Nvidia GPU could check if Firefox has the washed out video issue.

 

Edited by test5362
Link to comment
Share on other sites


4 hours ago, test5362 said:

Comparing about:support between the two systems (the PC with washed out Youtube has a GTX 1060), the main points all appear identical, except for differences in gfx.crash-guard flags and such

Try to experiment with different drivers, but the whole 1000 generation is very bright (it's how their BIOS is written). I returned 1080ti back to the shop, it was too bright and washed out.

https://msfn.org/board/topic/185912-should-i-get-a-gtx-1080ti-or-a-gtx-titan-x-pascal-for-vista/?do=findComment&comment=1255575

Link to comment
Share on other sites

That may be true as graphics cards always had some output differences between vendors, but that's a seperate matter as this is not about overall output but specifically Firefox video differences with media.hardware-video-decoding.enabled toggled on or off. To reiterate, videos look fine with this set to false (software decoding) but washed out set to true (hardware decoding).

Link to comment
Share on other sites

On 12/1/2023 at 10:41 AM, test5362 said:

specifically Firefox video differences with media.hardware-video-decoding.enabled toggled on or off. To reiterate, videos look fine with this set to false (software decoding) but washed out set to true (hardware decoding).

Well, this topic "win7-browsers-video-colour-range-stutter" doesn't specify Firefox only, try to switch to chrome then? 

Link to comment
Share on other sites

16 hours ago, vinifera said:

until you enable full color range in nvidia cpanel

You forgot to include the instructions or any precise explanations. Besides, not everyone with older monitors will see that function. 

Most importantly, you forgot to tell - it's mostly HDMI.

Here. lemme help you.

Correcting HDMI Colour on Nvidia and AMD GPU

https://pcmonitors.info/articles/correcting-hdmi-colour-on-nvidia-and-amd-gpus/

Link to comment
Share on other sites

Well, had a gfx driver crash after sleep mode on that laptop, nothing strange as sleep/hibernate would always cause issues like that for me, but since then video acceleration in Firefox has been broken just like on the 1060. Unfortunately system restore was off and I didn't think to make screenshots of the changed flags in about:support, so that doesn't help, but I think that does point to some blacklisting flag that is applied upon crashing and disables something. If there was a way to see what about:config flags are the newest...

On 12/2/2023 at 4:49 PM, Dixel said:

Well, this topic "win7-browsers-video-colour-range-stutter" doesn't specify Firefox only, try to switch to chrome then? 

I never tried Chrome, but used Chrome-based Opera for quite a while and do not recommend it under Win7, I wrote a bit about that in this thread as well.

 

On 12/5/2023 at 6:07 PM, vinifera said:

until you enable full color range in nvidia cpanel

Have had a curious bug with that actually - using a DVI monitor and TV over HDMI in clone mode with same resolution/hz (seems to be more performant than the normal mode, it tended to give microstutter in games when a browser window or video was on the other screen) almost everything under the "Change resolution" Nvidia CP tab is blanked out for me, and the color range selection is missing altogether. I know it's running in full range, so everything techncially works, but I always wondered if others experienced this as well.

Edit: video works correctly again on the laptop, not sure what caused the change. I did delete two flags, namely layers.mlgpu.sanity-test-failed=false and gfx.blacklist.video-overlay.failureid=FEATURE_FAILURE_DL_BLOCKLIST_NO_ID, but they do not seem to actually effect anything.

Edited by test5362
Link to comment
Share on other sites

  • 5 months later...

I'm having the same colour problem with my GTX 960 (4 GB VRAM) graphics cards on Windows 7 and Windows 8.1 when using :

Firefox + Hardware Acceleration and HDMI set to Limited in NVidia Control Panel

This problem does not occur in Microsoft Edge. Haven't tested other browsers.

 

I don't remember having this problem with my Nvidia GT 710 or 610M (laptop) but I was using an older driver version with those. Probably pre-400.00 .

Need to test it on W10/W11 to see if the problem exists there as well at some point.

Link to comment
Share on other sites

I have been using RGB Limited for years because I have always disliked how White and Deep Black colours looked in RGB Full.

I found it to be more strenuous on the eyes and to cause unnecessary visual fatigue (for me).

Well I now looked more deeply into this and turns out there is another solution : Using Ycbcr 4:4:4 in the Nvidia Control Panel. This does not cause any problem with HW ACC. enabled in Firefox.

The colours in general look more natural (to me) especially white and black on the monitor/graphics card combinations I have tried.

I thought Ycbcr was something from the Analogue era and never used that. I was probably confusing it with something like YUV.

 

Here are some interesting links I came across:

https://linustechtips.com/topic/82154-what-color-format-looks-better-gaming-ycbcr444-or-rgb/

https://www.nvidia.com/en-us/geforce/forums/discover/144126/rgb-vs-ycbcr444-/

https://hardforum.com/threads/rgb-vs-ycbcr444-in-nvidia-control-panel.1998222/

https://www.overclock.net/threads/which-setting-is-better-for-gaming-rgb-full-limited-or-ycbcr-422-444.1628651/

https://hardforum.com/threads/4-4-4-limited-vs-rgb-full-which-is-preferred-and-hdmi-2-0a-vs-2-0b-switches.1926589/

 

TLDR : Either RGB Full or Ycbcr 4:4:4 should be used depending on your monitor/graphics card combination and personal colour preference.

RGB Limited should be avoided with HW ACC enabled in FF


 

Link to comment
Share on other sites

19 hours ago, superleiw said:

I have been using RGB Limited for years because I have always disliked how White and Deep Black colours looked in RGB Full.

Sounds very much like your monitor is over-contrast to begin with. Try lower your contrast first, as full RGB looks amazing and shouldn't put strain on eyes.

Link to comment
Share on other sites

I'm already below my monitor's default setting but It doesn't change anything for me even with lowest settings. Maybe I have some kind of sensitivity.

 

Anyway I also came across another solution for Firefox :

1) Disable Hardware Acceleration

2) In about:config change "layers.acceleration.force-enabled" to "True"

3) Restart browser and everything works smoothly and colours are the way they should be (even in RGB Limited)

Link to comment
Share on other sites

I'm using full range RGB only and still have the problem. The only fix for me is media.hardware-video-decoding.enabled=false (the layers one does nothing), but this is undesirable on some systems due to the extra CPU load, so I'm still looking for a solution. To be honest I was expecting this to be a more common issue than it seems to be, so I'm probably going to have to go through checking a lot of flags to see which one causes the washed out video playback.

To clarify again, these two images showcase the difference between media.hardware-video-decoding.enabled on true/false for me:

firefox.png

firefox2.png

Edited by test5362
Link to comment
Share on other sites

In your first post you mentionned that you were using Webrender, is this still true? Did you manually enable it?

Because most of these settings only work on W10+.

 

In about:config those two options are for W10+ so maybe you can try setting them to False :

gfx.webrender.all -> true (Windows 10/11 only)
gfx.webrender.software -> true (Uses CPU instead of GPU but requires Windows 10+)

The following options might also need to be reset to their default values :

gfx.webrender.enabled
gfx.webrender.compositor
gfx.webrender.compositor.force-enabled

Link to comment
Share on other sites

On 5/20/2024 at 10:17 AM, superleiw said:

I'm already below my monitor's default setting but It doesn't change anything for me even with lowest settings. Maybe I have some kind of sensitivity.

No, everything is fine with your eyes! Starting somewhere in 2012-2013 all Nvidia cards are terribly bright and contrast by default. There is a lot of information comparing them to old AMD (in favour of AMD's default colours).

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...