Jump to content

Web Browser + Proxomitron Reborn + PtronGUI --- A How-To Guide


Recommended Posts

1 hour ago, NotHereToPlayGames said:

Technically the browser is irrelevant, the Proxomitron "test Proxy" is failing and that only tests the link between Proxomitron and ProxHTPPSProxyMII.

OK, first a fun fact - in that picture i posted before, Proxo was testing the connection to CCProxy :whistle: So, the HTTP chain.

Using the ProxHTTPSProxyMII port fails the test same way as yours. Fortunately, normal operation is fine, it's just the test that fails.

I wonder where that port 7734 in the error comes from, couldn't find it anywhere...

 

Another fun fact:

 

WSqhWgR.png

 

At least the build of Serpent that comes with XP Integral Edition was able to handle this and the rest of the downloads...

 

 

Link to comment
Share on other sites


Now for the guide...

 

Remember this link? https://prxbx.com/forums/showthread.php?tid=2172

Grab one of the downloads at the end of the first post (i used the "advanced" one this time).

Extract somewhere ( Program Files folder is fine), shorten the name to ProxHTTPSProxyMII

 

Next go here (also linked in the above page) https://prxbx.com/forums/showthread.php?tid=2172&pid=17955#pid17955

Get the Launcher, extract in the ProxHTTPSProxyMII folder. You can add a shortcut to it in StartUp or wherever.

 

Get Proxomitron from here (also linked in the above)

I used the ProxN45m.zip file. Extract, rename folder to Proxomitron if you wish, add a shortcut to Proxomitron.exe in StartUp.

 

Now, start both ProxHTTPSProxyMII (through the launcher) and Proxomitron.

The default config for ProxHTTPSProxyMII should be fine enough.

Proxomitron will need some tinkering. First uncheck all  checkboxes on the main page.

Click Proxy, put this in the field there, click OK. Don't bother testing (see here).

127.0.0.1:8081 ProxHTTPSProxyMII

Then click Config, go to the Startup tab and put this in the bottom field ("bypass all URLs blabla"):

$OHDR(Tagged:ProxHTTPSProxyMII FrontProxy/*)$SETPROXY(127.0.0.1:8081)(^) | $LST(Bypass)

 

Save and you should be done.

 

 

 

Edited by RainyShadow
Link to comment
Share on other sites

57 minutes ago, RainyShadow said:

Using the ProxHTTPSProxyMII port fails the test same way as yours. Fortunately, normal operation is fine, it's just the test that fails.

Wow!  Didn't even dawn on me to see if it "worked" and only the "test" was failing.  :blushing:

Link to comment
Share on other sites

Browser setting for Chrome, 360, etc. :

Control Panel > Internet Options

In the Connections tab click on LAN settings. Check "use a proxy...", click Advanced, uncheck "use same settings..."

Fill this in the HTTP row: 127.0.0.1 , port 8080

This for the Secure row: 127.0.0.1 , 8079

 

For Firefox-based browsers use the built-in browser settings.

HTTP proxy - 127.0.0.1:8080

SSL proxy - 127.0.0.1:8079

 

[edit] forgot something very important, lol

Right-click the CA.crt file in the ProxHTTPSProxyMII folder and select Install Certificate, click Next until it's done.

For FF and the likes, open browser Preferences > Advanced > Certificates. Click View Certificates, then Import and select the CA.crt file.

Edited by RainyShadow
Link to comment
Share on other sites

13 minutes ago, RainyShadow said:

I used the ProxN45m.zip file.

Hmm.  The "m" has a "fallback feature" - when your remote proxy FAILS, it will fallback to a "direct connection" without warning ( https://proxomitron.info/files/index.html ).  The Proxomitron community kind of went "up in arms" over that and the creator quickly released the "j" version.

Lunch time so I'll revisit later.

Edited by NotHereToPlayGames
Link to comment
Share on other sites

7 hours ago, NotHereToPlayGames said:

This is another of my Proxomitron "menus".  The possibilities are limited only by one's imagination.  This hidden menu opens when you hover over the top left corner and could easily contain Chromium links like chrome://flags or chrome://gpu or chrome://media-engagement or shortcuts to extension inner pages that normally take six mouse clicks to get to but now only take one.

image.png.853c84ec451837513dd912ce68259644.png

Very much looks like a browser extension , no ? I'm trying to find something similar to the one below. Could you help me ? As you can see , it's dead . It doesn't fetch alive IPs. It's a system tool for Vista (not an extension) . It has it's own filters too , BTW.

Today it finally got me one IP , but the IP is blocked by the bloody instagram too.

Pic removed , obsolete.

 

Edited by D.Draker
Link to comment
Share on other sites

3 minutes ago, D.Draker said:

Today it finally got me one IP , but the IP is blocked by the bloody instagram too.

Maybe you should find a better way to pick your food.

I fail to understand how getting a bunch of pictures helps you for that.

 

Also, simple automated crawling will always get your new proxy quickly banned.

Try using a GoogleBot user agent.

Link to comment
Share on other sites

45 minutes ago, NotHereToPlayGames said:

Hmm.  The "m" has a "fallback feature" - when your remote proxy FAILS, it will fallback to a "direct connection" without warning ( https://proxomitron.info/files/index.html ).  The Proxomitron community kind of went "up in arms" over that and the creator quickly released the "j" version.

Lunch time so I'll revisit later.

Hmm, i just tested the "j" version.

HTTPS connections go nowhere, there is nothing in both Proxomitron and ProxHTTPSProxyMII logs.

It should have worked since "technically" the remote proxy part should not be used - it actually makes ProxHTTPSProxyMII complain about misconfigured port.

WTF!

 

When i added 127.0.0.1:8081 ProxHTTPSProxyMII as a remote proxy (NOT enabled), it started working (still fails the test though).

WTF x2

 

I you want easier time and don't care about filtering through proxies, just leave the HTTP proxy field in the browser settings empty.

Edited by RainyShadow
Link to comment
Share on other sites

1 hour ago, RainyShadow said:

When i added 127.0.0.1:8081 ProxHTTPSProxyMII as a remote proxy (NOT enabled), it started working (still fails the test though).

WTF x2

Totally freaking amazing!  I had this working FOUR DAYS AGO but I kept thinking that the "test" actually MEANT something when it said it "failed".

Totally WOW!  I've re-read several posts on the other forum and NONE of them mention that the "test" button DOES NOT WORK!  At least not that I could find.

I'm just glad that BOTH of my logs are now "scrolling".

This wasn't hard at all.  Just a d@mn "test" button that says "fail" when in reality it PASSES.

I guess all I can do now is "laugh out loud".  And nap because I've spent too much time on a "test" button that doesn't actually "test" anything  :zzz:

Link to comment
Share on other sites

5 hours ago, RainyShadow said:

Maybe you should find a better way to pick your food.

I fail to understand how getting a bunch of pictures helps you for that.

 

Also, simple automated crawling will always get your new proxy quickly banned.

Try using a GoogleBot user agent.

It's easier said than done . They now have a law here for these stupid "vaxxine passes" , so I can't even go to a shopping center, if I'm not jabbed every 4 months. Like I said , automated crawling is very similar to human usage , several pics in 20 minutes, no more than a hundred in 5-7 hours. If you read my earlier posts , I'm not the only one with this problem , they won't even allow us to look at one picture anymore !! Two - three reloads = total block . 

Link to comment
Share on other sites

35 minutes ago, D.Draker said:

Thank you , I'll try.

Try this instead, it's almost like nitter for Twatter but for Instascam, sorry I meant Instagram...

https://greatfon.com/v/psg

https://greatfon.com/v/marine_lepen

https://greatfon.com/c/4356054631822833572

https://greatfon.com/v/romainpilliard_useitagain

Start searching...:)

https://greatfon.com

 

Link to comment
Share on other sites

1 hour ago, D.Draker said:

Thank you , unfortunately no automation process available . And the site connects to yandex (!). You can see it for yourself in the uBlock window.

Ok, I don't have that "problem"... the only extension I use is an adblocker but on the other hand I don't use my XP laptops for anything important. The old Thinkpad A31 I'm using now is still running the original install from 2003. No router, no VPN, no nothing and I'm not too worried if it connects to Paris, Moscow or Langley. Scanning/cleaning once a week. So far so good...

 

Link to comment
Share on other sites

  • NotHereToPlayGames changed the title to Web Browser + Proxomitron Reborn + PtronGUI --- A How-To Guide

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...