Jump to content

Audio problem with a M6400 laptop

kuja killer

Recommended Posts

Hello again, i have a laptop with a slightly new problem I can not ever figure out, and this time it's reguarding the Audio/Sound on a Dell Precision M6400.

I started with a clean fresh install of XP SP3, and things were going okay. I started doing the drivers slowly, starting with the chipsets, PCM cards, audio, video etc -- until i noticed something was really "off" about the way the audio sounds. First it's "IDT IDT 92HDxxx HD" It's really hard for me to explain this in words but i'll try. :(

For example when i double-click the audio icon in the system tray normally to bring up the volume control window, and just simply click the slider ..it sounds horribly low quality..washed out, "muffled" ..something like that. I dont know the right word to describe it. but if i click it really rapid and fast, it actually sounds normal like it should ...but if i slow down how fast im clicking it, it'll instantly be back to really bad.

It's as if it's going into some sort of power saving mode instantly or...really low/bad "sample quality rate" or...something. Instead of staying normal. The weird thing is, if i open any of my gaming emulators..or youtube or something that relies on sound whatsoever, it'll always be back to normal, but the second i close anything, it's back to crap. Thats why it's so hard for me to explain. I've never experienced such a thing happen on my D620, or the E6420 laptops...and never on any past PC's from the 2000's (win XP only)

I've seriously checked and tried everything i possibly could so far. I went to the IDT control panel and disabled the "power management" option and all the others there. - i went to the "andrea filter" control panel which has only 4 different settings, tried all of those - no difference --


i tried the method in this youtube video i saw about disabling the ESata Port in the BIOS ...which apparently fixed it for hundreds of people...i saw a comment or two of people doing this for the M6400...i guess it's a fix for Win 7 and 10 only. :(

I tried disabling a few other things in BIOS like wifi, lan/ethernet, all the media cards - tried disabling a bunch of other things 1-by-1 in windows device manager, dvd drive, even the "microsoft UAA sound driver" thing which only just disabled the sound entirly ...but turning back on didn't help.

I tried each and EVERY single version avaiable of the IDT from here:
A01, A03, A05, and A06 ...the bad news is that every step UP only makes it worse....only A01 is the closest possible thing to getting it to fixing it.

I also tried a driver that was meant for E6410/E6510 and M4500/6500 ..which managed to install but didnt help.
I then tried the current driver version that was on my E6420 laptop because it's IDT also ..but it wouldnt install because it'd say "your hardware ID is not compatible with this version"

I double-checked with the Direct X diagnostics tool - start -> run -> dxdiag -> sound tab and checking all the options on the slider for Hardware acceleration -- and i double-checked the 2 slider buttons for the Sound/Audio Devices Control panel going to the Advanced tab --> performance and trying out each possible option on "Hardware acceleration" and "Sample Rate Conversion Quality" - no difference on every slider option.

I dont know what else to do. :( Again basically it's like the audio somehow is getting instantly put into some sort of super low quality bit rate or...power saving..or something i dont freaking know. It's never happened on other laptops or PC's before. :(

I've read windows 7 and 10 has it's own generic "high defintion audio" driver that can be loaded without needing the IDT's own driver at all and i've been frantically google searching for hours to find out if there's anything like that for XP too but havent had any luck finding such a thing. Is there any ??

Edited by kuja killer
Link to comment
Share on other sites

Would i even be able to do that, at this point ? trying a lower version ? or have to restart all over ?? (re-install xp again deleting the partition first from usb flash drive then re-install) Since there's no where in the Device Manager specifically about this "intel chipset 9.0.x.x or 9.1 or whatever. And nothing in the Add/Remove Programs about it.

It's really confusing too when looking at the chipset section on there. There's "intel chipset" ..."intel mobile chipset" ..and "intel chipset software" -- with slightly different versions. 9.0 - 9.1 - and 9.2 - im pretty sure i frst picked ", A02"  - later after doing sound and hearing this annoying problem, i then tried the, A05 - which didnt do anything to the audio either. :(


Also i saw this website about doing things in a specific order ..the first thing it mentioned was doing "dell system software" first before anything else - i tried this later after the audio problem...maybe it would of fixed it... ya know ? but all it did was get rid of the USB connect sound effects according to the description for A04 - It literally deleted those 2 entries from the "sound scheme" page...ugh. :( reguardless, no difference before or after

Edited by kuja killer
Link to comment
Share on other sites

I had such a problem with a laptop that was stuck at very low CPU frequency (there was thermal paste on some parts around the CPU and it was messing things) - it was running at 300-800MHz most of the time instead of 2-3GHz, lol.

Could you checkyour CPU with some real-time monitoring tool (CrystalCPUID, Aida64, etc.) while this is happening?

Also, try to toggle the SpeedStep switch in the BIOS settings.

Link to comment
Share on other sites

I actually tried turning off the speedstep option from bios before i posted this thread and didnt help either. It's a "Core 2 Quad Xtreme 9300" - this one: I really kinda dont want this though, i would rather have a T9900 3.06 GHZ someday soon...if i decide to keep this laptop or not first

https://www.cpu-world.com/CPUs/Core_2/Intel-Core 2 Extreme Mobile QX9300 AW80581ZH061003.html

It's at it's minimum speed of 1.5 GHZ or 1533 MHZ i believe based on what CPU-Z and Throttlestop shows, and when right-clicking My Computer -> Propeties window. Doesnt matter either if i manually force it to the highest multipler with throttlestop which is 2.5 GHZ ( i never touched the overclock stuff ) - Already also tried applying the different regular windows XP's own power schemes like "laptop, always on, desktop" - didnt affect the audio in any way. :(

There's only 2 things left i could think of i guess... trying the much slower "ATA/IDE" hard drive BIOS setting which i cant do cause it BSODs instantly at the splash screen with "stop 7B" -- i just left it on it's default "raid" setting like the E6420 laptop was.

or just flat out try re-installing fresh again but with the ATA option selected first ...and then immediately try installing the IDT A01 sound driver before anything else whatsoever, assuming it works normal at all.. "then" go normally from there like chipset/etc to see when it gets screwed up. I have my doubts though. :(


Edited by kuja killer
Link to comment
Share on other sites

Try the suggestions of RainyShadow and Skorpios first.


If nothing works, leave the installing of new Chipset driver as a last resort, we don't know if that would help also.

Before you do that, make a backup (Image of your System or just your C: Partition where your Windows is installed, Restore Point, Registry backup).

I think it is better to Uninstall the existing driver first and then Install the new one, and PC Restart in between.

Link to comment
Share on other sites

I've looked at that whole thread first. And i would of posted on that forum (notebookreview) before here, but i probably wouldnt get any replies.. all the past M6400 threads and 100+ page long "m6400 owners thread" is locked.

So -- esata port disable in bios already tried (same as the youtube video i linked earlier) -- i installed the intel matrix storage thing just to test, but it wasnt affecting the sound as usual, so i un-installed it. When i first installed XP a few nights ago it was already loaded with version 8.6-something, i did try the latest driver which was 9.4 or 9.6 i think, but no difference. --- already tried turning off power management on IDT control panel. if that's "on" it will make those pop noises people have mentioned, when it's "off" it fixes that but it still doesnt do anything to this really bad low quality i've tried so hard to explain. :(

I never tested Control Point software, but i gave that a try tonight, looked through all the options, no difference, so un-installed that right away. - already had tried disabling the Wifi completely, turning off the switch, etc.

It's really not "stutter" or pops or clicks, it's more closer to something like this person said on the 2nd page of the thread - quote "I updated the BIOS and some drivers, and such, but the thing that fixed *this* issue was to change the sampling rate in Windows 7 to 44.1 KHz (the default was 48KHz)."

If windows xp had something like this, cause thats what it sounds or feels like. As if it's like 16 or 24 khz...but normal sounding if i click on the volume control slider button fast enough. (this affects all windows sounds and stuff unless i have like a game emulator running in the background for example even if no game is currently loaded on it)

About the IDE/ATA hard drive thing, i found this website called "fix ide" - https://www.d7xtech.com/free-software/fixide/

it took me a few hours to go through this, and it worked out letting me install the regular IDE controller driver without being forced to go through the XP setup all over again....so i could now boot with slow IDE or faster Sata Raid bios options....but it still did nothing whatsoever to address the stupid sound. :(

I don't own any headphones, so i havent gotten to test the headphone/microphone jacks other people mentioned, i have no clue about that yet. :| I perfer just using the regular laptop's speakers, but i am curious about people saying headphones can use the speakers.

Edited by kuja killer
Link to comment
Share on other sites

Okay i'll try that soon ..is that XP's "generic" type of driver that would work on any type of PC or laptop ?? like how win7 and 10 apparently has a basic "microsoft audio" thing or something like that.

i'll try this one since it has the most recent date of 2007 - Realtek Semiconductor Corp. - Sound - Realtek High Definition Audio Windows XPDrivers (Other Hardware) 10/24/2007 11.8 MB

Link to comment
Share on other sites

How do i install this cab driver exactly ? All these realtek drivers are in .CAB fomat and i cant for the life of me figure out how to yet. I already extracted the contents to a folder and it has like 8 different inf files, but no .MSI installers or anything. I dont want to blindy try every single INF file cause some them have names like "apple" or "samsung" in the filename. So i dont even know which one to pick

I've been fustrated for over an hour trying to google this and all i find is just commands like pkgmgr and dism which is only win 7 and higher. There's no right-click menu option for installing this cab directly.

Edited by kuja killer
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...