Jump to content

Windows XP Home Edition does not recognize all Ryzen cores, while Professional does


Recommended Posts

Hello MSFN, i recently installed Windows XP under a Ryzen 3 1200 machine with the A320 chipset. I initially found the ACPI was incompatible, 0x000000A5 BSOD if i recall correctly, so i replaced the ACPI driver in the ISO with a newer, community-modified one that fixes the problem. Everything now seems to be working fine, except one thing:

I realized Windows XP Home Edition was only recognizing 2 cores out of the total of 4 cores the processor has. At first i wasn't very sure why was that happening. I first tried switching different BIOS options to check if that was the problem, as well as revising Windows configuration, but that didn't help. I then decided to do some testing:

First, i installed Windows XP Home Edition (ACPI fixed ISO) under my AMD FX-8300 machine, as it has 8 cores. If the problem was also present there, it would have nothing to do with Ryzen. I have Windows 7 on my machine, and installed XP Home Edition on a different hard drive (having the other one unplugged).


As expected, Windows XP Home Edition detects all my cores perfectly (detailed screenshot). Now let's see what happens when i install Windows XP Home Edition (with the exact same ISO image i used with the AMD FX). The machine has Windows 8.1 installed and i'm installing Windows XP Home Edition on a different hard drive (having the other one unplugged).


As i said earlier, only 2 cores are recognized (detailed screenshot). I was already guessing what could be the cause of the problem, so i proceeded to install Windows XP Professional Edition, with the exact same ACPI fix and...


It detected all cores as should (detailed screenshot). I'm aware XP Home Edition supports up to 1 physical processor, while XP Professional supports up to 2 physical processors, but that doesn't make much sense in this context as the Ryzen 3 1200 is a single physical processor. I believe the Ryzen architecture is modularized at silicon level (you can see here the 1200 has 2 modules), but everything is still under the same die. The AMD FX architecture is also fully modularized, each module having 2 cores and 2 threads (the FX 8300 has a total of 4 modules), but doesn't suffer from this problem.

As a last resort, i considered the system might actually be using all cores, but after doing some benchmarks, that was clearly not the case, and it seems the system is just using two. You might now suggest we should just use Professional Edition as that one seems to fix the problem... But if you think about it, if the root problem is XP recognizing each Ryzen module as an individual physical processor, then, Zen 2 processors, which are more modularized than the predecessor microarchitectures, will suffer from this exact problem on both Home and Pro, let alone the Ryzen Threadripper. Using Professional Edition seems to only be a solution for those using older and less powerful Ryzen CPUs.

Using Windows Server 2003 could also be considered a solution, but given how very few people has licenses for it, is not a very practical one. Furthermore, i couldn't make the ACPI driver patch work with it (although it might be possible to get it working and i'm not aware).

At this point i'm starting to believe this is caused because of a bug within the Windows XP physical processor detector, or either, a BIOS bug, but that last one seems less likely. I'm usure if there's already a solution for this, that's why i'm asking here. Has anyone tried Ryzen with XP and had the same problem? I couldn't find much information regarding this as the XP Ryzen scene is quite small. If there's no known solution, i'd be interested to look forward for a fix to this. Any information that could get us closer to a solution is highly appreciated. If anyone interested has a Ryzen processor, you can try installing XP on your machine and telling us your results.

Thanks in advance for all your help.


Further details worth considering:

- All Windows XP ISOs used are original and untouched (en_windows_xp_home_with_service_pack_3_x86_cd_x14-92413.iso, en_windows_xp_professional_with_service_pack_3_x86_cd_x14-80428.iso). The only thing i did was replace the ACPI driver, as well as adding USB3 (for usb3 install) and AHCI drivers (motherboard lacks IDE). I've done the exact same procedure with Professional and Home Edition to include the drivers to the ISO file.

- All the Windows settings were left as they were out of the box. Nothing within the system configuration has been changed.

Edited by blueclouds8666
Link to comment
Share on other sites

  • blueclouds8666 changed the title to Windows XP Home Edition does not recognize all Ryzen cores, while Professional does

@Tripredacus As you can see in the detailed screenshot, the 4 cores show up in the device manager in both Professional and Home Edition, despite only two being usable on the latter. Each and every one is reported as "This device is working properly". Their device instance ID differs for each one:


The exact same thing appears in Professional Edition and Home Edition in regard to the device manager.

@Jaguarek62 Modern systems have an incompatible ACPI. For that reason, you will get something like 0x000000A5 BSOD. That can be fixed by installing a modified ACPI driver to the ISO image. Depending on your machine, you might have to add AHCI and USB3 drivers too. If you want to learn how to do that, i've made a guide you can check out here. There are many other guides you can follow as well, this is only my suggestion.


  • Like 4
Link to comment
Share on other sites

As you already wrote,

"Windows XP Professional will support up to two processors with an unlimited number of cores."
"Windows XP Home will support only a single processor with an unlimited number of cores."

However, there were few processors to actually test the 'unlimited' claim at the time. So yeah, maybe Windows XP Home detects it as being on two different processors, and then triggers the preset limitation.

I did a quick search for a CPU-Z screenshot of a Core-i7 on Windows XP Home. That should work. But so far none of them were confirmed to be on that OS...

Edit: I see your AMD FX-8300 on XP Home screenshot now. Not much to add.

Edited by gerwin
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...