Jump to content

Windows 2000 BETA drivers for testing purposes


daniel_k
 Share

Recommended Posts

In this topic I'll post my modified drivers for Windows 2000 with SP4 (no Updates Rollup or Extended Kernel needed).
For testing purposes only, so beware. If considered stable, will be promoted to Final.

- Intel Matrix Storage 7.6.9.1002 (AHCI/RAID)

- AMD(Hudson?) / Intel / VIA XHCI USB3.1 driver 1.1.0.0276

  • Driver only: 276BETA_W2K.7z
    Has the same issues with PAE as XP.
    Don't know if Windows 2000 is also affected by qword ACPI issue (the XHCI controller won't initialize and reports Error code 10).
    In this case, please try it in MPS Uniprocessor/Multiprocessor mode.
Edited by daniel_k
  • Like 3
Link to comment
Share on other sites


About testing:
- Unfortunately I don't have any optical driver to install Windows 2000 on my Coffee Lake PC, as USB-based install won't work with drivers integrated.
- Both drivers were tested on VirtualBox with no issues.
- Both drivers passed XP SP3 testing on my Coffee Lake PC with absolutely no issues, even USB-based install was possible.

Link to comment
Share on other sites

- Installed Windows 2000 SP4 (with drivers integrated) in MPS Multiprocessor mode (ACPI doesn't work here) on VirtualBox.
- Followed the instructions in this question: exporting a virtualbox VDI to a harddrive to boot it natively
- Plugged in a PS/2 keyboard, booted Windows 2000 and proceeded with all driver installs.
- Used the Composite devices solution outlined here: Universal Serial Bus (USB) Interface drivers (scroll down)
- And the result is:

xhci.png
Driver works fine with both Intel and VIA controllers.

diskbench.png

Edited by daniel_k
  • Like 1
Link to comment
Share on other sites

  • 2 years later...
On 12/31/2019 at 2:23 PM, daniel_k said:

In this topic I'll post my modified drivers for Windows 2000 with SP4 (no Updates Rollup or Extended Kernel needed).
For testing purposes only, so beware. If considered stable, will be promoted to Final.

- Intel Matrix Storage 7.6.9.1002 (AHCI/RAID)

- AMD(Hudson?) / Intel / VIA XHCI USB3.1 driver 1.1.0.0276

  • Driver only: 276BETA_W2K.7z
    Has the same issues with PAE as XP.
    Don't know if Windows 2000 is also affected by qword ACPI issue (the XHCI controller won't initialize and reports Error code 10).
    In this case, please try it in MPS Uniprocessor/Multiprocessor mode.

USB link is down

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...