Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Adobe Flash, Shockwave, and Oracle Java on XP (Part 1)


dencorso
 Share

Recommended Posts


Today the version 26.0.0.94 was released by the beta flashplayer, unfortunately the PPAPI Flashplayer for chromium-based webbrowser does not work either. So continue to wait and drink tea.

Little addition:
The existing PPAPI Flashplayer in the program directory of Google Chrome (C:\Program Files\Google\Chrome\Applications\49.0.2623.112\PepperFlash\) does not need to be deleted! If another user profile (other user in Windows XP) is set up, the PPAPI Flashplayer existing in Google Chrome's program path is first used. The PPAPI Flashplayer directory in Google Chrome's user profile
(\Documents and Settings\$USER$\LocalSettings\ApplicationData\Google\Chrome\UserData\PepperFlash\25.0.0.148\) corresponds to the regular Google Chrome components update path.

:)

Edited by heinoganda
Link to comment
Share on other sites

30 minutes ago, heinoganda said:

Today the version 26.0.0.94 was released by the beta flashplayer, unfortunately the PPAPI Flashplayer for chromium-based webbrowser does not work either. So continue to wait and drink tea.

Little addition:
The existing PPAPI Flashplayer in the program directory of Google Chrome (C:\Program Files\Google\Chrome\Applications\49.0.2623.112\PepperFlash\) does not need to be deleted! If another user profile (other user in Windows XP) is set up, the PPAPI Flashplayer existing in Google Chrome's program path is first used. The PPAPI Flashplayer directory in Google Chrome's user profile
(\Documents and Settings\$USER$\LocalSettings\ApplicationData\Google\Chrome\UserData\PepperFlash\25.0.0.148\) corresponds to the regular Google Chrome components update path.

:)

Heinoganda

Beta 26.0.0.94 was posted yesterday, but was digitally signed April 29, well before I discovered the issue. I am almost certain that the issue will be fixed in the final shipping version.

Link to comment
Share on other sites

Flash Player Version 25.0.0.171 has been released!

The Internet Explorer ActiveX plugin is available here: http://fpdownload.adobe.com/get/flashplayer/pdc/25.0.0.171/install_flash_player_ax.exe
The NPAPI for Firefox is available here: http://fpdownload.adobe.com/get/flashplayer/pdc/25.0.0.171/install_flash_player.exe

Currently, the Flash Player for Opera or Chromium (install_flash_player ppapi.exe) version v25.0.0.171 can be used!
Tested with Google Chrome v49.0.2623.112.

Installation Info for Google Chrome:

 

First close Google Chrome, copy from "%windir%\system32\Macromed\Flash" the files "pepflashplayer32_25_0_0_171.dll" and "manifest.json" to the User Profile from Google Chrome
" \Documents and Settings\$USER$\Local Settings\Application Data\Google\Chrome\User Data\PepperFlash\25.0.0.171\"
and rename "pepflashplayer32_25_0_0_171.dll" to "pepflashplayer.dll". Starting Google Chrome again.

Note:
Is also recognized by Google Chrome as version 25.0.0.171! (chrome://plugins, chrome://flash or chrome://components)

or

For all those who still use Google Chrome, I would like to provide a small updater for updating the PPAPI Flashplayer.

:)

Edited by heinoganda
  • Upvote 2
Link to comment
Share on other sites

Hi all, I just got a reply over at Adobe, and we are back in business with the Google Chrome PepperFlash PPAPI on Windows XP.

The latest stable is version 25.0.0.171, and the latest beta is 26.0.0.102. Both work on XP.

Sometimes you just have to ask nicely, and people will be willing to help you out.

https://forums.adobe.com/message/9507336#9507336

9507336.jpg

2500171.jpg

Edited by sdfox7
  • Upvote 4
Link to comment
Share on other sites

  • 2 weeks later...
On 5/9/2017 at 3:31 AM, heinoganda said:

Flash Player Version 25.0.0.171 has been released!

The Internet Explorer ActiveX plugin is available here: http://fpdownload.adobe.com/get/flashplayer/pdc/25.0.0.171/install_flash_player_ax.exe
The NPAPI for Firefox is available here: http://fpdownload.adobe.com/get/flashplayer/pdc/25.0.0.171/install_flash_player.exe

Currently, the Flash Player for Opera or Chromium (install_flash_player ppapi.exe) version v25.0.0.171 can be used!
Tested with Google Chrome v49.0.2623.112.

Installation Info for Google Chrome:

  Reveal hidden contents

First close Google Chrome, copy from "%windir%\system32\Macromed\Flash" the files "pepflashplayer32_25_0_0_171.dll" and "manifest.json" to the User Profile from Google Chrome
" \Documents and Settings\$USER$\Local Settings\Application Data\Google\Chrome\User Data\PepperFlash\25.0.0.171\"
and rename "pepflashplayer32_25_0_0_171.dll" to "pepflashplayer.dll". Starting Google Chrome again.

Note:
Is also recognized by Google Chrome as version 25.0.0.171! (chrome://plugins, chrome://flash or chrome://components)

or

For all those who still use Google Chrome, I would like to provide a small updater for updating the PPAPI Flashplayer.

:)

Beta channel has been updated to 26.0.0.110, and is confirmed working with Google Chrome on Windows XP.

https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/install_flash_player_ppapi.exe

fpbgc26x110.jpg

  • Upvote 1
Link to comment
Share on other sites

  • 2 weeks later...

Beta channel has been updated to 26.0.0.123, and is confirmed working with Google Chrome on Windows XP.

VERY IMPORTANT: Google deprecated NPAPI in 2015. (https://developer.chrome.com/extensions/npapi)

If you are using Google Chrome 44 or older, you will need to use the NPAPI plugin. My testing reveals that the PPAPI plugin does NOT work on older versions of Chrome. This is particularly useful for older legacy systems with non-SSE2 compatible processors, such as my Gateway 2000 Solo 9300 with Pentium III.

If you are using Google Chrome 45 or newer, you will need to use the PPAPI plugin. My testing reveals that the NPAPI plugin does NOT work on newer versions of Chrome (up to 49, the last supported version for Windows XP.

Chrome 45 and newer PPAPI: https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/install_flash_player_ppapi.exe

Chrome 44 and older NPAPI: https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/install_flash_player.exe

fpbgc26x123.jpg

Link to comment
Share on other sites

Adobe Flash Player 26.0.0.126 Final. Still compatible with Windows XP (IE/Firefox/Chrome compatible versions).

http://fpdownload.adobe.com/get/flashplayer/pdc/26.0.0.126/install_flash_player_ax.exe
http://fpdownload.adobe.com/get/flashplayer/pdc/26.0.0.126/install_flash_player.exe
http://fpdownload.adobe.com/get/flashplayer/pdc/26.0.0.126/install_flash_player_ppapi.exe
Link to comment
Share on other sites

On 6/13/2017 at 4:14 AM, Bersaglio said:

Adobe Flash Player 26.0.0.126 Final. Still compatible with Windows XP (IE/Firefox/Chrome compatible versions).


http://fpdownload.adobe.com/get/flashplayer/pdc/26.0.0.126/install_flash_player_ax.exe
http://fpdownload.adobe.com/get/flashplayer/pdc/26.0.0.126/install_flash_player.exe
http://fpdownload.adobe.com/get/flashplayer/pdc/26.0.0.126/install_flash_player_ppapi.exe

I just wanted to remark that the "online" installers (that download if you go to https://get.adobe.com/flashplayer/) no longer seem to work on my XP system. I get bogus errors about my C: drive being full. The "offline" installers Bersaglio gives above work just fine, however.

  • Upvote 1
Link to comment
Share on other sites

6 hours ago, Dibya said:

@sdfox7 p3 can still browse Web ?

Dibya

Yes. For that system you need to use Google Chrome 34 or older, which does not require SSE2 , or Firefox 48 or older that does not require SSE2. Internet Explorer 8 still works with a lot of sites, believe it or not!

Link to comment
Share on other sites

  • Dave-H changed the title to Adobe Flash, Shockwave, and Oracle Java on XP (Part 1)
  • Dave-H locked this topic
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...