Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Recommended Posts

Rebooting restarted it at 97%.  It's now done decompressing/decrypting and is ready to restart.  We'll see...

 

-Noel

Share this post


Link to post
Share on other sites

This is 10158 and your atlas theme thanks NoelC

 

Looks as though now they're drawing the caption buttons taller, relative to the title bar height.  I really liked them shorter, so I've changed the graphics a little.  I've had ZERO time to test this, but it might make the caption buttons a little less awkwardly positioned...  Chances are I still need to move some things around, but here you go:

 

This is for builds 10158 and 10159:

 

http://Noel.ProDigitalSoftware.com/ForumPosts/Win10/10159/RoundedCornersBlueActive.png

 

AGonWin10.png

 

Aero Glass seems to work, for the most part, but does have some visual glitches, accompanied by errors reported in the debug.log...

 

[2015-06-30 22:14:40][0x1560:0x11C4] Machine ID: CG6OCCLNFHOH5LOSAU3ILTAPGVTLO335QDLJRAKI4LOZUQ[2015-06-30 22:14:40][0x1560:0x11C4] Checking key dbe47a75c73a948c9b3f8fbe2ef4f68554ea864fc939f1620023b9f575b5d5a5fe86c507c7b6100fd9d9a9d4af2f15 for ID CG6OCCLNFHOH5LOSAU3ILTAPGVTLO335QDLJRAKI4LOZUQ...[2015-06-30 22:14:40][0x1560:0x11C4] Hook (USER32.dll!DrawTextW from udwm.dll) installed[2015-06-30 22:14:40][0x1560:0x11C4] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed[2015-06-30 22:14:40][0x1560:0x11C4] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed[2015-06-30 22:14:40][0x1560:0x11C4] Aero Glass for Win8.1 v1.3.2 DEBUG x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).[2015-06-30 22:14:40][0x1560:0x21C] Loading settings (flags = 0x1) from HKEY 0x0000000000000000 for session #3[2015-06-30 22:14:40][0x1560:0x21C] Settings reloaded[2015-06-30 22:14:40][0x1560:0x21C] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols[2015-06-30 22:14:40][0x1560:0x21C] dwmcore.dll version 10.0.10159.0[2015-06-30 22:14:40][0x1560:0x21C] udwm.dll version 10.0.10159.0[2015-06-30 22:14:40][0x1560:0x21C] DBGHELP: .\uDWM.pdb - file not found[2015-06-30 22:14:40][0x1560:0x21C] DBGHELP: .\dll\uDWM.pdb - file not found[2015-06-30 22:14:40][0x1560:0x21C] DBGHELP: .\symbols\dll\uDWM.pdb - file not found[2015-06-30 22:14:41][0x1560:0x21C] SYMSRV: C:\AeroGlass\symbols\uDWM.pdb\0F456C1E0E544F0B947AC102A75F63941\uDWM.pdb not found[2015-06-30 22:14:41][0x1560:0x21C] SYMSRV: http://msdl.microsoft.com/download/symbols/uDWM.pdb/0F456C1E0E544F0B947AC102A75F63941/uDWM.pdb not found[2015-06-30 22:14:41][0x1560:0x21C] DBGHELP: uDWM.pdb - file not found[2015-06-30 22:14:41][0x1560:0x21C] DBGHELP: udwm - no symbols loaded[2015-06-30 22:14:41][0x1560:0x21C] Failed to load symbol module udwm.dll: 0[2015-06-30 22:14:42][0x1560:0x21C] DBGHELP: .\dwmcore.pdb - file not found[2015-06-30 22:14:42][0x1560:0x21C] DBGHELP: .\dll\dwmcore.pdb - file not found[2015-06-30 22:14:42][0x1560:0x21C] DBGHELP: .\symbols\dll\dwmcore.pdb - file not found[2015-06-30 22:14:42][0x1560:0x21C] SYMSRV: C:\AeroGlass\symbols\dwmcore.pdb\891483D03F814E57BC33B27E9EBA87A61\dwmcore.pdb not found[2015-06-30 22:14:42][0x1560:0x21C] SYMSRV: http://msdl.microsoft.com/download/symbols/dwmcore.pdb/891483D03F814E57BC33B27E9EBA87A61/dwmcore.pdb not found[2015-06-30 22:14:42][0x1560:0x21C] DBGHELP: dwmcore.pdb - file not found[2015-06-30 22:14:42][0x1560:0x21C] DBGHELP: dwmcore - export symbols[2015-06-30 22:14:42][0x1560:0x21C] Failed to load symbol module dwmcore.dll: 0[2015-06-30 22:14:42][0x1560:0x21C] Failed to load symbol module dwmcore.dll: 0[2015-06-30 22:14:42][0x1560:0x21C] Failed to load symbol module dwmcore.dll: 0[2015-06-30 22:14:42][0x1560:0x21C] DWM incompatibility error 0x584[2015-06-30 22:14:42][0x1560:0x9C0] Message 0x31A, wparam = 0, lparam = 0[2015-06-30 22:14:42][0x1560:0x21C] Symbols loaded from patterns: 0xA7B[2015-06-30 22:14:42][0x1560:0x9C0] Loading settings (flags = 0x4) from HKEY 0x0000000000000000 for session #3[2015-06-30 22:14:42][0x1560:0x9C0] Settings reloaded[2015-06-30 22:14:42][0x1560:0x9C0] Delayed hook (UxTheme.dll!GetThemeStream from udwm.dll) installed[2015-06-30 22:14:42][0x1560:0x9C0] Atlas resource loading (custom: )[2015-06-30 22:14:42][0x1560:0x9C0] GetThemeStream 0,0,213[2015-06-30 22:14:42][0x1560:0x9C0] Message 0x31A, wparam = 0, lparam = 0[2015-06-30 22:14:42][0x1560:0xB98] GetThemeStream 0,0,213[2015-06-30 22:14:42][0x1560:0x9C0] Loading settings (flags = 0x4) from HKEY 0x0000000000000000 for session #3[2015-06-30 22:14:42][0x1560:0xB98] GetThemeStream 0,0,213[2015-06-30 22:14:42][0x1560:0x9C0] Settings reloaded[2015-06-30 22:14:42][0x1560:0xB98] GetThemeStream 0,0,213[2015-06-30 22:14:42][0x1560:0x9C0] Atlas resource loading (custom: )[2015-06-30 22:14:42][0x1560:0x9C0] GetThemeStream 0,0,213[2015-06-30 22:14:42][0x1560:0x9C0] Message 0x320, wparam = 1157636154, lparam = 1[2015-06-30 22:14:42][0x1560:0xB98] GetThemeStream 0,0,213[2015-06-30 22:14:42][0x1560:0x9C0] Loading settings (flags = 0x2) from HKEY 0x0000000000000000 for session #3[2015-06-30 22:14:42][0x1560:0xB98] GetThemeStream 0,0,213[2015-06-30 22:14:42][0x1560:0xB98] GetThemeStream 0,0,213[2015-06-30 22:14:43][0x1560:0x9C0] Settings reloaded[2015-06-30 22:14:43][0x1560:0x9C0] Message 0x320, wparam = 1157636154, lparam = 1[2015-06-30 22:14:43][0x1560:0x9C0] Loading settings (flags = 0x2) from HKEY 0x0000000000000000 for session #3[2015-06-30 22:14:43][0x1560:0x9C0] Settings reloaded[2015-06-30 22:14:43][0x1560:0x9C0] Message 0x15, wparam = 0, lparam = 0[2015-06-30 22:14:43][0x1560:0x9C0] Message 0x15, wparam = 0, lparam = 0[2015-06-30 22:14:49][0x1560:0x9C0] Message 0x1E, wparam = 0, lparam = 0[2015-06-30 22:14:49][0x1560:0x9C0] Message 0x2B1, wparam = 5, lparam = 3[2015-06-30 22:14:50][0x1560:0x9C0] Loading settings (flags = 0x1) from HKEY 0x0000000000000600 for session #3[2015-06-30 22:14:50][0x1560:0x9C0] Settings reloaded[2015-06-30 22:14:50][0x1560:0x9C0] Message 0x320, wparam = 553672191, lparam = 1[2015-06-30 22:14:50][0x1560:0x9C0] Loading settings (flags = 0x2) from HKEY 0x0000000000000600 for session #3[2015-06-30 22:14:50][0x1560:0x9C0] Settings reloaded[2015-06-30 22:14:50][0x1560:0x9C0] Message 0x31B, wparam = 0, lparam = 0[2015-06-30 22:14:50][0x1560:0x9C0] Message 0x31A, wparam = 262146, lparam = 1[2015-06-30 22:14:50][0x1560:0x9C0] Loading settings (flags = 0x4) from HKEY 0x0000000000000600 for session #3[2015-06-30 22:14:50][0x1560:0x9C0] Settings reloaded[2015-06-30 22:14:50][0x1560:0x9C0] Atlas resource loading (custom: C:\AeroGlass\RoundedCornersBlueActive.png)[2015-06-30 22:14:50][0x1560:0x9C0] GetThemeStream 0,0,213[2015-06-30 22:14:50][0x1560:0x9C0] Message 0x31B, wparam = 262146, lparam = 1[2015-06-30 22:14:50][0x1560:0xB98] GetThemeStream 0,0,213[2015-06-30 22:14:50][0x1560:0x9C0] Message 0x15, wparam = 0, lparam = 0[2015-06-30 22:14:50][0x1560:0xB98] GetThemeStream 0,0,213[2015-06-30 22:14:50][0x1560:0x9C0] Message 0x1A, wparam = 0, lparam = 976563468584[2015-06-30 22:14:50][0x1560:0xB98] GetThemeStream 0,0,213[2015-06-30 22:14:50][0x1560:0x9C0] Message 0x1A, wparam = 0, lparam = 976563468584[2015-06-30 22:14:50][0x1560:0x9C0] Message 0x320, wparam = 553672191, lparam = 1[2015-06-30 22:14:50][0x1560:0x9C0] Loading settings (flags = 0x2) from HKEY 0x0000000000000600 for session #3[2015-06-30 22:14:50][0x1560:0x9C0] Settings reloaded[2015-06-30 22:14:50][0x1560:0x9C0] Message 0x15, wparam = 0, lparam = 0[2015-06-30 22:14:50][0x1560:0x9C0] Message 0x1A, wparam = 24, lparam = 976563468584[2015-06-30 22:14:50][0x1560:0x9C0] Message 0x1A, wparam = 0, lparam = 976563468552[2015-06-30 22:14:52][0x1560:0xBB4] Allocating class CBlurEffect for D2D 0x000000E361C668D0[2015-06-30 22:14:52][0x1560:0xBB4] Allocating blur buffer 687 x 355 [pixelFormat: 87, 3] (D2D 0x000000E361C668D0)[2015-06-30 22:14:52][0x1560:0xBB4] Allocating class CReflection for D2D 0x000000E361C668D0[2015-06-30 22:14:54][0x1560:0x9C0] Message 0x219, wparam = 7, lparam = 0[2015-06-30 22:14:54][0x1560:0x9C0] Message 0x219, wparam = 7, lparam = 0[2015-06-30 22:14:59][0x1560:0xBB4] Allocating blur buffer 689 x 357 [pixelFormat: 87, 3] (D2D 0x000000E361C668D0)[2015-06-30 22:15:05][0x1560:0xBB4] Allocating blur buffer 687 x 355 [pixelFormat: 87, 1] (D2D 0x000000E361C668D0)[2015-06-30 22:15:10][0x1560:0xBB4] Allocating blur buffer 1698 x 486 [pixelFormat: 87, 1] (D2D 0x000000E361C668D0)[2015-06-30 22:15:11][0x1560:0xBB4] Allocating blur buffer 1703 x 501 [pixelFormat: 87, 1] (D2D 0x000000E361C668D0)[2015-06-30 22:15:11][0x1560:0xBB4] Allocating blur buffer 1703 x 501 [pixelFormat: 87, 3] (D2D 0x000000E361C668D0)[2015-06-30 22:16:24][0x1560:0x9C0] Message 0x219, wparam = 7, lparam = 0[2015-06-30 22:16:30][0x1560:0xBB4] Allocating blur buffer 1728 x 1093 [pixelFormat: 87, 1] (D2D 0x000000E361C668D0)[2015-06-30 22:16:30][0x1560:0xBB4] Allocating blur buffer 1728 x 1093 [pixelFormat: 87, 3] (D2D 0x000000E361C668D0)

 

 

-Noel

Edited by NoelC

Share this post


Link to post
Share on other sites

@NoelC, is your taskbar blurred?

Mine is!  screenshot_28.png

Share this post


Link to post
Share on other sites

No dwm.exe restarts with 10159!

Share this post


Link to post
Share on other sites

 

@NoelC, is your taskbar blurred?

Mine is!  

 

:( mine not

 

Do you have EnableBlurBehind DWORD under  HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Themes\Personalize?

I only have this problem on this new build, worked just fine in 10130 :(

Share this post


Link to post
Share on other sites

 

 

@NoelC, is your taskbar blurred?

Mine is!  

 

:( mine not

 

Do you have EnableBlurBehind DWORD under  HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Themes\Personalize?

I only have this problem on this new build, worked just fine in 10130 :(

 

Use SetWindowCompositionAttribute.exe found on bm's site.

Share this post


Link to post
Share on other sites

Use SetWindowCompositionAttribute.exe found on bm's site.

 

 

Tried it, doesn't work

Share this post


Link to post
Share on other sites

 

Use SetWindowCompositionAttribute.exe found on bm's site.

 

 

Tried it, doesn't work

 

Well, that is what I am using. It does work if you set it up properly.

Share this post


Link to post
Share on other sites

No dwm.exe restarts with 10159!

It is random. It even works on 10158 (except glass safety zone implementation) but it depends what data are stored in invalidly pointed memory. I actually don't know if there is some possibility to check that pointer is invalid and I should not inject my code. Currently, it does only "if(pData != NULL)".

  • Upvote 1

Share this post


Link to post
Share on other sites

 

 

Use SetWindowCompositionAttribute.exe found on bm's site.

 

 

Tried it, doesn't work

 

Well, that is what I am using. It does work if you set it up properly.

 

 

Please  <_<

Share this post


Link to post
Share on other sites

I pasted below in notepad and called it Taskbarblur.cmd  I put it on my root drive.  Delete lines with Secondary if only using one  monitor.

 

@echo off
:1
SetWindowCompositionAttribute.exe class Shell_TrayWnd accent 0 0 0 0
SetWindowCompositionAttribute.exe class Shell_TrayWnd blur true
SetWindowCompositionAttribute.exe class Shell_SecondaryTrayWnd accent 0 0 0 0
SetWindowCompositionAttribute.exe class Shell_SecondaryTrayWnd blur true
timeout /T 2 /nobreak
cls
goto 1

 

Then I pasted below in notepad, and called it StartTaskbarBlurMinimum.cmd and place it on root drive.  I created a task to start when logging in.

 

start /min C:\Taskbarblur.cmd
exit

 

Make sure SetWindowCompositionAttribute.exe is in \Windows\System32.

 

Create shortcut to ColorIntensitySlider  %windir%\System32\rundll32.exe shell32.dll,Control_RunDLL desk.cpl,Advanced,@Advanced

 

Adjust as needed.

 

 

I ALSO HAVE BLUR DEVIATION SET TO  30.

Edited by dhjohns

Share this post


Link to post
Share on other sites

Not that kind of blur, but the default one. 

Edited by Tusticles

Share this post


Link to post
Share on other sites

Yes, not working...

You have Aeroglass up and running, correct?  No Aeroglass, no work.

Edited by dhjohns

Share this post


Link to post
Share on other sites

Not that kind of blur, but the default one. 

Default blur is

 

Windows Registry Editor Version 5.00

 

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Themes\Personalize]

"EnableBlurBehind"=dword:00000001

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...