Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


diamant

Audio CDs with Media-Player-Classic?

Recommended Posts

I tried to play an Audio CD using Media Player Classic (MPC) version 6,4,9,1.

 

More precisely, what I tried:

First of all I inserted the CD into the CD-Rom-drive. I selected "play" from the CD-right-click-menu, and the CD was played using the Win98SE-internal  cdplayer.exe.

 

Then I tried to play the CD with MPC. I started MPC, selected "file" - and there was a command "open disc", what should obviously start playing CD ... but the command was greyed out!

Then I tried to load the *.cda-files from the Audio-CD manually to MPC, but I also got a (well-known?) error message "cannot render the file" from MPC. :rolleyes:

 

I tried to edit some options inside MPC (e.g. assign *.cda file extension to MPC), but all with no effect - I got always the same error message, and the "open-disc"-command stayed greyed out.

I tried also some other MPC-versions than 6,4,9,1; always the same error occurs.

 

It seems that MPC hasn't detected that there was inserted a CD with files to play?!

Or that it can't find the correct filter(s) to play *.cda files?

 

So the deciding question: Did anybody ever have success to play an Audio CD with MPC? :whistle:

 

 

BTW: I had the same issue while using the player "mplayer" which seemed to be an interesting alternative to MPC, but it can't play *.mid-files (and no *.cda-files).

Share this post


Link to post
Share on other sites

I had problems with Windows Media Player 7 not playing CD's that I inserted in my CD-Rom drive. Problem sounds familiar to what you experiencing.

I don't know what the problem was. However, once I upgraded to Windows Media Player 9, it has worked perfectly for years. By the way, WMP9 also supports .MID files.

Share this post


Link to post
Share on other sites

Sorry for trying on XP, I don't have Win9x here... but with MPC6.4.9.1 can open audio CDs in both opening the cda files and using "Open Disc" menu. Do you have more optical drives?

Share this post


Link to post
Share on other sites

I have 2 optical drives. Same problem with both of them.

 

The WMP9 doesn't support other file-types which are played by MPC, i.e. *.mp4 and *.mov; I like the MPC (still) some little more.

 

Now I found a (partial) solution for the MPC:

 

It was possible to cause MPC to use the filter  CLAudioCD.ax.

At first I had to register this filter using the command  regsvr32 CLAudioCD.ax.

Then I added the following registry key:

[HKEY_CLASSES_ROOT\Media Type\Extensions\.cda]
"Source Filter"="{54F4C1CD-D46A-11D4-9D0E-DA91C8F4645E}"

That caused that I can now at least load *.cda-files manually into MPC.

 

But the "open-disc"-option stiill stayes greyed out.

MPC does not detect automatically if a CD is inserted.

 

BTW: If I insert a CD under WinXP, so MPC detects automatically(!) when the CD is inserted; the option "open-Disc" changes from grey to black and can be selected.
 

UPDATE:

It's now possible to play an Audio-CD if inserted into CD-Rom-drive automatically with MPC.

How-To: Associate the file-type "AudioCD" with  mplayerc.exe. But the filter (codec?)  CLAudioCD.ax  seems still to be needed. Maybe it's not possible that MPC uses the same filter like the Win98SE-internal cdplayer.exe?!

The option "open-Disc" stayes greyed out.

Edited by diamant

Share this post


Link to post
Share on other sites

Is it a  pressed CD? (not a burned CD that could be a special mode CD). The "Open Drive" menu becomes available only when an audio cd is inserted.

Share this post


Link to post
Share on other sites

Ummm how are you getting that? That's proprietary...

http://regrunreanimator.com/research/multimedia-tools/powerdvd/claudiocd-ax.htm

I have PowerDVD that will play DVD's.

 

MP4 - a Video file

http://en.wikipedia.org/wiki/MPEG-4_Part_14

Take a look at this.

http://en.wikipedia.org/wiki/QuickTime

Try QuickTime.

See this (install above to get MPC to play MOV)

http://www.moviecodec.com/video-codecs/cant-play-a-mov-file-in-media-player-classic-72485/

 

Or Google this:

mp4 software player

mov software player

 

Also this:

mp4 "media player classic"

 

Those formats ar Movies, not Music.

 

(Barking up the wrong tree...)

Share this post


Link to post
Share on other sites

You need to find an old version of MPC Standalone Filters which works for your OS. I know that they dropped support for older OSes in the newer versions, but older versions worked.

You need CDDAReader.ax (register it) and maybe another one (my memory is failing me).

GL

Share this post


Link to post
Share on other sites

@Ponch
It's an built Audio CD. Win98SE detects it as an Audio CD -- because the CD is shown with the Win98SE-"AudioCD"-icon in "my computer".
 

Ummm how are you getting that? That's proprietary...
http://regrunreanimator.com/research/multimedia-tools/powerdvd/claudiocd-ax.htm
I have PowerDVD that will play DVD's.

 
I had/have the file  CLAudioCD.ax  from Cyberlink archived from an USB stick.
BTW: I have also a Cyberlink filter for playing DVDs.
All with MPC 6,4,9,1.
The MPC can also yet play *.mov, *.mp4 and other.
 
Newer MPC-versions (called MPC-HC) don't work (they also don't play files or crash, even with KernelEx enabled), but were not needed until now.
 

@GrofLuigi
I tried  CDDAReader.ax (the oldest version available on sourceforge.net) and registered it; but with no success. With this filter I get the well-known "cannot render the file" error.
 
I now found a interesting posting on http://forum.doom9.org/showthread.php?t=29798&page=70, quote:
 
"I have installed powerdvd 5.0 and was trying to use the included audiocd playing filter (CLAudioCD.ax) for playing cd's with mpc on win98se. I know that the included audio filter only works with winxp which is why I was trying to get this to work. The "open cd-rom" option is greyed out so I go to open file and select a track to play but it doesn't work."
 
I have marked the deciding passage. It could maybe be that the internal MPC AudioCD-filter CDDAReader.ax will not work in Win98SE even with older versions of MPC?!

Edited by diamant

Share this post


Link to post
Share on other sites

The internal CDDA filter (v6.4.0.2) in MPC6.4.9.1 is "2K/XP only" (tip text). Disable it in View>Options>Internal Filters when trying external filters.

Share this post


Link to post
Share on other sites

For audio I use Trout by skwire (Jody Holmes) - based on the BASS library and for video I use GOMPlayer 2.1.43.5119 (later versions don't suport 9x anymore).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...