Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


xrayer

KernelEx Apps Compatibility List (New)

Recommended Posts

There's a slim chance that this actually is a bug (or a sum of bugs) and not intended behavior, especially since it manifests itself randomly. Guys at FastStone have been kind enough so far as to keep compatibility so I sincerely hope the issue will be fixed.

Share this post


Link to post
Share on other sites

Do you suggest that we should tell (ask) them about it?

Do you think they would make case of such vintage OSes?

Share this post


Link to post
Share on other sites

We don't know what their stance is regarding Win9x. Maybe, just maybe, they would at least check the code to see if the bug(s) would affect NT-based systems as well. I'd give them some time, maybe they'll receive feedback from other sources.

Share this post


Link to post
Share on other sites

Maybe related to the FastStone problem. I have noticed that on the new version of IrfanView (4.40) the German language dll can not be loaded when the exe is set as 'KernelEx disabled'.

Share this post


Link to post
Share on other sites

Since many years ago I have something against that application. Can't say what it is - maybe the ugly icon, maybe something else. I've installed it now though, to test in regard to your problem.

First thing that caught my eye was a default plug-in, the first one listed in the plug-ins window: ANSI2UNICODE.DLL. That one may have to be checked/uninstalled when testing under 9x.

Second thing was the checkbox saying "Load Unicode PlugIn at program start [...]" when opening the Language item in Properties (Main Menu > Options > Change language).

 

Now, apparently the main app can't load the respective German language file even in Default compatibility mode, regardless of the state of the aforementioned checkbox.

Disabling kernel extensions had an immediate negative effect on the toolbar icons, corrupting them. German language library still can't be loaded.

Changind compatibility mode to Windows 98SE allowed the German language to load, but the icons were much more corrupted than before. First half of them illegible - luckily there are tooltips.

In Windows2000 compatibility language file is loaded and toolbar icons appear correctly. Functionality untested.

Loading Romanian translation with KernelEx extensions disabled was succesful, but icons are still corrupted. Language file is old 4.37 version. Changing KernelEx to Default compatibility mode fixed the icons issue and language is still loaded.

 

I would conclude that the language SDK for the current version may need some tweaking or at least a VC6-compatible project be derived from the current VS2013 project and language files be compiled under Win9x and VC6 for full ANSI compatibility. But that has to be done on the user side.

 

P.S. I still hate IrfanView and I still don't know why... :)

 

(I can't live without typos…)

Edited by Drugwash

Share this post


Link to post
Share on other sites

Thanks for looking into this Drugwash !

Earlier today I contacted Irfan about this issue - fortunately he understands German very well - and only a few minutes later I had a VC6-compiled version of the German-dll (4.40) in my inbox !! Just awesome !!!

And I am so used to the often distorted toolbar icons that I don't notice them anymore.

So, I wouldn't say that I love this app but it does what I want and this new version fires up in under a second. I am quite pleased.

Share this post


Link to post
Share on other sites

Glad you got things sorted out. And of course, to each their own so if this application pleases you then everything's fine. :)

 

BTW, I created a VC6 language project from the VS2013 one using prjconverter but for building a working language library the respective translated .rc file is required. It may still need some tweaking (output is 164kB compared to original 151kB). If anyone wants the .dsp/.dsw files just wave your hand or whistle. :)

Share this post


Link to post
Share on other sites

I have sent a feedback and request to FastStone.

 

BTW, on their homepage, it is mentioned: 'All products work on XP, Vista, Windows 7, Windows 8.x and Windows 10'

but if you compare with the last snapshot from Wayback Machine (mars 30, 2015, with FastStone Image Viewer version 5.3) you get: 'All products work on Windows 98, ME, XP, Vista, Windows 7 and Windows 8'

so the bad news may be that they already know about that... 

Edited by CharlesF

Share this post


Link to post
Share on other sites

They must've adjusted the compatibility list sometime these days - I'm 99% positive I saw 98/ME up there when downloading 5.4 following your announcement above.

In that case there's nothing we can do. Another one bites the dust… :(

Share this post


Link to post
Share on other sites

FS Image Viewer 5.4 (OS WinME KernelEX 4.5.2015.8): 

The "Save as" function (post 399) and the Options button (post 402) work here, if KernelEX is enabled. They fail, if I disable KernelEX. Kext (kstub822) doesn't matter. So far I testet on one machine and KernelEX 4.5.2015.8 only.

Share this post


Link to post
Share on other sites

The option button becomes grayed out and unusable if I want to save as another format on Win Me with KernelEx enabled. Not that I care too much about FSViewer however as I am an XnView user and fanboy.

 

 XnView also requires Kernelex since a little while but no features are broken apparently. 

Share this post


Link to post
Share on other sites

The button works if I write the planned file type (with name) into the "Object name" box. The type must be the same in the "save as Type" box. 

On XP it works better.

Share this post


Link to post
Share on other sites

The button works if I write the planned file type (with name) into the "Object name" box. The type must be the same in the "save as Type" box.

Same thing here! :thumbup

You only need to manually add the extension in "Object name", after you have selected the file type.  :D

KernelEx is in default compatibility.

Share this post


Link to post
Share on other sites

The option button becomes grayed out and unusable if I want to save as another format on Win Me with KernelEx enabled. Not that I care too much about FSViewer however as I am an XnView user and fanboy.

 

 XnView also requires Kernelex since a little while but no features are broken apparently. 

Can you change the language of XnView? (Tools>Options>Interface or xnview.ini [start] Language= ) It sticks to English.

Possible is to copy the xnview.ini of "Application Data XnView" to the program folder in the case that the file doesn't exist in the program folder of XnView. Then set the desired language in the ini file. This file can disappear and XnView sticks to English again.

 

 

I can set Tools>Options>System integration>Save options>as ini file in folder to "XnView". Then I must set the desired language in the ini file. Afterwards the language selection works.

The other "Save options" for the ini allow no selection.

XnView Version 2.34. This behavior occurs with three machines here. OS WinME  

Edited by schwups

Share this post


Link to post
Share on other sites

FS Image Viewer v5.5 has been released. Unfortunately same issues as before:

- 'Save as' dialog won't appear unless KernelEx is specifically set to 98SE/ME compatibility (may work with 2000/XP too - haven't checked)

- Saving as different image type won't allow 'Options' (greyed out button) unless an extension is manually specified for the output file

It's sad that they couldn't (wouldn't?) fix such trivial (IMHO) issues. :( But hey, it still (mostly) works, with workarounds.

(I've only tried the portable zip version)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...