Jump to content

[SOLVED] problem with Vlite 1.2 and Win7 SP1 (MSDN)


Recommended Posts

I made a complete test successfully with Windows 7 SP1 MSDN! :thumbup

1) Installed WAIK 1.1 for Vista, and using GImageX.exe inside: C:\Program Files\Windows AIK\x86\

2) Using Apply tab and Capture tab with GImageX.exe

3) Restart the PC

4) Using vLite 1.2 (installed also vLite 1.1.6 Final to have wimfltr folder and files) with my Last Session.ini customized

5) To make "lite": Same process and method as explained here (because my Windows 7 x86 SP1 is with French language):


*I'm guessing the trouble (Windows could not find the digital signature for Winload.exe - [ and installation fails])

was to use WAIK 3.0 for Windows 7 first to Mount /Unmount Commit the image and after to use WAIK 1.1 for Vista.

Using ONLY WAIK 1.1 for Vista works fine, and the workaround given by bapt WORKS! B)


Edited by myselfidem
Link to comment
Share on other sites

It works for me with WAIK 1.1.

For whatever reason, which I dont understand, Gimagex wont work with WAIK 2.0 and WAIK 3.0 on my PC.

I am applying the dism batch file as I type.....

P.S. Thanks myselfidem for your help and patience ;)

Edited by theKramer
Link to comment
Share on other sites

It works for me with WAIK 1.1.

For whatever reason, which I dont understand, Gimagex wont work with WAIK 2.0 and WAIK 3.0 on my PC.

Thanks ;)

Using GImageX.exe or imagex.exe with WAIK 1.1 for Vista, I see I can keep the same temp folder to mount /unmount images.

But using WAIK 3.0, I need to change every time the temp folder after mounting /unmounting an image and always close the the current folder window if I use GImageX.exe, and if I don't use

the "workaround" below.



You must install the WIMMount filter before you can mount an image. Disable System Restore when running Windows image filter. Windows imaging filter may fail when copying files into the mount point. On Windows Server 2003,

running the xcopy command against a Windows image mounted from DVD or CD may cause system failure. Do not run the xcopy command during the mount.


Works whitout errors, with all WAIK, if I use the workaround and disabling Antivirus!

*Edit: Remember if you use another WAIK to move GImagex.exe and to set a new time inside the location = C:\Program Files\Windows AIK\Tools\x86\ (or .\amd64).

Edited by myselfidem
Link to comment
Share on other sites

Indeed, I have not yet to find how "unmount"

I use "take ownership" on each folder and delete the files after

Hello! :rolleyes:

To cleanup the temp folder (mount) more easily, After using Apply and Capture with GImageX.exe, I made a batch file: Cleanup.cmd (en-US/fr-FR)!

Also available for any temp folder for images x86 or amd64!


*Edit: NEW Batch files works fine and faster now (en-US/fr-FR)


Edited by myselfidem
Link to comment
Share on other sites

  • 4 weeks later...

In your note #3 you said you got a few small errors. Would you share them and how you dealt with them? Thanks in advance.


I replaced in Vlite's root folder wimgapi.dll with win 7's wimgapi.dll from WAIK tools ( WAIK tools folder -> x86 folder\wimgapi.dll )( have to download the iso from MS ) and install WAIK to get these files .

You will need to uninstall the Vista wimfltr that is loaded on your PC ( if you have ran vlite after installing it ) as the files from WAIK 7 are not the same , not sure how to do it manually as I have the InstWimFltr.exe by JFK from a winbuilder project that I use, that will uninstall the wimfltr of Vista's ( yep fixed that winbuilder project too with WAIK 7 Files )

Also a reboot when uninstalling these files wont hurt, after removal of the wimfltr of Vista's just to clear any memory that might be latched onto these files.

From WAIK, I also copied in the x86 and (amd64) wimmount.sys replacing wimfltr.sys by renaming wimmount.sys to wimfltr.sys respectfully in both x86 and x64 folders so yes delete wimfltr.sys in both folders first then copy in the win 7 files :).

I didnt change the wimfltr.inf at all, I left it as vlite installed it, I just replaced the wimfltr.sys in Vlite's folder with wimmount.sys from WAIK and renaming it to wimfltr.. easy peasy

what you end up with is Vlite using win 7 dll files, it werkd for me, but I got a error or 2 at first, then they went away, I made 4 builds back to back with the SP1 x64 and everything was fine and the iso installs fine too.

NOTE: even uninstalling Vlite from Add | Remove Programs DOES NOT UNINSTALL the Vista wimfltr!

NOTE 2: After running Vlite on a win 7 moddin win 7 have you ever encountered that DISM fails( Pre SP1 iso files that is )??

NOTE 3: I got a few small errors after doing the above from Vlite, but after a few errors passed all was good hence the TRY IT AT YOUR OWN RISK.

Anyways maybe that is enough for some more knowledgeable person to figure out a better werk around than what I have done.

Vlite does the job I want quicker than RTLite, RTLite is way to slow and seems like it wants to just freeze up the whole time I run it,.. a scalpel over a hammer any day lol , this is my werk around for that :)

Link to comment
Share on other sites

Just had to sign up to say thank you for solving this issue as I happened to become a victim of it today and I was really taking a big risk without testing it first on a virtual machine (it's not the first time it happens) and I've been spending the whole day trying to get Windows 7 SP1 integrated slipstreamed installed and I've faced all kinds of annoying issues with my older windows slipstream copies (I don't always name the CDs/DVDs very well :P) so been chasing after those and then I get probs accepting the HDD partition accept the partition as OS disk and what not so had to use a Maxtor HDD (for some reason I've always been able to rely on Maxtors when every1 keeps swearing they are the most unrealiable HDDs out there) I've stopped using to empty it completely and it finally let me install Vista where I'd have to take care of the Win 7 SP1 MSDN slipstream issues which was an easy task as I happened to stumble across this useful thread. So here I am and have just confirmed the install working in VMware so kudos to you guys for making my VERY BAD day better (you wouldn't have wanted to be with me in the same room, trust me, I've raged so hard... :P).

Edited by RPGWiZaRD
Link to comment
Share on other sites

NEW batch file to remove temp folder containing an mounted image. It's not needed to restart the computre now using WAIK for Windows 7:

CleanUpTemp.zip (fr-FR/en-US)



*EDit: Using WAIK SP1 for Vista it's needed to restart the computer to remove the temp folder using Cleanup.cmd!

Edited by myselfidem
Link to comment
Share on other sites

  • 3 months later...

When I try to remove components, Vlite always crashes after the first step (Preparing).

I've tried several versions of wimfltr, a normal install.wim and a "captured" install.wim.

Won't work on Windows XP Pro x64 and Windows 7 x64.

Any suggestions? :(

Link to comment
Share on other sites

  • 2 weeks later...

We can read inside the tutorial:


A. Install and configure

1.Download and install: "Automated Installation Kit (AIK) for Windows Vista SP1 and Windows Server 2008."

This program is provided free from Microsoft, and can be found here:


2. Download and install: vLitev1.2 Final : [ http://www.vlite.net/download.html].

First make sure you have first completed Step 1, and that you installed the correct AIK version—the AIK for Vista SP1, NOT the AIK for Windows7

(vLite 1.2 is designed for use with the AIK for Vista SP1) before downloading and installing vLite 1.2.

When vLite is launched, it looks for a few components of the AIK program and copies them into a few special folders of the vLite program. It needs these components.

If you encounter a vLite error during use

Various forums posts here note " vLite must be configured correctly". This means that vLite has, as expected, created certain folders and placed certain AIK components in them.

For vLite to do this, the AIK has to be installed before you launch vLite. Therefore, if you encounter errors using vLite,

· first ensure you have installed the correct version of Windows AIK required here (see Step1).

· See if a folder called "wimfltr" exists inside \ProgramFiles\vlite. (It would be inside \Program Files(x86)\vlite for 64-bit Windows). If that subfolder isthere, look inside it.

It should have inside two subfolders, an "x86"subfolder as well as an "x64"subfolder, and each should have 2 files inside them, wimfltr.inf and wimfltr.sys.

· If you have the correct version of Windows AIK installed (see Step 1), and installed vLite after installing the AIK, but those subfolders and two files are for some reason not there:

· Create a new folder inside C:\Program Files\vLite and name it "wimfltr"—be careful to spell it properly with an "m" (wim): "wimfltr" .

Then, create subfolders inside it called "x86" (\wimfltr\x86) and "x64" (wimfltr\x64).

Then copy the correct versions of wimfltr.sys and wimfltr.inf into them, as follows:

These are the 2 files: wimfltr.inf, wimfltr.sys

Copy them both from here,

C:\Program Files\Windows AIK\Tools\x86 to here, C:\Program Files\vLite\wimfltr\x86,


Copy them both from here,

C:\Program Files\Windows AIK\Tools\amd64 to here, "C:\Program Files\vLite\wimfltr\x64.

If vLite crashes during use

Ensure you have unmounted any previously mounted images. Close any other programs that were running when you ran vLite.


Rerun vLite with no other programs running or images mounted.

Crashes can happen.Reboot, try again.

I hope that can help you!

Edited by myselfidem
Link to comment
Share on other sites

  • 3 weeks later...

What is the correct sequence and tool (not procedure) to:

1. Integrate IE9 with Win 7 SP1 MSDN

2. remove winsxs

and still be in a position to further remove/ tweak the components in vLite?

Is it possible to remove winsxs and still be in a position to install windows update?

What I have done so far:

1. Used RTLite to integrate IE9

2. Used gimagex for apply/ capture to remove all unwanted version.

If I skip step one, I can use vLite to remove/ tweak feature but I cannot integrate IE9 with winsxs removed

If I use step 1 and 2, the image does not open in v:ite to enable me to remove features.

Kindly help.

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

Has anyone of you been able to vlite an up-to-date Windows 7 Image?

I install Windows in a VM, download & install all updates available and sysprep it into an up-to-date install.wim (which is 3,8GB in size then). Then I apply & capture the image as described in post #105, but vlite just crashes due to an unhandled exception at 50% of the "Preparing" process. <_<

I works fine with my stock Windows 7 SP1 image though. :wacko:

Edited by neo2k
Link to comment
Share on other sites

@ neo2k,

you stated "it works fine with my stock windows 7 sp1 image though." could you post your process or steps so i can try and duplicate, i'm using win se7en x64 pro ¿

thanks for any help,

michael clyde

Edited by mchldpy
Link to comment
Share on other sites

@ neo2k,

you stated "it works fine with my stock windows 7 sp1 image though." could you post your process or steps so i can try and duplicate, i'm using win se7en x64 pro ¿

thanks for any help,

michael clyde

What process do you mean? I described it in my previous post, didn't I?

Link to comment
Share on other sites

  • 2 months later...

from the beginning: (is that right ?)

1. install WAIK 1.1 for vista SP1

2. use GimageX as done on post #105

3. use myselfidem's instructions as on post #166

but what components are not removable in vlite ? and how much can be deleted from the 7 installation ? I missed the part that deals with the actual deletion

Edited by monohouse
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...