Jump to content

7Customizer - a Windows 7 Customization and Deployment tool

Recommended Posts



7Customizer should be used before vlite on modified installation.

Well, as it turnes out this is not the whole story.

Today I managed to Vlite the so called 'removal phase' win7 source, with a Last Session.ini that I'm attaching.

I did that with the Win7 AIK, and managed to bring the installation to 1.8G.

I then ran 7cusomize on it, and including all the Windows Update files I have an ISO of 2G.

All is running well, and I'm actually typing now from the new installation.

BTW 4 out of 57 windows updates failed, probably because they were updating stuff that wasn't there. :)

I'm attaching again the log file.

Regarding the tweaks, all these tweaks and lots more will be implemented.

Wow, as soon as that happens I really will have a Win7 installation CD that will account for all my needs.

Thanks again blue4603




Link to comment
Share on other sites

Blue, under unattend tab > Time and Currency, Portuguese (Brazil) option is not available. To correct that I need to manually edit Autounattend.xml file and replace <UserLocale>pt-PT</UserLocale> for <UserLocale>pt-BR</UserLocale>.

Can you correct that?

thanks for program.

Edited by Sydnelson
Link to comment
Share on other sites

Vlite only need two files from waik.. and it needs the waik for vista, not win7..

So u actually only need 2 files, and not the whole waik package..

Edited by puntoMX
Removed download link, WAIK files may NOT be distributed that way.
Link to comment
Share on other sites


You are most welcome


Your experiments are really nice. Maybe later in future release I will implement 7Customizer so that it will be able to work with modified installations.

For now we will focus on more important stuff

Thanks for your feedback and testing.


Yes. I will add it in the next release.


hi Avnerk how did u managed to run vlite with waik7 please tell me i tried vlite with waik7 but it is asking for

Automated Installation Kit (AIK) for Windows Vista SP1 and Windows Server 2008


This is not a thread for these kind of problems. Post it in vlite section.


Link to comment
Share on other sites


Why do you want to delete the mount folder? 7Customizer needs this folder to work properly

If you want to delete the contetn of mount folde first make sure that there is not any image mounted. If there is just unmount it using imagex.

Thanks for the registry tweaks file


Link to comment
Share on other sites

First, I would like to thank you for your tools.

Second, I think the only thing missing for got an entire "replacement for vlite" application, it's an iso maker build in 7customizer ; so I would like to submit an idea : why don't you add a path line under "Dism" and "ImageX" wich ask for the path of "oscdimg" ?

I use this line and it works fine for me :

oscdimg -u2 -m -h -b"D:\System\TOOLS\WIN7_UPD\boot\etfsboot.com" "D:\System\TOOLS\WIN7_UPD" "D:\WIN7_UPD.iso" -lWIN7_IMAC24

(Information for user of certain MacUser : if you make your "iso" with this standard command line it wiil fix the EFI boot problem).

Thank you very much for reading me.

jL (France)

Link to comment
Share on other sites

Absolutely, positively, unequivocally interested in this tool. I've been working with nlite and vlite, and Windows 7 is the next unattended installation to create, trimmed of all the MS fatty fat. If there is a user guide for this particular software that I missed, please reply with the link.

Link to comment
Share on other sites


Thanks for the update. Trying it now.

1. In the Tweaks tab under Start Menu there are two items missing:

System Administrative Tools:

a. Display on the All Programs Menu

b. Display on the All Programs Menu and Start Menu

c. Don't display this Item.

2. Task bar - Notification Area - Customize.

3. At this stage (56 tweaks) a preset file would help a lot.

it takes some time to go over them again and again :) Sorry for nagging.

and thanks again



All tweaks worked fine under 0.2.5


Edited by avnerk
Link to comment
Share on other sites

i get error every time i select my syspreped image. log. by the wat. i have good tweaks for 7 that i can upload to you. is it needed?

=== 7Customizer Started===
7Customizer verion: 0.2.5
OS: Microsoft Windows NT 6.1.7600.0
OS architecture: AMD64
Work folder found: True
Mount folder found: True
Extract utility found: True
Configuration file found: True
Getting drive info
Free space: 13,3337745666504 GB
Getting drive info: Done
Saved Imagex path:
Saved DISM path:
ImageX Path Selected
ImageX Path: C:\Program Files\Windows AIK\Tools\amd64\imagex.exe
Dism Path Selected
Dism Path: C:\Program Files\Windows AIK\Tools\amd64\Servicing\Dism.exe
Windows source path selected
Sources folder found
install.wim found
install.wim size: 3820 MB
Testing imagex
Imagex result begin:

ImageX Tool for Windows
Copyright (C) Microsoft Corp. All rights reserved.
Version: 6.1.7600.16385

Imagex result end.
Testing dism
dism result begin:

C��⥬� DISM
�����: 6.1.7600.16385

dism result end.
added: "C:\Program Files\Windows AIK\Tools\amd64\imagex.exe" /XML /info "E:\w7ru9\sources\install.wim">work\imagesinfo.xml
Starting imagex
Imagex created imagesinfo.xml Successfully
Reading images information from imagesinfo.xml
First 5 lines of imagesinfo.xml
Number of Available Images: 1
Available Images: Begin
Unexpected Error: there is no link for object.
в _7Customizer.Form1.selectImagePathBtn_Click(Object sender, EventArgs e)

Edited by mickmack
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...