Jump to content

HOWTO create a fully up to date XP x64 DVD (EoL Feb 2016)


Recommended Posts

Kurt, thanks once more.

I have a couple of questions but will try to refrain from directing future questions about VMware to you.

Why are you not running VMware Tools? Everything I see indicates it will help your guest performance, synchronize your clocks and allow copy and paste from the host to the guest and more. I may be naive but since it is an installed program on the guest, you may be able to extract it and include it with your integration process. I am guessing that it is included in the 491 MB file I am DLing right now (Beta, now 90% complete), but maybe it is not free and requires real money. I have looked all over the VMware site and can't find any info on VMware tools except how to install it. It looks like to install it, simply click VM then click Install VMware Tools. The DL is complete. I extracted it and out came only 7 files/folders, a total of 36 MB?????? I did not find anything that looked like VMware Tools. Versions 1.0.4 and 1.0.5 are only 146 MB Dls. I didn't DL them but I wonder why 2.0 Beta is so much larger - discourage players?

I have studied the image you posted and cannot find your name at all - no big thing.

Thanks for the tool. I ran the Windows only version from their web site. I am OK but I suspected that since my CPU is family F as shown by CPU-Z. I assume your desktop won't work because the family is too low.

I installed Java 6u6 on a minimally nLited disc containing only SP2 and unattended stuff to make it silent and saw the same results. I don't know how to write Java Script or what I might have around to test it, so I'll just wait till I get VMware Server running and see what happens. I assume I will be able to get an Internet connection.

I think IIS is installed on your systems unless you specified in the Unattended phase not to install it as I have (will allow install). Update KB942830 (in your hotfix list) is to IIS.

Thanks again.


Link to comment
Share on other sites

491MB for the beta? Yipe!! To think that Virtual PC 2007 is only 30.5MB and Virtual Box is only 20.6MB. Even allowing for debugging code, there's got to be some serious bloat in there.

I didn't bother installing VMWare tools as it is unnecessary for testing purposes. There is a file "Windows.iso" located at "Program Files (x86)\VMWare\VMWare Server" that includes the drivers. Some can probably be integrated, but I haven't actually tested this.

IIS is installed in the guest OS as I have to ensure no updates for it are needed. Note that if you choose to install IIS from the nLite option box in the unattended section, it's only partially installed.

Link to comment
Share on other sites


I installed and ran VMware Server 1.0.5 and it runs great! An install of my nLited disc took about 15 minutes. QEMU takes 1.5 hours minimum. I tried to install 2.0 Beta without success. I will send VMware a note, but it may be that IIS is not installed on my machine.

With an Internet connection, I visited a speed test site that uses Java and discovered that my Java does not work. Now I have a platform to debug this issue.

Thanks for all your help.

This is fun!

Enjoy, John.

Edited by johnhc
Link to comment
Share on other sites

  • 2 weeks later...

Kurt, Here is the answer you gave on a question I ask some time ago about updating the Registry:

3. To include a .reg file use a command like that for Key.AnyDVD [if exist %Source%AddOns\Key.AnyDVD Regedit /S %Source%AddOns\Key.AnyDVD], replacing Key.AnyDVD with MySetting.reg. The "If exist %Source%AddOns\Key.AnyDVD" part of the command is not really necessary, but if you execute "Regedit /S %Source%AddOns\Key.AnyDVD" and the reg file isn't found the installation will halt with an error message

I have tried to do what I think you mean and wanted to check if it is correct. I cannot see your Key.anyDVD or find MySetting.reg, so I may be up the wrong tree.

My code:

If exist %Source%AddOns\UnBlock_FAST.reg Regedit /S %Source%AddOns\UnBlock_FAST.reg

UnBlockFAST.reg contents:

Windows Registry Editor Version 5.00

"%windir%\\system32\\usmt\\migwiz.exe"="C:\\WINDOWS\\system32\\usmt\\migwiz.exe:*:Enabled:Files and Settings Transfer Wizard"

Please let me know if I am on the right track.

Thanks, John.

Link to comment
Share on other sites

This may be totally off topic but i thought i'd mention it anywy.

If i use the Visual basic installers as mention in post #1, i integrate x86 and x64, i still get double installers showing up at add-remove-programs,control panel, when i install f.ex Ati drivers for system chipset, etc. This Ati Installer has own VB setup files, and i think maybe one problem is there. Also I know that Ahead Nero 8 micro edition has these VB installer files, which i found funny (micro edition).

So if i basically first install VB in itself, then these two programs, or one of them i dont remember you see atm, i will get double up for x86 version at least in add/remove programs. And i dont like that. I have downloaded the latest version of VB and dont understand where the problem really is.

Maybe the ati/nero installers just force VB anyway. But it shouldnt force double up uninstlallers. Also i remember that size of VB in add/remove was different.

Link to comment
Share on other sites


Your example is correct.


I don't entirely understand your problem, could you post a screenshot?

Imagine Add/Remove Programs in Control panel? You start it, and you see 2 entries for visual basic runtime files for x86 f.ex

Not just 1 entry. Sorry for bad writing. One other thing tho i have had much trouble with disk.sys since i bought new computer, always used xp pro x64 since it came out almost, and now have random disk.sys bsods. I was only wondering if there is some update that could cause instability on some part with disk.sys? It's driving me crazy. Not that i arent already. On Vista x64, no trouble, so it is the os.

One more thing, .Net framework 1.1 on x64, xp at least.

I know it will install and installer works great, tho small notice on install. Is not .net 1.1 needed because 2.0/3.0 does not contain it?

Also if i do not install .net 1.1 on xp x64 and i run CCleaner, then it will find missing registry keys for .net 1.1

At least thats what i remember it reports, it could be that ccleaner just doesnt understand like variables for windows paths f.ex %systemroot%. (tho it does understand that, but x64 has some folders 32bit doesnt have, and there may be 'conflict' in ccleaner there on x64 versions).

Edited by TranceEnergy
Link to comment
Share on other sites


In going line by line through your RUN1_XP-64.BAT file, I came up with some questions and a comment:

1. You install Visual C++. Is this your preference or does something else need it?

2. You install VirtualBox and VirtualPC. My searching indicated that neither support x64 guest systems. Is this correct? BTW, I find VMware Server great!

3. The name of the DirectX installer is now directx_mar2008_redist.exe since the latest update.

Thanks, John.

Link to comment
Share on other sites

On a sidenote Visual Basic 2008 runtime files have been out on the market for a while.

I havent downloaded the x64 version yet, so i dont know 100% that it exists, but i would believe so.

The directx installer here runs from %Source%DX9c\DXsetup.exe /Silent, which is from the extracted directx_mar2008_redist.exe.

No problems here installing that. I talk to friend who is a programmer and he uses c+ express 2008 edition, which he says is very popular.

Coding games demos etc. I am curious, if 2008 version contains backwards compability, and system can be patched so 2005 version is not needed.

But as i wrote in previous post, i think certain installers, ie the ATI drivers installer, forces the 2005 install anyway.

Link to comment
Share on other sites

No new updates this month.

KB943729 (Group Policy Preference Client Side Extensions) still doesn't work properly with Windows Update, if it's still not working next month it will be dropped.

Added information on testing:

I use VMware Server for testing purposes, it's free but has some limitations (no sound for one) and requires registration. Before downloading and installing, use this tool to ensure that your processor will support 64-bit guests. Silent installation of Virtual Machine extensions is supported, there is a file "windows.iso" at "\Program Files (x86)\VMware\server" extract its contents and save them to \AddOns\VMware.

The good news for the month is that there is a new version of the WMP11 slipstreamer out (v1.2) that fixes the problems with XP x64 integration. So you can once again get your Boooggy on.


1. Visual C++ is entirely optional, just like .Net, Defender, et al. I've restructured the download list to make this clearer.

2. You are correct in that neither Virtualbox nor VirtualPC support 64-bit guests. They are supported for installation in Run1_XP-64.bat because compared to VMware server they are about 1/5 the size, take about 1/10 the time to install and do not require registration. The most useful O.S. for a user of XP x64 to virtualize is Win 98se, for this VirtualPC 2007 is best (VirtualBox doesn't properly support 98se).

3. As TranceEnergy noted, you missed the part about EXTRACTing the DirectX redistributable, again I've made it clearer.

Trance Energy:

I haven't included .Net 1.1 because it isn't officially supported on XP x64, yes I know it can be made to work but as far as is feasible this guide will use only those programs / runtimes that are officially supported.

I was going to include the Visual C++ 2008 runtimes, but Microsoft brilliantly decided to give the file the exact same name as the Visual C++ 2005 SP1 runtimes. As I've come across a program that requires the 05 version (and won't work with the 08 one), guess which version gets the slot?

As I've never encountered your double entry problem (even on my ATI chipset laptop I use for testing), I don't think I'll be able to help you.

Link to comment
Share on other sites

Kurt, Thanks again!

I indeed did not see the part about extracting DirectX.

I was just about to start looking at how to silently install VMware Tools, so thank you very much for that.


Link to comment
Share on other sites

I used to use wmp ss 0.991 i think it was, with no problem, i deleted the old version yesterday so dont really know if it was 0.991 or 0.996 lol.

Anyway wmp ran just fine, tho i am currently moving more to using only portable firefox with media connectivity plugin, so to use vlc or mplayer instead of wmp.

One quick thing about wmp11 and its integration: upon finished install if i go into sysoc.inf file and delete "hide" from wmp11 files, i can remove certain extra files from add/remove in control panel. I dont know if it actually does anything, but it looks like it anyway.

I find the wmp11 network and sharing services or what they were called, bloatware, annyoing at best.

Maybe it could be made a registry file or something so the extra wmp crap can be deleted upon install or so.

I'm also hoping nuhi will take a better look at x64 after a while. the Iasjet service has been laying around as dead meat for ages now.

Ie the service entry and name are all there, except the service doesnt exist as its removed,that is on my test install showed here.

Link to comment
Share on other sites


I have been installing a few items at a time (I have allocated only 4GB virtual C disk) using your procedures and have run into a problem with .NET 3.5. Somewhere in the middle of the install, my host computer suddenly restarted. I found nothing in my host System log or my guest System log. I copied the install file from the DVD to my guest DT. I checked the hash and it was correct, then executed it with no problems. A few steps into the install, it gave me a dialog about DLing 65 MB. It did not identify what was being DLed, but it completed (an told me I could close my Internet connection) and proceeded with no problems. I assume (perhaps falsely) that there is no Internet connection at the time your procedure is running. This all brings up a few questions:

1. What was it DLing?

2. Is this what crashed my host?

3. How can I get around this problem (assuming it repeats; only tried once) ?

4. Have you installed .NET 3.5 with no problems?

Thanks for any help.


Link to comment
Share on other sites


4GB? That's a bit cheap, I'd recommend at least twice that. I allocate a 16GB dynamic virtual HDD on a USB HDD attached to my laptop when testing. With the full application loadout that I test it uses 6GB.

To your host computer, your VM experiments just look like another application, admittedly one with more intense disk usage and deeper hooks than most. Probably the best comparison is to an Anti-Virus scan. In other words it's extremely unlikely that your host crashing has anything to do with the guest installing .Net 3.5

1. As the .Net installation was crashed midway, the installation would have been damaged. The download would most likely be something to do with the repair.

2. It did not crash the host, these are not the droids you're looking for...

3. Try again, hard to see how it's anything but a freak coincidence.

4. I've never had any problems installing .Net 3.5 in at least 10 trials.

All my install tests are done with the VM having no net connection and I recommend real installs be done the same way. Vista is a bit different in that it checks for driver updates as part of the install, hence installing while connected behind a router makes sense in Vista's case.


The problem with the WMP11 slipstreamer was that WMP11 would not initialize in limited accounts (Boooggy said there were some other problems as well), so if you only run as an administrator, you wouldn't have come across the problem. Also the limited account problem was a regression bug, it didn't exist in version 0.96 or earlier of the slipstreamer (but KB941569 wouldn't integrate). That being said, I don't use WMP11 either, I use Media Player Classic (less resource use and I don't have a music library to manage).

The one thing I'd really like fixed is the Windows Update service when IE7 is integrated, my method of altering the link's properties, while it works, is a bit dodgy.

Edited by Kurt_Aust
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...