Jump to content

[RELEASE] Boooggy's WMP 11 direct integration solution


boooggy
 Share

Recommended Posts

Dam, I got some bad info somewhere (forgot where I read it). Would have been nice for Microsoft to include WMP 11 and IE 7.

I guess Booggy's WMP 11 will be re-written a bit after SP3 comes out (since I would assume the hotfixes will not be needed)? Same goes for the IE 7 "NR_IE7en_Addon_1.1.0.7" pack I have now (for same reason).

Edited by Mike89
Link to comment
Share on other sites


i will not rewrite anything as long as sp3 doesnt contain any wmp 11 and its hotfixes.

sp3 contains wmp9.

and of course it would be nice that they were included ...but microsoft decided not to. so slipstreamer will be the same .....

Edited by boooggy
Link to comment
Share on other sites

As for the WMP11 updates not being needed, that would be incorrect as well, because the WMP11 updates are applied to WMP11 files, not Windows Files, so even with SP3, the WMP hotfixes will still not be applied. Not to mention that even once SP3 is RTM, it doesn't mean that people won't continue to integrate only SP2, since certain things that some people like (the Address Bar on the Taskbar) are going to be removed.

Link to comment
Share on other sites

x64: Setuperr.log errors:

Hi Boooggy,

I looked into this a little more, I know you hate x64 but please keep reading.

I had more luck using the Integrator BEFORE nLite.

-So I started with a fresh x64 SP2 and applied the integrator with all fixes.

-After that I applied nLite with the attached settings.

Afer installation WITH WinNT32 a had a functional system with only one line in setuperr.log:

Error:
Setup was unable to process some components because of the following error in section InstallWMP7 of information file wmp.inf:
The data is invalid.
***

I can probably live with that but do not know what it means.

And btw the "Play All" problem with x64 is now gone :thumbup

Last_Session.ini

Link to comment
Share on other sites

i know about that error, dutchman and it will be fixed in next version.

x64 wmp integration is been a pain in the arse....hopefully this time it will work without errors.

Edited by boooggy
Link to comment
Share on other sites

  • 3 weeks later...

I would love to get this to work but it isn't could you help. Using a fresh copy of windows sp2 and it wouldn't slip in:

WMP11Slipstreamer v0.991

Detected source: Windows™ XP Professional SP2

System.Exception: Delta API failed to apply patch "_sfx_0010._p" to the file "update.exe". ---> System.ComponentModel.Win32Exception: Unknown error (0xc00e4102)

--- End of inner exception stack trace ---

at WMP11Slipstreamer.Backend.NativeExtractHotfix(String hotfixInstaller, String destinationPath)

at WMP11Slipstreamer.Backend.ExtractWMP11Installer()

at WMP11Slipstreamer.MainGUI.workerMethod(Object addonSettings)

Deleting "C:\XPCD\i386\wmp11temp"... FAILED!

An exception occurred while attempting to delete the temporary folder to revert the changes done to the source.

System.UnauthorizedAccessException: Access to the path '_sfx_.dll' is denied.

at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive)

at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive)

at WMP11Slipstreamer.ErrorForm..ctor(Exception ex, Boolean critical, String tempFolder, String osString, String hotfixList)

Thanks.

Tom

Link to comment
Share on other sites

I tried integrating WMP11 and the hotfixes and I get an error. If I just integrate WMP11 without the hotfixes, it integrates fine.

I get the following when doing the hotfixes. Sorry, I didn't try each one seperately to find the culprit(I did try it without the .msu file):

WMP11Slipstreamer v0.991

Detected source: Windows™ XP Professional SP2

Hotfixes:

Windows6.0-KB929399-x86.msu

windowsmedia11-kb928788-x86-intl.exe

windowsmedia11-kb929773-x86-intl.exe

windowsmedia11-kb932390-x86-intl.exe

windowsmedia11-kb933547-x86-intl.exe

windowsmedia11-kb935551-x86-intl.exe

windowsmedia11-kb935552-x86-intl.exe

windowsmedia11-kb939209-x86-intl.exe

WindowsMedia11-KB939683-x86-ENU.exe

windowsmedia11-kb942264-x86-intl.exe

windowsmedia11-kb944110-x86-intl.exe

windowsmedia11-kb944882-x86-intl.exe

windowsmedia11-kb946665-x86-intl.exe

WindowsXP-KB941569-x86-ENU.EXE

System.ComponentModel.Win32Exception: %1 is not a valid Win32 application

at Epsilon.Win32.Resources.ResourceEditor.throwWin32Exception()

at Epsilon.Win32.Resources.ResourceEditor.loadResourceLibrary()

at WMP11Slipstreamer.CM.GetCabData(String pathToSfxCab)

at WMP11Slipstreamer.Backend.NativeExtractHotfix(String hotfixInstaller, String destinationPath)

at WMP11Slipstreamer.Backend.standardHotfixApply(String fixesFolder, Dictionary`2 hotfixFileDictionary)

at WMP11Slipstreamer.Backend.ApplyFixes()

at WMP11Slipstreamer.MainGUI.workerMethod(Object addonSettings)

Deleting "F:\VRMPOEM_EN XP2C\i386\wmp11temp"... Done!

The source being modified has not been damaged.

All changes have been successfully reverted.

Link to comment
Share on other sites

First of all a MSU file is an update for Windows Vista, not XP. There is a mixup of download links in one of the KB articles, all of the hotfixes should be exe files.

This is the reason of this error. Also if one of the hotfixes is corrupt (corrupt download) this will also happen.

Go into your hotfix folder and double-click on each hotfix (get rid of the MSU first and get the XP version) and the one that just flashes a console window without running is the culprit. Redownload it since it is corrupt and causing this issue.

In the next version I will build in a check for corrupted files.

Link to comment
Share on other sites

Ahh, I see. I'vd been a tad busy. Instead of waiting for a response, I installed the OEM SP2C disc and then used SP3 RC refresh. I am testing at the moment and waiting on activating. I'll simply need to install WMP11 after. But, even if I hadn't had the error, I had a problem with my nlited discs, so I had to use the factory disc as stated previously(Of course, the nlite problem is immaterial here.).

Link to comment
Share on other sites

Hi all,

im get an error during the WMP11 slipstreaming. Can anyone give me a hand on this error. Plz

Thanks very much

This is the bug report:

WMP11Slipstreamer v0.991
Detected source: Windows™ XP Professional SP2

Hotfixes:
windowsmedia11-kb928788-x86-intl.exe
WindowsMedia11-KB929399-v2-x86-INTL.exe
windowsmedia11-kb929773-x86-intl.exe
windowsmedia11-kb933547-x86-intl.exe
windowsmedia11-kb935551-x86-intl.exe
windowsmedia11-kb935552-x86-intl.exe
WindowsMedia11-KB936782-x86-ENU.exe
windowsmedia11-kb939209-x86-intl.exe
WindowsMedia11-KB939683-x86-ENU.exe
windowsmedia11-kb942264-x86-intl.exe
windowsmedia11-kb944110-x86-intl.exe
windowsmedia11-kb944882-x86-intl.exe
windowsmedia11-kb946665-x86-intl.exe
WindowsMedia-KB911564-x86-ENU.exe

System.IO.FileNotFoundException: Could not find file 'D:\Data\xp setup\i386\wmp11temp\Fixes\WM11\wmvcore.dll'.
File name: 'D:\Data\xp setup\i386\wmp11temp\Fixes\WM11\wmvcore.dll'
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileInfo.get_Length()
at Epsilon.Win32.PeEditor..ctor(String pathToPe)
at WMP11Slipstreamer.Backend.standardHotfixApply(String fixesFolder, Dictionary`2 hotfixFileDictionary)
at WMP11Slipstreamer.Backend.ApplyFixes()
at WMP11Slipstreamer.MainGUI.workerMethod(Object addonSettings)

Deleting "D:\Data\xp setup\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.

Link to comment
Share on other sites

Why is the menubar showing on my integrated WMP 11?

Process:

1. nLite'd

2. WMP integrated with Tweak option

(I just read that it should be the other way, but first time I did that, it didn't work - Maybe because I removed the WMP10 component with nlite?)

Which tweaks are applied with tweak option?

Link to comment
Share on other sites

first of all u should not remove any wmp componentsw with nlite.

second the tweaks are toooo many to be enumerate. anyhow....we are working to separate the tweaks which will appear in one of the next versions.

if u dont want the menu bar choose vanila.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...