Jump to content

RC8 "Advanced INF Install Failure"


Recommended Posts

I've been slipstreaming for a while with nlite.

I recently came across a problem when I slipstream using RC8.

Upon installation following the slipstream, under each user on first login the "Advanced INF Install" runs 3 times. With users without admin, it generates 3 "Advanced INF Install Failure" , it is due to lack of installation privelege.

I repeated the slipstreaming process form scratch using RC7 and these symptoms were not present.

One quick question:

the update log for RC8 shows direct integration compatibility with the various april and may updates, does this mean that RC7 is not compatible with these updates? I slipstreamed using RC7,including my own switchless of the flash patch, and it has seemed to work fine.

Anyone else with these symptoms, problems? Thanks everyone.

Link to comment
Share on other sites

I too am recieving this error, although I'm getting the INF errors twice. I spotted these entries in NLITE.INF:

HKU,".Default\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","nlpo_01",0x00020000,"rundll32 advpack.dll,DelNodeRunDLL32 ""%10%\Help\Tours"""
HKU,".Default\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","nlpo_02",0x00020000,"cmd.exe /c md ""%SYSTEMROOT%\Temp"""
HKU,".Default\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","nlpo_03",0x00020000,"rundll32 advpack.dll,DelNodeRunDLL32 ""%SystemRoot%\System32\dllcache"""
HKU,".Default\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","nlpo_04",0x00020000,"cmd.exe /c md ""%SystemRoot%\System32\dllcache"""
HKU,".Default\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","nlpo_05",0x00020000,"cmd.exe /C move /Y ""%SystemRoot%\System32\syssetub.dll"" ""%SystemRoot%\System32\syssetup.dll"""
HKU,".Default\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","nlpo_06",0x00020000,"rundll32 advpack.dll,LaunchINFSection nlite.inf,nLiteReg"
HKU,".Default\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","nlpo_07",0x00020000,"rundll32 advpack.dll,LaunchINFSection nlite.inf,S"

I believe our problems are going to lie somewhere here. I'm about to do some testing and report back in a bit.

Edited by razormoon
Link to comment
Share on other sites

Ok then...

in NLITE.INF (as shown in the previous post), I have removed the following entries:

Section [C]

HKU,".Default\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","nlpo_04",0x00020000,"cmd.exe /c md ""%SystemRoot%\System32\dllcache"""
HKU,".Default\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","nlpo_05",0x00020000,"cmd.exe /C move /Y ""%SystemRoot%\System32\syssetub.dll"" ""%SystemRoot%\System32\syssetup.dll"""


Section [R]


I could not find a related entry for syssetub.dll or syssetup.dll in RC7, but I did find

a reference for the dllcache.


Section [T]

HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx\nlQl",0,,"rundll32 advpack.dll,DelNodeRunDLL32 %SystemRoot%\System32\DLLCache"

Well...those were MY two inf errors...

I really don't know what these two lines are doing. What I do know is that they run every time a new user account is logged into. I was wondering if running just once is enough and if thats the case then we can change






Any suggestions...advice?

Think I'll just go and use HKLM for now...just in case.


Just noticed that most entries in RC7 are HKLM (including dllcache)

Edited by razormoon
Link to comment
Share on other sites

The error isn't nLite.inf's fault (as I was trying to tell you by linking to ViVa's post and subsequent discussion).

Like that thread says, the problem is that nLite.inf isn't in txtsetup.sif, so sysoc.inf can't find it. While it's admirable that you've spent all that time trying to hunt down the problem, the answer's been right in front of you the whole time ;)

Edited by RyanVM
Link to comment
Share on other sites

Hey Ryan...!

Thanks for the reply, but I think you should have a look at this...

netwv48.inf = 100,,,,,,,20,0,0
netx56n5.inf = 1,,,,,,,20,0,0
netx500.inf = 1,,,,,,,20,0,0
netxcpq.inf = 1,,,,,,,20,0,0
ngrpci.sys = 1,,,,,,,,3,3,,1,4
NirSoft.cab = 1,,,,,,_x,,3,3
NirSoft.inf = 1,,,,,,,20,0,0
nlhive.inf = 1,,,,,,_x,,3,3
nlite.inf = 1,,,,,,,20,0,0 <<<<<<<<
nmas.dll = 100,,,,,,,,3,3
nmasnt.dll = 100,,,,,,,,3,3
nmchat.chm = 1,,,,,,,,3,3

This has NOT been added manually. Could it be ppl installing over RC7 without uninstalling first??

As I posted before, I did find the issue. I've since HKLMd all 7 entries and the unattend is doing fine.

That is unless, one of those entries should be entered into user\.default




Clean MCE

NLite with a buttload of addons and update pack (tweaks too) oh, sfc, uxtheme and wga are addons, NOT nlite

BTS Driverpacks


Edited by razormoon
Link to comment
Share on other sites

Thanks for all the replies.

Bottom line.

Is there a difference in the way the slipstream is handled by RC7 and RC8?

Since I have only had the problem with RC8, is there a major reason not to use RC7?

Have there been any bugs in RC7 not allowing direct integration of the latest hotfixes and patches?

And last question (can of worms):

Is there a reason why the tweaks would be applied only to the HKCU instead of HKLM? I notice RC7 uses

HKLM's where RC6 used HKCU? Does RC8 go back to using HKCU? If so, why?

I'm new and I appreciate all the support (only been nlite'ng since RC4) Big Thanks to everybody.

Link to comment
Share on other sites

The issue is still persistant after many trials.

These slipstreams DO NOT involve driver integration. (It was my first guess originally)

The symptom is specific to the registry runonce "cmd" lines entered by RC8 that involve modification

of the "%systemroot%" directory. The error then occurs when due to the use of the HKU, that runs once

for all new users.

In actuality there are three entries of this nature, but because one involves the users temp directory no error is thrown.

Both the NLHIVE.INI and NLITE.INF are definately being processed, if they weren't then the error would not occur.

I'm wondering why RC8 uses these "cmd" calls even when tweaks are not done (example, only hotfix integration) wher RC7 does not.

Big thanks to all those working on this.

Now here is the question to show how much i don't know:

How do i recompress the nlite.inf after i've manually edited it? THanks

Link to comment
Share on other sites

all nlite builds are deleting par example dllcache folder......

and for me this err only appears when i integrate drivers on my cd. (tested several times)

Edited by boooggy
Link to comment
Share on other sites

How do i recompress the nlite.inf after i've manually edited it? THanks

You're gonna need cabtool.

Since it's only an INF, that's all you'll need. I'm not sure if that specific tool also modifyPEs (pechecksum - which you can also download in that same link above). Make sure the original is name correctly. In other words NLITE.INF >> NLITE.IN_ and NOT NLITETEST.INF >> NLITETEST.IN_ >> rename to NLITETEST.IN_

I tell you this because I spent 3 hours trying to find out how I f'd up! :w00t:

Link to comment
Share on other sites

I've integrated drivers on both RC6 and RC7, and there were not the same "cmd" calls that are present in RC8 even without driver integration, or any modification (tweak, patch, etc.) These "cmd" entries involve the recreation of directories, are their deletions a glitch in RC8? Thanks.

I've been playing around with it. I haven't dug out RC6 to try from scratch again.

Side question: I have RC7 and RC8 installed currently, (separate directories obviously). Are there any common files or registry entries on the host computer that would cause conflicts? I'm assuming there are not, (besides the standard software uninstall keys). Since I also use the ZIP packages without installation.

Thanks again for everybody's comments, I appreciate all the help. I've tried getting on the bug forum but haven't yet, can anyone tell me if this issue is one being addressed as a bug?

Link to comment
Share on other sites

  • 3 weeks later...

I've found the problem (I think):

Basically it haas to do with these two lines in the Nlite.inf file:

HKU,".Default\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","nlpo_07",0x00020000,"rundll32 advpack.dll,LaunchINFSection nlite.inf,nLiteReg"

HKU,".Default\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce","nlpo_08",0x00020000,"rundll32 advpack.dll,LaunchINFSection nlite.inf,S"

And with this line in Cmdlines.txt
"rundll32 advpack.dll,LaunchINFSection nLite.inf,nLiteReg"

What happens is that Cmlines is processed when actually logged on as Default User so there is a RunOnce entry made in de Default User Profile.

What is supposed to happen in the Nlite.inf files after the first person logs on is that NliteReg should be run again (?why?) and afterwards the RunOnce key should be made empty using the nliteinf,S command. These commands are actually removed from the HKU\.Default key, but when I use regedit to load the Default User hive (ntuser.dat), I notice that the RunOnce entries are still there! So whenever a user logs on the RunOnce entries are proccessed causing an Advanced Inf Install Error.

I have worked around this problem by adding these lines to the cmdline.txt:

"rundll32 advpack.dll,LaunchINFSection nLite.inf,nLite"

"rundll32 advpack.dll,LaunchINFSection nlite.inf,S"

"cmd.exe /C move /Y ""%SystemRoot%\System32\syssetub.dll"" ""%SystemRoot%\System32\syssetup.dll""

And nlite.inf I've removed these 3 lines.

What the exact problem is, I do not know. Anyone?

Link to comment
Share on other sites

I also had this problem

I used hfslip to integrade the NISTWin2kProGold.inf, and then nlited the sourcess folder, on installation everything works fine, but when I create a user, and login as user, I get the described error "advanced INF install failure"

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...