Jump to content

HFSLIP - Test releases


Recommended Posts

I have 2 other requests about hfslip, can you add support, in GuiRunOnce mode, for .cmd files?

Second request, can you add the support for copy files, as $OEM$ do? I mean if I put files in $1 directory, they'll go to %SystemDrive%, if I put files in $$ directory, they'll go to %SystemRoot% directory.

I know that in HFEXPERT directory of HFSLIP, there are WIN and PROGRAMFILES directory, but if I put one file in WIN, and this file has spaces in his name, Windows installation doesn't start, because TXTSETUP.SIF or DOSNET.INF doesn't accept files with spaces in their name.

EDIT: Tomcat I have found where the error messages are shown.

The first message (The system cannot find the file specified.) is related to KB902845 update. I don't know why this message is shown, because, when extract with hfslip script, there are 2 files (setupldr.bin and setupldr.exe), and the same result is if I extract that hotfix manually... :blink:post-109382-1170095611_thumb.jpg

The second message (The system cannot find the file 'DIR/B/A-D.)is after the copy of .cat files and before the driver.cab is extracted.


The third message (File Not Found) is when the script process the HFEXPERT directory, so I think it displays the error message because HFEXPERT/WIN or HFEXPERT/PROGRAMFILES is empty.


I have posted the image, so you can understand better :)

Edited by S3pHiroTh
Link to comment
Share on other sites

In the latest stable version there is an error in timezones update processing. I don't know if it's corrected already or not:

line 1117 - FOR /F "TOKENS=* DELIMS= " %%I IN ('FINDSTR/I "Time.Zones" TEMP\UPDATE\_TZC.inf') DO ECHO>>WORK\928388A.TXT %%I

I think you intended to write FINDSTR /R /I "Time.Zones\\ ", because without /R it ain't won't not find nothing.


note the "\\ " I added(a space is there!). This way you can use three less of those search-strings on the next line

EDIT: also I think it's not wise to write the parameters immediately after the command. I had found lots of issues, I can post some if you'd like, but maybe it's just because my cpu is buggy, or maybe it was "feature" not bug... like the above... dunno

I happen to have some issues too. I have rewritten HSLIP a bit, so it might be that i made this bug, but maybe someone can help me where look for solution:

SOURCES with FDV + HFCLEANUP +DX9 (an absolutely conservative general minimal install should be)

1, during install it pops up dirver signing dialogs (i set DELCATS).

2, many services are not removed, for example Utility Manager, which should be by Applications_AccessibilityOptions.inf, and many others. I found out that HFSLIP folder exists in WINDOWS folder, full of inf files. Now when I installed them manually by doubleclicking them, after a restart the entries in Services MMC are removed, so these infs were not processed for some reason during install. As I know the whole folder (WINDOWS\HFSLIP) should be removed by HFSLIP.CMD.

Any idea what is the cause? How does the install process goes exatly? SYSSETUP is called first, and it calls HFSLIPWUF or how? Is it possible that the whole hfslipwu.inf were not processed, or the issue might be with hfslip.cmd? Where should I start looking?

Edited by whitehorses
Link to comment
Share on other sites

If any installation INF isn't written correctly, it won't install. Sounds like you modded the script and it broke some installation INF. Sorry, I don't plan on helping with this one, there are too many variables. If it means anything, the main setup infs are sysoc.inf, sysssetup.inf, and the hfslip infs. IIRC, syssetup.inf is only processed if using hfcleanup and/or using FDV files.

Link to comment
Share on other sites

@TP - could you explain it a bit more...

1. the mistyping I mentioned is in the original HFSLIP, not my modded one.

2. I'm exactly sure there could be problems with writing the parameters next to the command. (i had one issue around hfcleanup, with a findstr i think. the one who wrote hfcleanup also knew something, since all commands there are separated for reason)

3. I understand that my problem above is not your concern in a way like if it happened with the current stable release, so I just asked for your oppinion about it.

Can you scetch the dependecies of inf files during installation? which is the root? what calls it? What is IIRC you mentioned?

By the way I don't make modifications to the script too much, just reidenting and reading it...khm and I had probably this issue for a year, long before I started thinkering the script...khm...

EDIT: Maybe I'm annoying, sorry for that. I wrote this, to be put in the end of :TZ928388 :

FOR /F "TOKENS=* DELIMS= " %%I IN ('FINDSTR /I /R "_Std.*= _Dlt.*= _Display[^_]*=" TEMP\UPDATE\_TZC.inf') DO ECHO>>WORK\TZCEXTRACT2.TXT %%I
FINDSTR /V /I /C:"South America Standard Time" /C:"Central Brazilian Standard Time" WORK\TZCEXTRACT1.TXT >> SOURCESS\I386\HFSLPHIV.INF

At least ON MY "STRANGE" COMPUTER it's working this way correctly. Maybe I'm wrong sorry for that. ;)

EDIT 2: changed to work without RegEx in the 1st and 3th line

Edited by whitehorses
Link to comment
Share on other sites


It depends on the tool if switches can be combined or not, or even "attached" to the program's name. FIND needs them separated and "detached" but FINDSTR doesn't.

/R stands for Regular expression. It should only be used if there are regular expressions in your search string.

Just to make something clear: there's nothing "wrong" with the time zone code that's there in the current final of HFSLIP; it's "working" and produces the same result as your code. But I admit that your sample is better; I reworked it a little and it's now used in version 70130b. Thanks :)

Link to comment
Share on other sites

I have the problem with the the newest test version in the text mode:




IE7_INST.EXE = 1,,,,,,,1200,0,0

I have had the same issue this afternoon when I have tried the latest version of hfslip

Link to comment
Share on other sites

Hmmm... I just don't see why...

FINDSTR/I "Time.Zones" supposed to find strings like:




But never ever will it find the string with a space, which was probably what it intended to:

Time Zones

I checked the inf file in concern manually, and at least if you want this command to find something you should not search for /I Time.Zone literally. The "." in regex means any character, including space, so it will return the line you need. Altough this works, there is absolutely no need to use RegEx here, by the way. It would be more efficent and convinient to simply write:

FINDSTR /I /C:"Time Zones"

Using regex searches is just a waste of cpu power, so I suggest only using it when neccessary.

EDIT : So it turned out that findstr takes dots as wildcards by default, and I used total commander's search when I said that I found no occurance of "Time.Zones".

Edited by whitehorses
Link to comment
Share on other sites

@TC - I see you have changed it in the newest test release. Unfortunately it wasn't quite succesfull, at least to say ;)

FINDSTR[color="#FF0000"]/VI[/color] "America.Standard.Time.Dynamic.DST...2 Brazilian.Standard.Time.Dynamic.DST...2" WORK\928388A.TXT>>SOURCESS\I386\HFSLPHIV.INF

This code is a bit different in some aspects than what I suggested, AND... beside that minor formating difference, that you left the spaces in front of the [string] section entries, by not adding that FOR in front of the last FINDSTR, ... which is not an error...

... there is one indicated with red: a missing /R. Though it's much smaller problem than it was before, since this one only just results in four additional entries in the strings section, which is harmless. But if you don't care about it, just ignore the whole line

EDIT: Sorry I will be really annoying I know, but I'm even a bit angry, because I was turned down when I said my installs are not behaving as they should. There are a LOT of such mistypings,as the above, even more serious. Call it bug or ERROR does not matter. Explain this for example:


Yes this is at the end of :CLOSURE, ("New binaries" it says) Should I be surprised if there a no "new binaries" processed when I install my shiny new Windows? I don't clearly see what's the exact results of this code, but I think it can be serious. Hasn't ever anyone noticed something strange about this?

EDIT 2: Ok here is another subject guys: EFFICENCY. Not as important as correctness and validity, but important too.


why would you write SRC1.TXT line by line to FULLSRC.TXT without making any processing on the text, instead of:


Have you tested what's the difference? Well I did! On my 1,4GHz PentiumM the second for cycle on a w2k txtsetup.sif takes 30 seconds!!!! THAT'S A LOT

EDIT 3: I did not want to offend anyone, I just want a clean install, and maybe help others to have so.

EDIT 4: here's the ... more efficent, less... script:

FINDSTR /I /B /R "[^=][color="#FF0000"]*[/color]\." SOURCE\I386\DRVINDEX.INF>>WORK\FULLSRC.TXT

EDIT: the * is needed, sorry for omitting it first

Edited by whitehorses
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...