Jump to content

[Final] XPize 4.0 MCE


XPero
 Share

Recommended Posts


Always uninstall previous versions first. Maybe in the next release I optimize the installer so you can install XPize over previous versions. But for now, uninstall previous versions before installing new one.

Thanks. Add that to the FAQ. :D

It is in the README of the installer :D

Link to comment
Share on other sites

I've just integrated Xpize into my i386 folder of my unattended cd install... Then tested on VirtualPC...

Unfortunately, I still see the old bootscreen, old logonscreen, no 128pixels icons (not even when I select large icons).

I didn't got any errors when integrating... so I don't understand why this has happened.

EDIT: did not used Xpize before!

Edited by ZileXa
Link to comment
Share on other sites

Ow djeezz how stupid of me... I didn't know bootscreen, logonscreen and settings are part of "Extra's"!

I do know how to modify files in i386 folder, so Bootscreen, Logonscreen, Screensaver and Wallpaper I can do,

and I suppose I should use the installer of TaskSwitchPro itself (T.exe in folder Windows\XPize)

But how do I add Custom Icons?

(C:\WINDOWS\XPize\FileTypeIcons)

there must be a regtweak or something to register the .ico file in this folder with the corresponding file type I suppose..

Oh and good work Xpero, Xpize is really great... every xp pc should use it!

Btw, the msgina.dll is integrated, but then one will have 2 different styles for logonscreen and for the shutdown dialog... perhaps the logonscreen shouldn't be part of extra's? Or msgina.dll not part of standard Files.. just a suggestion!

Edited by ZileXa
Link to comment
Share on other sites

I currently have this installing great from a network share during t-12. Everything seems to work great. I have it running silent with norestore set also. It would not do any good as I shut off sfc during install and also already have the uxtheme patched into my installer.

My issue is that for some reason everything seems to work accept for the style. The background and the screensaver are there the icons are correct (which look great) but the start bar is not skinned and it is using the default windows xp style. Does anybody have any ideas on this.

Link to comment
Share on other sites

i have tow program that make some problem with xpize:

1-BTS driver pack ( i will have to uninstall cmd to be able to use it)

2- avast anti virus (during the scan that happen before windows start the modified boot screen is blocking the way so i can't see what's going on).

Link to comment
Share on other sites

Where can I find the Xpize version of ntoskrnl.exe? if I check my Xpized system (installed normally with extras) system32 folder, the ntoskrnl.exe file in there is just the original one.

Same goes for msgina.dll!

I need them to integrate in my uA winxp, well, at least the msgina.dll (logoff/shutdown window).

Link to comment
Share on other sites

Where can I find the Xpize version of ntoskrnl.exe? if I check my Xpized system (installed normally with extras)  system32 folder, the ntoskrnl.exe file in there is just the original one.

Same goes for msgina.dll!

I need them to integrate in my uA winxp, well, at least the msgina.dll (logoff/shutdown window).

msgina.dll is directly patched using i386 pathing method. The ntoskrnl.exe is not patched, instead XPize adds XPize_Logon.exe to your system32 and add the following reg key.

HKLM "Software\Microsoft\Windows NT\CurrentVersion\winlogon" "UIHost" "XPize_Logon.exe"

You should do this manully in your uA install

Edited by XPero
Link to comment
Share on other sites

thanks Xpero!

EDIT:

How come, if I select Logoff in startmenu, I still see the oldfashioned colored dialog window.. :angry:

If I select Shutdown, I see the Xpize dialog window.

(msgina.dll).

EDIT: It's all working correctly now :D

Edited by ZileXa
Link to comment
Share on other sites

@XPero: yesterday the XPize thread on my site to wich you link through your download page bypassed 1000 views!

A truly great job  :thumbup

Congrats :hello:

EDIT: Yeah I know what you mean ;) but I say congrats to you cuz it seems your site is

popular. :)

Edited by XPero
Link to comment
Share on other sites

Nice work... however, I installed it on a virtual image and like to install 'some' of your modification's on a live setup. How can i extract your exe so that it does not install on top of everything.

Edited by epic
Link to comment
Share on other sites

I removed much more components this time with nLite 1.0 RC1, and now XPize does not install/show the Luna+Royale theme; everything else is replaced tough. What does XPize needs not to be removed? Some service besides the Themes service?

Edit: Uninstalling and reinstalling solved the problem. :blink:

Edited by Fox Mulder
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...