Jump to content

Need help to get ISA sound card works in Window XP


ackmangogo
 Share

Recommended Posts

Hi guys,

I got Orphues sound card with portwell ruby-9719 mobo in Windows Xp, because the limited ioport range this board can handle,
Tiido says here http://www.tmeeco.eu/TKAYBSC/RUBYISA.TXT

So I configured Orpheus sound card to use
WSS port: a34-a37
WSS control port: a38
and this works fine in DOS and Linux.

Windows xp let me chose 4 WSS port range below
0530-0537
0604-060B
0E80-0E87
0F40-0F47
all of them are not reachable for this mobo, when I tried to set port range to 0A34-0A37, I got this message

Is possible to enforce Windows XP use the a34-a37 ports.

Thanks in advance.

cs4237-xp.png

Link to comment
Share on other sites


1 hour ago, jumper said:

Also try putting the card in a different slot. XP might show different port options.

It doesn't appear to have another slot 

https://www.bing.com/images/search?view=detailV2&&mediaurl=https%3A%2F%2Fwww.prlog.org%2F10399203-portwells-ruby9719vg2ar-industrial-atx-motherboard-based-on-intel-g41-express.jpg&q=portwell+ruby-9719

 

Link to comment
Share on other sites

Just a thought, I have found that ISA boards that share the same physical positioning as a PCI card do not have frequency dividers to set back the clock frequency. A good ISA slotted board has more space between the PCI slot and the ISA slot and within this space there will be some chips. I have had much trouble with ISA cards not working with this type of motherboard arrangement.

Link to comment
Share on other sites

On 8/13/2022 at 5:20 PM, jumper said:

Check the .inf file!

Also try putting the card in a different slot. XP might show different port options.

 

Looking through cwbwdm.inf file, nothing related to i/o port.

cwbwdm.inf

Link to comment
Share on other sites

 

On 8/13/2022 at 7:05 PM, RainyShadow said:

@ackmangogo

Maybe try to boot DOS first and do the configuring there. 

Then start grub4dos using the DOS executable and chainload NTLDR to boot XP without restarting.

 

I tried program the EEPROM on sound card to set 0A34-0A37  as default WSS port, start from here, sound card configured properly already.

Freedos, Win98, Linux will take the default WSS port value from EEPROM, WInXp does not.

Link to comment
Share on other sites

6 hours ago, Damnation said:

@ackmangogo

I'm not sure if it'll make much of a difference but maybe try disabling ACPI and set resources manually.

Or set the "Plug and Play compatible OS" to "No" in BIOS setup, if this option is available. 

It would force the BIOS to configure the devices on startup instead of leaving it to the OS.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...