Jump to content

Microsoft Windows Update v3/v4/v5


 Share

Recommended Posts


23 minutes ago, xpandvistafan said:

Finally got it working on 2000, but on my 95 installation it refuses to work. No clear error in Fiddler, all 200 status code, but it fails after requesting filever.ini, I think it's invalid for Windows 95. @WinFX Any help on this?

https://drive.google.com/file/d/18SDovpwQ4JdUYkJ4ZwuxMzv4Hta5Q6Id/view?usp=sharing for Windows 95, 98 and NT 4.0 this works fine

Link to comment
Share on other sites

17 minutes ago, xpandvistafan said:

That doesn't work either. It says the ident.cab file is not a trusted certificate.

Click on Vornext Technologies and install the certificate on local computer

Link to comment
Share on other sites

6 minutes ago, xpandvistafan said:

Thanks, that now works extremely well. Unfortunately some updates do not install, what is the reason for this? 

Micro$oft removing updates from their servers.

Link to comment
Share on other sites

6 hours ago, WinFX said:

And you are using a English version or German version of actsetup.cab?

 

The German one. Windows Update v3 is fully localized and uses the one from the DE folder, it's the original file.

 

I also found out that in the v31 Content folder are interesting files in the folders with the numbers eg. 90715. Each OS and IE config uses its own folder. the files 0x000004XX.as and 0x000004XX.gng are the "Language Packs" and each language has its own inv and bm files wich is the actual catalog. If you replace the files you get different updates. I have replaced some and interestingly NT4 showed me some Windows 98 updates. 

Link to comment
Share on other sites

14 hours ago, WinFX said:

Micro$oft removing updates from their servers.

That's unfortunate, I think they only started doing this recently. We should also archive those Windows Updates still on the servers to make sure they are downloadable forever.

Link to comment
Share on other sites

16 minutes ago, xpandvistafan said:

That's unfortunate, I think they only started doing this recently. We should also archive those Windows Updates still on the servers to make sure they are downloadable forever.

The problem is that very old updates appear, like ie5.5rtm when windows 98 supports up to ie6sp1, or dx7.0a when it supports up to 9.0c.

Also for some reason wayback machine stores only up to R563 of inv and bm, coming from the middle of 2000. Although WUv3 remained open for more than 10 years there is not a single inv of R1150 archived, or at least of a close version such as R1116 or R1097 , only up to R563!

Link to comment
Share on other sites

8 minutes ago, WinFX said:

The problem is that very old updates appear, like ie5.5rtm when windows 98 supports up to ie6sp1, or dx7.0a when it supports up to 9.0c.

Also for some reason wayback machine stores only up to R563 of inv and bm, coming from the middle of 2000. Although WUv3 remained open for more than 10 years there is not a single inv of R1150 archived, or at least of a close version such as R1116 or R1097 , only up to R563!

Yeah, probably because you have old catalog files, if ones from 2011 were archived, then all the recent updates would show up. Also, on the topic on Windows Update v4, that is probably going to be much harder than v3. First off, v4 has a different mechanism, where it sends data to Microsoft and Microsoft returns the applicable updates, much like v5 and v6. But with v3, we got it working because it didn't send data to Microsoft, it requests catalog files which contain all the updates in them, and shows them in the site based on what updates you have installed. 

Link to comment
Share on other sites

1 hour ago, WinFX said:

The problem is that very old updates appear, like ie5.5rtm when windows 98 supports up to ie6sp1, or dx7.0a when it supports up to 9.0c.

Also for some reason wayback machine stores only up to R563 of inv and bm, coming from the middle of 2000. Although WUv3 remained open for more than 10 years there is not a single inv of R1150 archived, or at least of a close version such as R1116 or R1097 , only up to R563!

We need a way to edit the catalog files and fill in the new updates. But I don't know how the files are encoded, not a lot of information is available for inv and bm files, sadly.

Edited by ByQuadCore
Link to comment
Share on other sites

Well that's interesting, the IE 5.01 web installer still works. I would have thought that they deleted the files for that years ago. But IE 5.5 from v3 doesn't work because of 404. It's interesting that they don't remove IE 5.01, but they remove 5.5.

Link to comment
Share on other sites

16 hours ago, WinFX said:

So, after some trying, I keep getting a can not display page error. I'm trying it on windows 98SE. Could Windows 98FE be a solution? Trying fiddler also doesn't work... as it needs Windows 2000 and up..

Link to comment
Share on other sites

3 minutes ago, Sanvahu said:

So, after some trying, I keep getting a can not display page error. I'm trying it on windows 98SE. Could Windows 98FE be a solution? Trying fiddler also doesn't work... as it needs Windows 2000 and up..

On Windows 98 it only works in English with IE5.01, not 5.5 or 6.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...