Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Annoying search column problem in XP


justacruzr2
 Share

Recommended Posts

The answer to the question that I have seen asked before, including myself, that Explorer doesn't save the column settings in search results is that you have to give yourself a password, then logoff, shutdown the computer and then restart.  I know that most of us are the sole user of our computer so why bother with setting a password but it does work.  I came up from the 9x series and didn't bother with a password either.  I just liked booting in and going but it's a tradeoff I'm willing to do since I usually do searches many times in a session but only have to enter a password once.  Found the solution when I did a clean install on another computer.  Hope this helps.

Link to comment
Share on other sites


This has always been an annoyance for me. Why does it save all the other column settings, including in the Recycle Bin, but not in Search results?!
I do have a password though, although Windows is set to log on automatically.
It's not saving them for me.
:dubbio:

Link to comment
Share on other sites

On 11/19/2021 at 6:21 PM, Dave-H said:

This has always been an annoyance for me. Why does it save all the other column settings, including in the Recycle Bin, but not in Search results?!
I do have a password though, although Windows is set to log on automatically.
It's not saving them for me.
:dubbio:

The best I can figure is that the programmers felt that the search result column settings were a personal setting and not a global setting.  Two other thing I noticed is that 1) the list of users is different between User Accounts in Control Panel and the Users and Groups folder in Computer Management.  For me that might be because on this computer (I have 2) I installed XP over Millennium and the XP install gave me an account called Default in Documents and Settings and 2) when I left clicked on the Administrator account in the Users and Groups folder of Computer Management and I got the "What's This" pop-up, I decided to click on that just to see what it would say and it gave me an interesting piece of information.  That the Administrator account is not shown on the welcome screen if there are other user accounts.  Didn't know that.  For me that means because I have the account called Default and also am shown as the Administrator too, when I log on I am logging on as Default...not the Administrator even though it uses the same password for both accounts.  Currently, now that I know  this,  I am trying to figure a way to change this without losing all my personal settings.  I already tried deleting the Default account and shutting down and reloging in as the Administrator and that part worked but it created a new folder under Documents and Settings called Administrator (which I expected) but my personal settings were lost.  I did do a backup before this so I am back to where I was before this experiment.  I did see the identifier it gave the Administrator account in the registry and I'm going to try a little registry trick of renaming my Default  account folder (not the .DEFAULT  folder) with the Administrators identifier (if the Registry Edito doesn't complain about this) and see what happens.

 

Link to comment
Share on other sites

OK, I guess I should explain this better.  You have to be logged in as the Administrator.  If you have any other user accounts they have to be deleted because Windows does not show the Administrator account on the Welcome screen if there are any other user accounts.  You also have to turn off the "Guest" account.  You can check this in Computer Management under the "Local Users and Groups" folder.  The Administrator account must also have a password or you don't get the logon Welcome screen, just the regular Welcome screen.  I have no idea why they did it this way since how can you log in as the Adminstrator without it being shown on the Welcome screen?  And as soon as you put back the other user accounts (if you have any) the Administrator account is again not shown.  Some sort of catch 22.  My situation is a little different than a clean install because I copied Millennium onto the drive that I was going to use for the XP install.  I did this because I thought it would be easier for me if the install took as many settings as it could from Millennium and that would save me some time re-doing all those settings in XP.  Because I did not have a user account in Millennium, the install created a default user account call "Default" in Documents and Settings.  In the "Local Users and Groups" folder on my computer in the users folder is listed "Administrator - Built-in account for administering the computer/domain", "default - Account upgraded from Windows Millennium Edition" and "Guest - Built-in account for guest access to the computer/domain".  So when I did all the above things I was able to set the columns the way I like them and it has stuck ever since.  

Link to comment
Share on other sites

3 hours ago, jaclaz said:

Awesome.  Thanks for that bit of info.  Doesn't make sense the way they did it though.  Maybe they thought some other user might try to logon as the administrator.  But they would have to know the password anyway.

Link to comment
Share on other sites

I believe that when they took Windows 2000 and bastardized it for the masses[1] they thought that it was a good idea to have a (hidden and by default passwordless) built-in administrator account accessible in Safe Mode only, and - as a matter of fact - I think it saved countless reinstalls.

So, while making little sense (there could have been tens of better ways to provide a similar mechanism) it does make some, in organizations, the Administrator account would be protected by a password (set by the IT people) but the account would remain hidden, and the user (coming from a Windows DOS/9x/Me) would have only "self" to choose at logon.

jaclaz

 

 

 

[1] Consider that in those times noone,  and I mean noone outside an office or organization had network nor any need for authentication of users (which 99% of the time was only one) so that the DOS/Win9x/Me world was effectively "passwordless" and "all users are admins".

Link to comment
Share on other sites

A very plausible explanation.  Tried the method you suggested last night and that works a lot better than deleting or disabling all other user account to get the Admin logon.  Also found out that my other idea works.  I used File and Settings Transfer Wizard to copy all the settings from my "Default" user account to the "Admin" account in Docs and Settings and saved a lot of time resetting all those things.  Learned a couple other things too.  The S-1-5-21 accounts with the 25 digit long identifier in HKU are, by the looks of it, dynamically loaded into the registry according to the user that is logged on.  That goes for HKCU too.  After all this time I'm still finding new things out about XP.

Link to comment
Share on other sites

10 hours ago, jaclaz said:

... in organizations, the Administrator account would be protected by a password (set by the IT people) but the account would remain hidden, and the user (coming from a Windows DOS/9x/Me) would have only "self" to choose at logon.

Organizations, though, would generally be running XP Pro to log into a network domain, and its logon screen is different: you type your user ID rather than selecting it. In that environment there's nothing to stop you from typing "Administrator" if you know the password.

Link to comment
Share on other sites

My user account is the administrator account on the machine, and it's renamed to "Dave".
The Guest account is disabled.
There are no other accounts.
I have a password set, but the system is set to automatically log on with it so I don't have to enter it.
My "Search" window columns' settings are still not being remembered, I wish I knew why.
:dubbio:

Link to comment
Share on other sites

On 11/25/2021 at 7:52 PM, Dave-H said:

My user account is the administrator account on the machine, and it's renamed to "Dave".
The Guest account is disabled.
There are no other accounts.
I have a password set, but the system is set to automatically log on with it so I don't have to enter it.
My "Search" window columns' settings are still not being remembered, I wish I knew why.
:dubbio:

Go to Local Users and Groups in Computer Management and click on Groups.  You will see a list.  Click on Adminstators and see what it shows you.  If it shows Adminstrator and then you "Dave" then you are not the top Administrator.  It seems strange but only "THE" Administrator gets that priveledge and not just "A" Administrator.  Could be an oversight when coded.  That was the same way it was on my system until I made myself "THE" Administrator.  Also, if you have not done so yet, click on the link Jaclaz provided above for instructions on how to make "THE" Administrator account appear whether or not there are other users.  When I did that and then logged in under that account, the columns I like to use appeared automatically.  Thanks again Jaclaz for that link.

Link to comment
Share on other sites

Dave, here's some additional information.  After you do the registry entry reboot.  Depending on whether you gave your "Dave" account a password already you will either see the Logon welcome screen or the plain welcome screen.  If you had a password already logon to that account and the go to settings/control panel/user accounts.  Give THE Administrator account a password and if you haven't done so already your "Dave" account too.  Tip: use different pictures for both of them because on the Logon welcome screen the description will be the same and without different pictures you will be unable to tell the difference between the two.  Reboot again and on the logon welcome screen logon as the Administrator.  This is when the Administrator folder is created in Documents and Settings.  You will be a little disappointed at first because the account will not have your settings.  Now logoff and logon to your Dave account and go to Files and Settings Transfer Wizard.  Choose this as the computer you want to transfer files from. On the second panel use the "other" option where you can choose the "Dave" folder as the source and the destination folder you want to save these settings in.  Now logoff and logon as THE Adminstrator.  Reverse the process by choosing this is the computer you want to transfer files to.  The rest you can probably figure out yourself.

Link to comment
Share on other sites

9 minutes ago, Dave-H said:

This is what I've got in those settings.

Image1.thumb.jpg.4567df0e68911ad8f92808568d1d2d89.jpg

:dubbio:

Hi Dave.  Can you wait till Monday as I'm walking out the door from work and can't access MSFN from hime.  Sorry.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...