Jump to content

Specific application needs JRE v1.7 in XP Pro to run but JRE won't install properly


Recommended Posts

I have a specific application that controls an external device (not PC related) that needs Java RE v1.7 to work. Apparently between Oracle & M$, compatibility/support seems to be a issue with XP probably making matters worse. Oracle calls this v1.7, "7" adding to the confusion.

Initially, in my older Wintel Gateway Notebook this did not install properly.

I did some further testing. I tried installing this in my somewhat newer AMD based HP ProBook and it installed/extracted properly.
What I did this time was to install JRE first, then the devices program.

Then I went back to the problematic Gateway Notebook, uninstalled the program and started from scratch, installing JRE first. Same thing, it didn't extract fully.

What I'm referring to is in the JRE installation folder, all that is there is a single 0kb file and a "core.zip" folder. Nothing else. What should be there are a few text files, a welcome html file and two folders "bin" and "lib".
I opened (unpacked) this 'core.zip' folder and those other 2 folders were there, both full of files (590 to be exact). I manually extracted the core folder, but since it wasn't in the installation 'mode', whatever is placed in the Windows folder (or wherever the .dll's etc are placed it didn't happen.

I hope I explained it correctly, lacking some technical terms.

Ok, the question now is, since both computers are running the exact same XP Pro w/sp3 O/S, why the difference (other than the MB's chipsets)?

Edited by videobruce
Link to comment
Share on other sites

@Dave-H When did you get that new banner under your pic?! Congrats :P

Maybe you could add a short summary in the first post there? Or at least few links to the revelant posts?

I asked dencorso before, but maybe they didn't notice...


I'll too have to try updating my Java install soon. Currently got three JRE versions listed in the Java .cpl , but whenever i try running some test applet in a browser, the launcher just hangs.

Also, recently i got few Arduino, ESP32 and ESP2866 boards to play with. The IDE runs in its own Java bundle, but maxes my CPU constantly on XP. Same executable works fine in Win7 without any excessive CPU usage, but rebooting just to use it is kinda pain in the ***

Edited by RainyShadow
Link to comment
Share on other sites

The Java version I'm using on XP is Java 8 Update 251.
That works fine (with a manual install, the installer hasn't worked on XP for ages) but needs one incompatible file (sunmscapi.dll) replaced from the previous version.
Other people have had later versions working, but it's a lot more work, and personally I didn't think it was worth the trouble!
Current versions are completely incompatible with XP AFAIK.

I'll look into clarifying the first post of the main thread about it.

Link to comment
Share on other sites

I have already changed the thread title to perhaps be a bit clearer as to what the thread developed into.
The first post was actually about a specific issue with Flash six years ago, and I think the thread only developed into a more general reference thread for Flash and Java later.
As it was @dencorsowho actually first posted in that thread, maybe he can see how his first post could now be modified to better reflect the present purpose of the thread.

Link to comment
Share on other sites

@Dave-H: be my guest & feel free to modify any the post you mentioned as you see fit. Of late, I've been getting in my plate far too many nuts to chew for confort, so sorry, I just cannot attend to it myself, at present. :(
I guess you might split the thread from the point it became more general and let the specific stuff + the OP in a separate thread that'll sink as soon as it's split off. Or, even better, split it just before your own 1st post there, so that you'll become the new OP at the new thread and can give it proper care. :angel

Link to comment
Share on other sites

FWIW, none of those versions I tried worked. They 'install' but the installation is corrupt with a single .exe file & a "core.zip" folder that doesn't get extracted.  Even after I manually extract it, the program still complaints about a corrupted install. I tried 4 or 5 different versions, they basically all do the same thing.


If you want all the (unnecessary) details of the situation (that shouldn't of mattered in the 1st place);

That was a Wintell 'Atom" Gateway Notebook.

I'll try my AMD HP 'Laptop' and see if that is any different (still XP Pro) that I've had form years with NO need for JRE. I also have a much larger AMD Toshiba Laptop that has Win7 and the program w/ JRE v1.7 working fine, but it's large for the space where it would have to sit to connect to the device intended which is why I wanted to use a smaller solution in the first place.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...