Jump to content

Solitaire crash


Recommended Posts

 Microsoft´s solitaire game opens in this computer and immediately crashes.

The system message is:


Problem signature:

Problem event name: APPCRASH

Application program name: Solitaire.exe

Program version number: 6.1.7600.16385

Program time/date stamp: 4a5bc9f9

Failed module name: igdumd64.dll

Module version number:

Module time/date stamp: 4aba758c

Exception code: c0000005

Exception offset: 0000000000070c62

Operating system version: 6.1.7601.

Place identification: 1046

Additional information 1: cfa9

Additional information 2: cfa960e6b4c4547a2e547d51c23416cb

Additional information 3: d3b9

Additional information 4: d3b9a87ac727b849c019f7ad661c15c0



Would anyone help to find the cause and solution of the problem?

If it cannot be perceived in the signature, the operating system is 64-bit Win 7 Pro.

The game files came with the O/S, but were installed  later.


Link to comment
Share on other sites

I'm not sure what the problem might be although it obviously concerns that igdumd64.dll. It is apparently an Intel Graphics Driver DLL - do you have problems launching any of the other MS Win7 games? If so it might be problem with that DLL or the driver itself which will have to be addressed. I can't give any advice on that.

The games which come with WIn7 are located in C:\Program Files > Microsoft Games so I'd go to that folder and click on the Solitaire EXE to see if it works from there. If it does then its probably a shortcut/start menu (Games) shortcut issue and you just need to replace it/them.

Do you have the original installer you used or do you mean you just had to enabled the Win7 Games 'feature' from the Control Panel. That's normal; for whatever reason the Win7 games are not enabled by default.  

If it is still not working then I'd run system file checker and then chkdsk . I doubt either will fix the problem but it might worth trying.

Do you have the original Win7 installer disc? If so you may be able to find the games folder on there and get Solitaire out of that and simply replace the existing copy.

I thought it might be possible to use a Win7 games installer for Win10 download to get the game's folder and EXE for Solitaire. Whilst it is possible to extract it, actually quite easy, I've tried several things and couldn't get it to launch on a Win7 64bit Pro PC.

So it appears you need someone to share an original Win7 version of the particular game's folder/EXE because the only other solution I've seen suggested is to reinstall Windows 7 completely. :(

Of course there is no guarantee doing any of that will fix the problem if it is a graphics driver or DLL problem.

Link to comment
Share on other sites

I got two other versions of igdumd64.dll, but installing one seems more difficult

than just replacing one for other in C:\Windows\System32.  If I do this, the display

still works the same ( igdumd64.dll is an user, not a system .dll ), but Solitaire fails

to find a display driver and does not open . If I replace the video driver using the

control panel ( there is another compatible driver in the list ), then replace

igdumd64.dll, then return to the Intel Express Q963/965 chipset driver, (with the

proper system restarts in between) the system restores the default version of


 BTW, I have always launched Solitaire from its file, never used a shortcut.

          The only other game I tried yet is Tetris, and it works OK.


Link to comment
Share on other sites

 More info:

I tried other card games and each one failed the same as Solitaire.

 As WalksInSilence guessed, I enabled the games using the Control Panel.

They are not new versions.



Edited by jassenna
Link to comment
Share on other sites

  • 2 weeks later...

If the stable driver that would run this game doesn't exist or Win7 bundled games are the only applications utilizing 3D hardware acceleration that are of concern, I suggest downloading dgVoodoo2 (look under Latest stable version). Alternatively, download it from GitHub, author's own site has been often tagged by Google Safe Browsing due to anti-virus software considering his software malicious.

In the downloaded ZIP file, run extract and run dgVoodooCpl.exe. Make sure Config folder is set to something like C:\Users\YourName\AppData\Roaming\dgVoodoo and minimize it.

Then, in the ZIP file, navigate to MS->x64 and extract D3D9.dll to C:\Program Files\Microsoft Games\Solitaire. Try the game, it should launch normally and you'll see dgVoodoo watermark in the lower-right corner, which may be disabled with the dgVoodoo Control Panel on the DirectX tab (apply settings after change).

If it doesn't work, try changing Output API on General tab to Direct3D 11 MS WARP (software), though I guess that in your case, nothing but WARP option and Best available would be available, in which case Best available translates to WARP anyway. At least in the past, dgVoodoo2 didn't work in VMware virtual machine without explicitly selecting WARP, because while some D3D10 support existed in its graphics driver, a certain needed feature didn't.

The control panel may be closed when you're happy with the configuration.

Edited by UCyborg
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...