Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Who's still using Win9x on the web besides me???


ZortMcGort11
 Share

Recommended Posts


Wunderbar98 said:
> https://o.rths.cf/gpc/files1.rt/rzbrowser-tls12-20180504.7z
> Unfortunately this link is down.

Yes can be, he mentioned in the XP topic that the server will be down temporarily for an unknown while.
But while offline, you can get it here:
https://web.archive.org/web/2020/https://o.rths.cf/gpc/files1.rt/rzbrowser-tls12-20180504.7z

EDIT:
my fault, links was for old domain! cf => ml
https://o.rths.ml/gpc/files1.rt/rzbrowser-tls12-20180504.7z

Edited by siria
Link to comment
Share on other sites

Oops... I had copied an old domain link! The correct one works, no prob.
Since RT likes to update files without changing date in name, better download again directly:
https://o.rths.ml/gpc/files1.rt/rzbrowser-tls12-20180504.7z

and major OOOPS-2:
waybackmachine: am realizing only now that every call to "web.archive.org/web/2020/http" without a COMPLETE specific date creates a NEW SAVE action?! :blink: Slightly in shock now.... where have I posted such links... uh oh...
Then again, not sure, perhaps not... must investigate further...

But glad you're having fun with DOS games :D
I'm not into games at all, but probably contributes that I don't even know what I'm missing, never seen, lol!

Edited by siria
Link to comment
Share on other sites

On 9/27/2020 at 4:06 AM, ZortMcGort11 said:

I used Opera exclusively for about 7 or 8 years... from 2010 until 2017? Then it just went to total crap. Endless popup windows and certificate errors that don't go away even after I click the okay button. It's unusable.... worse than Firefox 2.

It looks like Opera has been compromised. It can happen if you download old drivers or the like that turns out to be fake or has malware and you open it. Also the web sites have became more complex and downloading to check certification can take longer the first time so you do not want to click on accepting any and what should happen Opera will eventually clear certification. It can bring up the red notification though in the interim of the checking process. You also need to restart your machine to get the Opera error correction implemented from a crash and you need to start without that page/tab that caused the problem. Having just a modem has no port blocking and leaves your computer vulnerable if any port can be opened. I needed Port Blocker software on Win2K professional as it was designed to be a corporate server and most ports were open. There were huge IP addresses wanting to access. If you can borrow a friends Win10 machine you can connect both locally via a switch will do off-line then you can make your complete Win98 C: drive shareable and navigate throughout the 98 machine from the Win10 machine, it will pick up on malware. Win10 must have Windows security enabled and running. It is more difficult though to get shares going on a local area network with Win10 especially when the OS was setup a to a Windows account at first. My best success Win10 share linking is from Win10 to Win 7 but not Win10 to Win10. Media share is easy though. Registry browser add-ons will need to be checked and this can be accessed by software on the Win98 machine. You cannot be locked out of parts of the registry from malware with Win98 which is good. It might just be in your Opera profile that the malware is located and deleting Opera profile could fix this. Opera needs the TLS1.2 enabled manually, it has turbo settings and add blocker but from what you have explained - it should not happen. Being on dial-up an ISA modem is better than the newer PCI cards in that the software did not check for line speed on dialing in. They can go a lot faster than the exchange allowed and our exchange cut speeds to half if the speed limit was exceeded. Getting drivers for them can be impossible though, they are not all out there. I emphasize with you and others who need to use dial-up. I had return to it as a backup and had it running on Vista. It was terribly slow so I gave up and cancelled the account about 8 years ago.

Link to comment
Share on other sites

Hi @siria, works well though my system is no longer Mozilla virgin, previous installs of SeaMonkey, Firefox and RetroZilla. The browser download link you provided identifies as Firefox Community Edition. The executable is 'firefox.exe' and is based on Firefox v2.0.0.2. In about:config 'general.useragent.extra.firefox' with value 'RetroZilla/2.0.0.2'.

First run creates profile pathway C:\WINDOWS\Application Data\Mozilla\Firefox\Profiles, although it also creates a blank C:\WINDOWS\Application Data\RetroZilla directory, query potential conflict with concurrent use of other RetroZillas. The ssllabs site confirms TLS v1.2.
https://clienttest.ssllabs.com:8443/ssltest/viewMyClient.html

Nice browser but only briefly tested. Since it's already branded Firefox Community Edition, maybe an appropriate member project title if someone wants to start this with extra content for add-ons, updated search engines, etc.

Edited by Wunderbar98
Link to comment
Share on other sites

Hi @ Goodmaneuver


"Having just a modem has no port blocking and leaves your computer vulnerable if any port can be opened."

I use Tiny Personal Firewall with maximum security setting, and according to the Gibson Shields-Up Firewall test, all the ports appear closed.

It just seemed like every website I visited with Opera required the certificates to be validated again and again, even after I already told it to ignore the certificate error, it would keep reminding me. Opera just seemed really buggy. I tried fresh installs too... but no luck.

K-Meleon 1.7.0 simply works MUCH better on my system than Opera. And now I'm also able to use Netscape 9 with TLS 1.2 support so I'm pretty happy about reading Wikipedia again! Retrozilla (also with TLS 1.2) is working great as well.

I got some free time, so I'm gonna try a few more of the browsers you guys listed here!

PS
I didn't get the K-Meleon 1.5.4 TLS 1.2 package to work, it said some files were missing.

Link to comment
Share on other sites

Wunderbar98 said:
First run creates profile pathway C:\WINDOWS\Application Data\Mozilla\Firefox\Profiles, although it also creates a blank C:\WINDOWS\Application Data\RetroZilla directory, query potential conflict with concurrent use of other RetroZillas. The ssllabs site confirms TLS v1.2

Thanks for testing! It really should work in Win98, being Firefox2, but always good to have confirmation.
AppData-Retrozilla is IMO probably no conflict, just mighty confusing. Since this older rzbrowser-version writes into AppData-Firefox, and the younger rzbrowser-version (which identifies itself as RZ) writes profiles into a special subfolder "RetroZilla/browser/". But really completely confusing this version chaos.

ZortMcGort11 said:
K-Meleon 1.7.0 simply works MUCH better on my system than Opera.

Too weird. Complete opposite for me, and always has been, so am still very suspicious of your system too. Opera12.02 had a much advanced engine and also a lot better ciphers as (badly buggy) KM1.7alpha. Whenever I had no access to a site 2-3 years ago with KM and then tried Opera, it got in without probs. When I needed a younger complicated function (think reCaptcha etc.) Opera was shining, and zero chance with KM1.x. Old Opera only started failing too when Google finally forced the whole web to kick older browsers and systems out. At any rate I think it's not normal that Opera engine is worse as in KM1.x. Perhaps your new installs just adopted the old profile, or whatever, no clue... What's also reported quite often, that personal security tools were found culprits for "weird" profile probs, especially infamous is CCleaner. And such tools tend to automatically find well known popular browsers, but have no clue of KM. Can be anything.

But my heavy dislike of KM1.7alpha comes mainly from the broken macros plugin, being a huge macros fan. So don't have much practical experience, only used it as occasional fallback browser many years ago - and it usually failed even then. Especially if old ciphers were blocking site access.
And all the years until finally KMG74 appeared I was only struggling like crazy hundreds of hours with KM1.7 macro plugin bugs, and with KM1.5.4 stoneage engine+macros functions, trying to get my published macros running in those nightmare versions too, and KM1.7 being the "last" Win98 version. Cursing and trying to figure out complicated workarounds, but usually just a huge waste of time and rarely success. I realize I'm not quite a typical user, but still feels weird if someone finds them great ;-)

ZortMcGort11 said:
didn't get the K-Meleon 1.5.4 TLS 1.2 package to work, it said some files were missing.

Yeah sure, but easy to fix. As already explained here on page-1 (look for "KM154" and a few lines below about Fx3.6)
https://msfn.org/board/topic/181912-whos-still-using-win9x-on-the-web-besides-me/?do=findComment&comment=1188096

But overall, Retrozilla and KM1.5.4 are of the same age as Firefox2, this alone causes huge probs already. Very crucial functions still missing (e.g. no wrapping of endless long strings, and no document.querySelector yet), and same prob for macros plugin, crucial functions missing (injectJS-return etc). Internally KM1.6 is already a lot better, even if not at first look, but if websites are messy macros have a lot better chances to use workarounds.

Luckily you have KernelEx too and are not stuck at FF2 level :-)
.
Edited by siria
Link to comment
Share on other sites

7 hours ago, ZortMcGort11 said:

Gibson Shields-Up Firewall test, all the ports appear closed

That is good, WinME had all ports closed too and I assume 98 has well but it is best to check and I used GRC.com too. They have a lot of information about security as well, presented in entertaining talk sessions. The certificate first time certification or after the signings have changed may take a long time as emails and other pages updating will contribute to the slowness but anyway it will take minutes to clear, if on dial-up give it many minutes. In fact forget about that page and surf a different web address in a new tab, that's what I did, but not too many pages can be open at once for you will run out of RAM. I have not told told Opera to ignore the certificate error. My Mozilla browsers work best here as I get full width on my newer ME builds with the default profile view setting but when I go to post, the drop down does not happen but does for pictures but no text, for example, if I go to edit a post with a picture the picture appears in the drop down but no text. I think it is a registry setting that's not there or not correct.

Edited by Goodmaneuver
OT of course on dial-up
Link to comment
Share on other sites

ZortMcGort11 said:
I'm using Firefox 3.6.28 Community Edition (TLS 1.2 support) as I type this. It works great too!!

Great :-)
Actually now remembered that the last version for Win98 with basic KernelEx v452 was Firefox10, acc. KernelEx wiki, but when I tried this as fallback many years ago it was just about unusable on my computer, extremely slow and freezy and crashy. Only years later learned that Firefox9 should work much more fluent, but at the time had finally heard about Opera12.02, which was much more advanced already, so never really tried Firefox9 anymore. But pity that FF10 was so problematic, since lots of important new engine features, JS+CSS, were introduced with version FF10.
And now wonder if roytams TLS-package for Cometbird9+10 would work in FF9+10 too. Perhaps will test when getting around, but not now...

-------

And just discovered something else, the handy ancient addon PREFBAR which I always assumed needed at least Firefox version 3.5 (=useless on vanilla Win98), actually has older versions available too. Didn't realize earlier, since on official AMO page the oldest version always started with "min Firefox 3.5", but now see the addon-homepage still hosts even the oldest 0.x versions, way back to 2003!

Here are some screenshots to get an idea what it's about:
http://prefbar.tuxfamily.org/screenshots.html
Or less scary, early versions from 2010 for Retrozilla, Firefox2 etc (wayback archive):
https://web.archive.org/web/20101004180100/http://prefbar.tuxfamily.org/screenshots.html
Mainly it can create toggle buttons for javascript and other stuff (like in K-Meleon PrivBar, have once read it were based on PrefBar), and it has a UserAgent switcher build in etc.

Or extend it with yet more buttons with all sorts of powerful actions (e.g. for taking screenshots of whole page, making lists etc., similar macros/userscripts):
http://prefbar.tuxfamily.org/buttons.html
Since v6 the button code changed from "xml" to "json", but older buttons are still available HERE
Overall highly flexible and customizable.
There's also a long forum topic for it on MozillaZine

Don't know if this special button system existed already in v4.3 (for vanilla98), but the core functions are already nice, and it's quite rare to find addons which work in ancient SM/RZ too.
Actually there's another very similar addon, named "Custom Buttons", but acc install.rdf only works in Firefox, not SM/RZ.
I find both very interesting, but have no own experience. Only used PrefBar in FF2 for a short time until getting younger fallback browsers.

Download page for old versions:
http://prefbar.tuxfamily.org/archive.html
v4.3.2 install.rdf says it's for Firefox 1.5+ and Seamonkey 1.0+ (=should work in Retrozillas)
v5.x needs Firefox 3.0+, but Seamonkey must be 2.0 already
v6.x needs Firefox 3.5+
v7.x needs Firefox 4.0+, and Seamonkey at least 2.1+

Archived AMO pages:
https://web.archive.org/web/20171227123958/https://addons.mozilla.org/en-US/firefox/addon/prefbar/
https://web.archive.org/web/20180730050933/https://addons.mozilla.org/en-US/firefox/addon/prefbar/
https://web.archive.org/web/20180730050932/https://addons.mozilla.org/en-US/firefox/addon/prefbar/versions/

FIX if installation of SIGNED Addons doesn't work:
younger versions contain a Mozilla SIGNATURE, which is in folder "META_INF", and also referred to inside install.rdf. Luckily many alternative browsers allow to install addons without signatures (or even can't handle them at all)
HOWTO modify the xpi: make a backup copy of the original file, then open the XPI with with 7-zip, right-click on folder META_INF and remove whole folder. Perhaps also click on install.rdf to EDIT, and adjust text inside (not signed anymore). Do NOT save, instead CLOSE it by X in upper window corner => now 7-zip will ASK if you want to save changes - NOW save it. Close 7-zip with X, again it will ask - now save.
.
Edited by siria
  • Upvote 1
Link to comment
Share on other sites

On 9/30/2020 at 11:36 AM, Gansangriff said:

Recently I had a voice chat over an open Teamspeak 2 server with a mate, who used a modern Windows 10 laptop! What a bridge between technology, gapping 20 years! If you know your old tools well since plenty of years, you're very powerful with old computers.

This is actually amazing lol, and yet another reason I find Discord's murdering of TeamSpeak, forums etc everywhere more than loathsome... (then again if users aren't willing to find info outside Discord and Twitter, are they actually worth having on a forum/IRC? Maybe it'll help quality control in the long run.)

HTTP deprecation everywhere seems to be a tactic to scare older devices users into upgrading, which could explain Google's insane pushing of it in 2015 and beyond.

Edited by MintChocAero
Link to comment
Share on other sites

@Wunderbar98

Hi, yes they are posted at the very bottom under "web browsers". There's 2 different browser areas on my site... one is for KEX browsers only, then further down the page is for "vanilla" browsers.

I haven't uploaded anything to my website yet, got all the links DONE, but until I get on a faster computer connection it won't be finalized.... hopefully sometime this week!!!


@ Siria

Those are cool screenshots, thanks. I was looking at the SeaMonkey PrefBar, and that's pretty cool.... very much like K-Meleon. I'm gonna see if that works in Retrozilla. Thanks.

Link to comment
Share on other sites

Earlier in this thread someone posted a link to rzbrowser-tls12-20180504.7z.  I had already downloaded and installed that package in Sept 2018 so I don't know if there's anything newer.  I still use FF2 on my win-98 system and haven't really experienced any reduction in usefulness over the past year for the sites I visit.  One thing that has been a downer for me is that I somewhat often use https: //bgp.he.net/  with Opera 12.02 and at some point a week or two ago that stopped working.  I can bring that page up in FF2 but when I enter an IP to check I get a "this site requires javascript so please turn it on" message (and I'm pretty sure I have it turned on).  If anyone can perform an IP lookup on bgp.he.net using any browser running on win-98 please tell me.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...