Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

[WIP] Windows Vista Extended Kernel


win32
 Share

Recommended Posts


On 11/4/2021 at 7:09 PM, Vistapocalypse said:

Do you have BSODs before you install the antivirus that I think might be Webroot, or only after??

the bsods happen on fresh installs of both vista and server 2008. and continues to happen unless i have windows in debug mode. in fact it starts happening happens before the 2nd part of setup after the first reboot from Windows PE. so yeah they happen before i install anything. including the extended kernel. i think i mentioned it before. but i also had this problem on another uefi capable machine

Edited by ScrapMechanicFan2016
  • Upvote 1
Link to comment
Share on other sites

Today i tried Firefox 91.3.0 ESR on Windows Vista with the new extended kernel. It looks like there is some problem with font rendering... (Same issue with Firefox 94, Firefox 78 works fine)

1164079647_firefoxfont.thumb.JPG.ac87e77e855a884ecb12321d140f7558.JPG

Does anyone know how to solve this?

Edited by TSNH
91.3.0 not 93.3.0
Link to comment
Share on other sites

22 minutes ago, Jakob99 said:

Does anyone know if .net framework 4.8 works under Vista? If so, how do I get it working.

Installation is possible, but I would advise against it because you will get missing dependency errors with .NET software that should work on vanilla Vista (see this May 17, 2019 post). Unless you simply must test some program that specifically requires 4.8, you would get better results with any lower 4.x version.

  • Like 2
  • Upvote 1
Link to comment
Share on other sites

1 hour ago, TSNH said:

Today i tried Firefox 91.3.0 ESR on Windows Vista with the new extended kernel. It looks like there is some problem with font rendering... (Same issue with Firefox 94, Firefox 78 works fine)

1164079647_firefoxfont.thumb.JPG.ac87e77e855a884ecb12321d140f7558.JPG

Does anyone know how to solve this?

I believe the previous extended kernel had the same issue. Aside from sticking with Firefox 88 or below, you could try the hex edits in win32’s September 11 post. Edit: Next post suggests that this advice no longer applies.

Edited by Vistapocalypse
  • Like 1
  • Upvote 1
Link to comment
Share on other sites

Just now, Vistapocalypse said:

I believe the previous extended kernel had the same issue. Aside from sticking with Firefox 88 or below, you could try the hex edits in win32’s September 11 post.

Thanks for reply. It looks like i had a spelling error in my osver.ini file.

image.png.80a4466a8edc40240cf423ddc2567a64.png

No hex editing is needed!

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...